<!DOCTYPE html><html class="no-js mh-one-sb" lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /> <noscript id="aonoscrcss"></noscript><title>&#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221; &#8211; Kichuu</title><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; &#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221; Comments Feed" href="https://kichuu.com/yaa-marqaa-si-afuufuun-si-liqimsuufi/feed/" /><!-- <link rel='stylesheet' id='wp-block-library-css'  href='https://kichuu.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/cache/autoptimize/css/autoptimize_single_4bc19d35d9e5befbc0d4ac845aab7f5b.css?ver=5.4' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/cache/autoptimize/css/autoptimize_single_617c65fef3747d563db91bb13aa7bf68.css?ver=1.7.5' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/cache/autoptimize/css/autoptimize_single_99db444516eac8eeb6d4917ae34d2191.css?ver=3.9.8' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/pfkb096/2lnqh.css" media="all"/><link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' /> <script src='//kichuu.com/wp-content/cache/wpfc-minified/33alo9g4/ab99k.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://kichuu.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> -->
<!-- <script defer type='text/javascript' src='https://kichuu.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> --> <!-- <script defer type='text/javascript' src='https://kichuu.com/wp-content/cache/autoptimize/js/autoptimize_single_c46dd8af747321bc408cc73d09d12b54.js?ver=3.9.8' id='mh-scripts-js'></script> --> <link rel="https://api.w.org/" href="https://kichuu.com/wp-json/" /><link rel="alternate" type="application/json" href="https://kichuu.com/wp-json/wp/v2/posts/89509" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /><link rel="canonical" href="https://kichuu.com/yaa-marqaa-si-afuufuun-si-liqimsuufi/" /><link rel='shortlink' href='https://kichuu.com/?p=89509' /><link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F" /><link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&#038;format=xml" /><style type="text/css">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</style><!--[if lt IE 9]> <script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css">.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }</style><style type="text/css" id="custom-background-css">body.custom-background { background-color: #e5e4e2; }</style><link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-32x32.png" sizes="32x32" /><link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-180x180.png" /><meta name="msapplication-TileImage" content="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-270x270.png" /></head><body id="mh-mobile" class="post-template-default single single-post postid-89509 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="mh-container mh-container-outer"><div class="mh-header-nav-mobile clearfix"></div><div class="mh-preheader"><div class="mh-container mh-container-inner mh-row clearfix"><div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix"><nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li><li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li><li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li><li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li><li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li><li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li></ul></div></nav></div><div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix"><aside class="mh-header-search mh-header-search-top"><form role="search" method="get" class="search-form" action="https://kichuu.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="mh-container mh-container-inner clearfix"><div class="mh-custom-header clearfix"><div class="mh-header-columns mh-row clearfix"><div class="mh-col-1-3 mh-site-identity"><div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand"> <a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" class="custom-logo" alt="Kichuu" srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w" sizes="(max-width: 331px) 100vw, 331px" /></a></div></div><aside class="mh-col-2-3 mh-header-widget-2"><div id="custom_html-14" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="5930196910"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></aside></div></div></div><div class="mh-main-nav-wrap"><nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li><li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li><li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li></ul></li><li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><ul class="sub-menu"><li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li><li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li><li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li><li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li></ul></li><li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li><li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a><ul class="sub-menu"><li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li><li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li></ul></li><li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li><li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li><li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li></ul></div></nav></div></header><div class="mh-subheader"><div class="mh-container mh-container-inner mh-row clearfix"><div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix"><div class="mh-header-ticker mh-header-ticker-bottom"><div class="mh-ticker-bottom"><div class="mh-ticker-title mh-ticker-title-bottom"> News Ticker<i class="fa fa-chevron-right"></i></div><div class="mh-ticker-content mh-ticker-content-bottom"><ul id="mh-ticker-loop-bottom"><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/oduu-simbirtuu-ganamaa-un-security-council-dhimma-itoophiyaa-irratti-irra-deebiin-gaafa-bitootessa-11-2021-walgahii-isaa-gaggeessuuf-jira/" title="Oduu Simbirtuu Ganamaa! UN security council dhimma Itoophiyaa irratti irra deebiin gaafa Bitootessa 11, 2021 walgahii isaa gaggeessuuf jira."> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Oduu Simbirtuu Ganamaa! UN security council dhimma Itoophiyaa irratti irra deebiin gaafa Bitootessa 11, 2021 walgahii isaa gaggeessuuf jira. </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/kana-booda-jaarsummaa-hin-deemu-atileet-haile-gebresillasie/" title="Kana booda Jaarsummaa hin deemu&#8221; Atileet Haile Gebresillasie!"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Kana booda Jaarsummaa hin deemu&#8221; Atileet Haile Gebresillasie! </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/%e1%88%9d%e1%88%ad%e1%8c%ab-%e1%89%a6%e1%88%ad%e1%8b%b5%e1%88%9d-%e1%88%9b%e1%8a%95-%e1%8a%a5%e1%8a%95%e1%8b%b0%e1%88%86%e1%8a%90-%e1%8b%a8%e1%8a%a0%e1%89%a5%e1%8b%ad-%e1%8d%8d%e1%88%88%e1%8c%8e/" title="ምርጫ ቦርድም ማን እንደሆነ የአብይ ፍለጎትም ምን እንደሆነ በግልፅ አሳይቷናል&#8230;."> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> ምርጫ ቦርድም ማን እንደሆነ የአብይ ፍለጎትም ምን እንደሆነ በግልፅ አሳይቷናል&#8230;. </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Amharic </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/world-bank-group-statement-on-current-situation-in-ethiopia/" title="World Bank Group Statement on Current Situation in Ethiopia"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> World Bank Group Statement on Current Situation in Ethiopia </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Business </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/dubbii-micciirudhaan-gantummaa-sirna-godhachuu-hindandaamu/" title="Dubbii micciirudhaan gantummaa sirna godhachuu hindanda&#8217;amu!"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Dubbii micciirudhaan gantummaa sirna godhachuu hindanda&#8217;amu! </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Videos </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/yaa-marqaa-si-afuufuun-si-liqimsuufi/" title="&#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221;"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> &#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221; </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/egypt-president-el-sisi-visits-sudan-amid-rapprochement/" title="Egypt president El-Sisi visits Sudan amid rapprochement"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Egypt president El-Sisi visits Sudan amid rapprochement </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Africa </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/egypt-president-el-sissi-visits-sudan-amid-rapprochement/" title="Egypt president el-Sissi visits Sudan amid rapprochement"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Egypt president el-Sissi visits Sudan amid rapprochement </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Africa </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/abin-bakka-buuun-magaalaa-asallaa-irratti-filanoof-dorgoma-abo-fi-kfo-filannoo-keessaa-baasanii-abin-dorgomshisuuree/" title="ABIN bakka bu&#8217;uun magaalaa Asallaa irratti filanoof dorgoma. ABO fi KFO filannoo keessaa baasanii ABIN dorgomshisuuree?"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> ABIN bakka bu&#8217;uun magaalaa Asallaa irratti filanoof dorgoma. ABO fi KFO filannoo keessaa baasanii ABIN dorgomshisuuree? </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/risch-cardin-colleagues-re-introduce-resolution-encouraging-peaceful-resolution-to-conflict-in-tigray-ethiopia/" title="RISCH, CARDIN, COLLEAGUES RE-INTRODUCE RESOLUTION ENCOURAGING PEACEFUL RESOLUTION TO CONFLICT IN TIGRAY, ETHIOPIA"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ March 6, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> RISCH, CARDIN, COLLEAGUES RE-INTRODUCE RESOLUTION ENCOURAGING PEACEFUL RESOLUTION TO CONFLICT IN TIGRAY, ETHIOPIA </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> World </span> </a></li></ul></div></div></div></div><div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix"><aside class="mh-header-search mh-header-search-bottom"><form role="search" method="get" class="search-form" action="https://kichuu.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><div class="mh-wrapper clearfix"><div class="mh-main clearfix"><div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/" itemprop="item"><span itemprop="name">News</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>&#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221;</nav><article id="post-89509" class="post-89509 post type-post status-publish format-standard has-post-thumbnail hentry category-news-afaan-oromoo"><header class="entry-header clearfix"><h1 class="entry-title">&#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221;</h1><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></header><div id="custom_html-15" class="widget_text mh-widget mh-posts-1 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="4616959710"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div class="entry-content clearfix"><div class="mh-social-top"><div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&t=%E2%80%9CYaa+Marqaa+Si+Afuufuun+Si+Liqimsuufi%21%E2%80%9D', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=%E2%80%9CYaa+Marqaa+Si+Afuufuun+Si+Liqimsuufi%21%E2%80%9D:&url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&media=https://kichuu.com/wp-content/uploads/2021/03/157307347_5150059088400644_2721742276713995828_n-1-e1615031621979.jpg&description=%E2%80%9CYaa+Marqaa+Si+Afuufuun+Si+Liqimsuufi%21%E2%80%9D', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-email" href="mailto:?subject=%E2%80%9CYaa%20Marqaa%20Si%20Afuufuun%20Si%20Liqimsuufi%21%E2%80%9D&amp;body=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div><div class="kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto"><strong>&#8220;Yaa Marqaa Si Afuufuun Si Liqimsuufi!&#8221;</strong></div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Waaqoo Nooleetiin Bito. 6, 2021</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto"><a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/caasaa?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Caasaa</a> Hawaasaa Biyya Tokkoo Keessatti, Biyya Ijaaruu fi Diiguu Keessatti Qooda Ol Aanaa Kanneen Qaban Warra Nagaya Buusuun Beekaman (peace Makers) dha.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Biyya Keenya Oromiyaa keessatti qaamota nagaha buusan(peace Makers) jedhamuun kanneen Beekaman</div><div dir="auto">#Hayyoota Amantii,</div><div dir="auto">#Abbootii Gadaa,</div><div dir="auto">#Jaarrolii Biyyaa,</div><div dir="auto"><a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/haadholii?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Haadholii</a> Siinqee,</div><div dir="auto">#Beektotaa fi Hayyoota.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Qaamoleen nagaha buusan kunneen Cufti isaaniituu Dirqama mata mataa isaanii Jireenya oolii bultii isaanii keessatti raawwatan qabu. Dabalataan akka Lammii biyya tokkootti, biyya ijaaruu( state building) keessatti:- Siyaasaan( politically), Hawaasummaan (Socially) fi Diinagdeen(Economically) hirmaannaa isaan irraa eeggamu gochuun gahee isaanii taphachuuf mirga qofa osoo hin taane dirqama Lammummaa/ Biyyummaa qabu. Haa ta&#8217;u malee dirqama isaan irraa eeggamu seeraa bahachuu dadhabuun daangaa malee haqa ummataa fi Haqa biyyaatti yoo bu&#8217;aan gaafatamummaa seeraa fi seenaa jalaa hin bahan.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Eegaa, Qaamoleen nagaha buusan kunneen gaafa dirqama isaan irraa eeggamu bahachuu dadhabanii fi Daangaa darbaa itti dhimma bahan gara biyya diiguutti deemu. Akkasumas Dirqama isaanii qixaan qixatti utti dhimma bahan taanaan gajeen isaan biyya ijaaruu keessatti qaban akkan ol aanaa dha.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Mee Dirqamaa fi gaafatamummaa qaamota armaan olii haa ilaalu!</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">1. <a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/hayyoota?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Hayyoota</a> Amantii:- Hayyoonni Amantii biyya isaanii keessatti amantii gosa kamiituu qabaniin, beekkumsa fi barnoota Amantii sanaa babal&#8217;isuun ummata amantii isaanii sana hordofan barsiisuu dha. Caasaa biyyaa keessatti bakka bu&#8217;aa Amantaa isaa ni qabaata, mirgi Amantaa isaa akka hin dhiibamnee fi dirqama biyya isaatiif hojachuu qabu hawaasa Amantaa sana hordofaniin dhaqqabsiisuun qooda keessaa fudhata. Bakka rakkoon jirutti hayyummaa Amantii qabu saniin nagaha buusuuf qooda isaa Adda durummaan bahata.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">2. <a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/abbootii?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Abbootii</a> Gadaa:-:Abbootiin Gadaa qaama Sirna Gadaa keessatti waan Gadaan jedhu Lallabuun, sirna bulchiinsa Gadaa hanga gadaa Bulchiinsa isaa fixatee kan biraatti dabatsuutti Safuu fi duudhaa sirnichaa kabajee nagaha ummataa fi Biyyaa lallavu Abukaatoo Gadaati.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">3. <a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/haadha?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Haadha</a> Siiqqee:- Wayyuu uummaa, Hanfalaa kabajaa, Ganyaa Araaraa Taankii fi Madfiin afoo hin dhaabanne Utubaa nageenyaa biyya tokkooti!</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">4. <a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/jaarrolii?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Jaarrolii</a> Biyyaa:- Jaarsi biyyaa jaarsa dhaweessaa fi maleessa jaarsa Halangee dhibdee fi kuttee kutee Koottu dhufeen taa&#8217;ee citaa fi Ciccitaa biyyaa suphu, Qaalluu Araaraa mana Kitaabaa ( Library) Biyya Tokkooti.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">5. <a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/beektotaa?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#Beektotaa</a> fi Hayyoota:-Sammuu baranee, beekkumsaa fi hayyummaa barnoota Qalamaa qabuun Lammii isaa tajaajiluuf waadaa seene Dawaa dhibee biyya tokkooti.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Kun kanaan osoo jiruu, Qaamolleen nageenyaa biyya tokkoo mirgaa fi dirqama isaanii osoo beekanii maal na dhibee fi akka fedheen Dantaa ummataa fi biyya isaaniif yaaduu dhiisanii dantaa dhuunfaatti Imaanaa harkarraa qaban geeddaran yoo ta&#8217;e isaan Rabbii fi nama birattillee Cubbamtoota tuuta Azaabaa akkasuma Yakkamtoota seeraa Seeraa fi Seenaa jalaallee hin baanee dha.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Ustaazonni keenya dirqama iddilee keessan osoo hin raawwatin iddoo nageenyi Waaraa fi Tasgabbiin sabatiinsa qabu hin jirretti, Murna Shiftaa Harki dhiigaan laaqame faanaa hiriiruun Filannoo dimokiraatawaa fi Haqa qabeessa fakkeesitanii dorgommiif of qooheessuun Shiftoota kaleessa korkoddee isin hidhaa turtee fi har&#8217;as Ummata keessan isin afotti ajjeessaa jiraniin addummaa hin qabdan.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Sababa isin, filalloo keessatti ni hirmaannaan of kaadhimtaniif jecha, <a class="oajrlxb2 g5ia77u1 qu0x051f esr5mh6w e9989ue4 r7d6kgcz rq0escxv nhd2j8a9 nc684nl6 p7hjln8o kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x jb3vyjys rz4wbd8a qt6c0cv9 a8nywdso i1ao9s8h esuyzwwr f1sip0of lzcic4wl q66pz984 gpro0wi8 b1v8xokw" tabindex="0" role="link" href="https://www.facebook.com/hashtag/murnishiftaapp?__eep__=6&amp;__cft__[0]=AZWOyylyv3qQ-Dq9-697QukRPAl5U3s_uQ4PqcsxPtvE2xBjNeLREozJ4-MwjavY_EdE7jlnoFgEdJrNSXSsImtOgMzuF4eOxKtnz47oycegpulaK7N9CgHrwQee3tSehPs32HfYD7iXlHoxot4i1krk_faE8zZphZ5JP4rZaQjtHQ&amp;__tn__=*NK-R">#MurniShiftaaPP</a> lafa isin hanqisee Gootota dorgommiif dhihaateen isin jajaa jiru; Jajamuu qofa osoo hin taane jaji&#8217;amuunis akka jiru dagachuun gonkumaa hin barbaachisu. Kanaafi kan, &#8220;Yaa Marqaa Si Afuufuun Si Liqumsuufi!&#8221;jedheefi.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Gadaan Gadaa Xumura Gabrummaati!</div><div dir="auto"> </div><div dir="auto"><strong>Filannoon Jalqabaa MCBO ti!</strong></div><div dir="auto"><img loading="lazy" class="alignnone size-full wp-image-89510" src="https://kichuu.com/wp-content/uploads/2021/03/157307347_5150059088400644_2721742276713995828_n-1-e1615031621979.jpg" alt="" width="700" height="728" /></div><div dir="auto"><img loading="lazy" class="alignnone size-full wp-image-89512" src="https://kichuu.com/wp-content/uploads/2021/03/157944199_800059087289455_8886778708524735252_o-e1615031829180.jpg" alt="" width="700" height="991" /></div></div><div class="mh-social-bottom"><div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&t=%E2%80%9CYaa+Marqaa+Si+Afuufuun+Si+Liqimsuufi%21%E2%80%9D', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=%E2%80%9CYaa+Marqaa+Si+Afuufuun+Si+Liqimsuufi%21%E2%80%9D:&url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F&media=https://kichuu.com/wp-content/uploads/2021/03/157307347_5150059088400644_2721742276713995828_n-1-e1615031621979.jpg&description=%E2%80%9CYaa+Marqaa+Si+Afuufuun+Si+Liqimsuufi%21%E2%80%9D', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-email" href="mailto:?subject=%E2%80%9CYaa%20Marqaa%20Si%20Afuufuun%20Si%20Liqimsuufi%21%E2%80%9D&amp;body=https%3A%2F%2Fkichuu.com%2Fyaa-marqaa-si-afuufuun-si-liqimsuufi%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div></div><div id="custom_html-16" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="4120112176"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev"> <a href="https://kichuu.com/egypt-president-el-sisi-visits-sudan-amid-rapprochement/" rel="prev"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/2507406-505419402-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Egypt" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/2507406-505419402-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/2507406-505419402-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Egypt president El-Sisi visits Sudan amid rapprochement</p></a></div><div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next"> <a href="https://kichuu.com/dubbii-micciirudhaan-gantummaa-sirna-godhachuu-hindandaamu/" rel="next"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/pizap-83-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Gantummaa" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/pizap-83-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-300x225.jpg 300w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-700x524.jpg 700w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83.jpg 1170w" sizes="(max-width: 80px) 100vw, 80px" /><span>Next</span><p>Dubbii micciirudhaan gantummaa sirna godhachuu hindanda&#8217;amu!</p></a></div></nav><div id="comments" class="mh-comments-wrap"><h4 class="mh-widget-title mh-comment-form-title"> <span class="mh-widget-title-inner"> Be the first to comment </span></h4><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/yaa-marqaa-si-afuufuun-si-liqimsuufi/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='89509' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c09ad290ce" /></p><input type="hidden" id="ak_js" name="ak_js" value="47"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3980511370"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89529 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/oduu-simbirtuu-ganamaa-un-security-council-dhimma-itoophiyaa-irratti-irra-deebiin-gaafa-bitootessa-11-2021-walgahii-isaa-gaggeessuuf-jira/" title="Oduu Simbirtuu Ganamaa! UN security council dhimma Itoophiyaa irratti irra deebiin gaafa Bitootessa 11, 2021 walgahii isaa gaggeessuuf jira."><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/156979799_932455664184983_7585336204951970844_n-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/156979799_932455664184983_7585336204951970844_n-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/156979799_932455664184983_7585336204951970844_n-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/oduu-simbirtuu-ganamaa-un-security-council-dhimma-itoophiyaa-irratti-irra-deebiin-gaafa-bitootessa-11-2021-walgahii-isaa-gaggeessuuf-jira/" title="Oduu Simbirtuu Ganamaa! UN security council dhimma Itoophiyaa irratti irra deebiin gaafa Bitootessa 11, 2021 walgahii isaa gaggeessuuf jira."> Oduu Simbirtuu Ganamaa! UN security council dhimma Itoophiyaa irratti irra deebiin gaafa Bitootessa 11, 2021 walgahii isaa gaggeessuuf jira. </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89524 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/kana-booda-jaarsummaa-hin-deemu-atileet-haile-gebresillasie/" title="Kana booda Jaarsummaa hin deemu&#8221; Atileet Haile Gebresillasie!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/pizap-85-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/pizap-85-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/pizap-85-300x225.jpg 300w, https://kichuu.com/wp-content/uploads/2021/03/pizap-85-e1615039126895.jpg 700w, https://kichuu.com/wp-content/uploads/2021/03/pizap-85-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2021/03/pizap-85-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/03/pizap-85-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/kana-booda-jaarsummaa-hin-deemu-atileet-haile-gebresillasie/" title="Kana booda Jaarsummaa hin deemu&#8221; Atileet Haile Gebresillasie!"> Kana booda Jaarsummaa hin deemu&#8221; Atileet Haile Gebresillasie! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89521 post type-post status-publish format-standard has-post-thumbnail category-amharic"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%88%9d%e1%88%ad%e1%8c%ab-%e1%89%a6%e1%88%ad%e1%8b%b5%e1%88%9d-%e1%88%9b%e1%8a%95-%e1%8a%a5%e1%8a%95%e1%8b%b0%e1%88%86%e1%8a%90-%e1%8b%a8%e1%8a%a0%e1%89%a5%e1%8b%ad-%e1%8d%8d%e1%88%88%e1%8c%8e/" title="ምርጫ ቦርድም ማን እንደሆነ የአብይ ፍለጎትም ምን እንደሆነ በግልፅ አሳይቷናል&#8230;."><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/156726540_10215119915910629_4552260465936295187_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="ምርጫ ቦርድም" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/156726540_10215119915910629_4552260465936295187_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/156726540_10215119915910629_4552260465936295187_n-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/%e1%88%9d%e1%88%ad%e1%8c%ab-%e1%89%a6%e1%88%ad%e1%8b%b5%e1%88%9d-%e1%88%9b%e1%8a%95-%e1%8a%a5%e1%8a%95%e1%8b%b0%e1%88%86%e1%8a%90-%e1%8b%a8%e1%8a%a0%e1%89%a5%e1%8b%ad-%e1%8d%8d%e1%88%88%e1%8c%8e/" title="ምርጫ ቦርድም ማን እንደሆነ የአብይ ፍለጎትም ምን እንደሆነ በግልፅ አሳይቷናል&#8230;."> ምርጫ ቦርድም ማን እንደሆነ የአብይ ፍለጎትም ምን እንደሆነ በግልፅ አሳይቷናል&#8230;. </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89518 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/world-bank-group-statement-on-current-situation-in-ethiopia/" title="World Bank Group Statement on Current Situation in Ethiopia"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/download-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="World Bank Group" loading="lazy" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/world-bank-group-statement-on-current-situation-in-ethiopia/" title="World Bank Group Statement on Current Situation in Ethiopia"> World Bank Group Statement on Current Situation in Ethiopia </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89515 post type-post status-publish format-standard has-post-thumbnail category-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/dubbii-micciirudhaan-gantummaa-sirna-godhachuu-hindandaamu/" title="Dubbii micciirudhaan gantummaa sirna godhachuu hindanda&#8217;amu!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/pizap-83-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Gantummaa" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/pizap-83-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-300x225.jpg 300w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-700x524.jpg 700w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/03/pizap-83.jpg 1170w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/dubbii-micciirudhaan-gantummaa-sirna-godhachuu-hindandaamu/" title="Dubbii micciirudhaan gantummaa sirna godhachuu hindanda&#8217;amu!"> Dubbii micciirudhaan gantummaa sirna godhachuu hindanda&#8217;amu! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89506 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/egypt-president-el-sisi-visits-sudan-amid-rapprochement/" title="Egypt president El-Sisi visits Sudan amid rapprochement"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/2507406-505419402-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Egypt" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/2507406-505419402-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/2507406-505419402-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/egypt-president-el-sisi-visits-sudan-amid-rapprochement/" title="Egypt president El-Sisi visits Sudan amid rapprochement"> Egypt president El-Sisi visits Sudan amid rapprochement </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89503 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/egypt-president-el-sissi-visits-sudan-amid-rapprochement/" title="Egypt president el-Sissi visits Sudan amid rapprochement"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/800-2-80x60.jpeg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Egypt" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/800-2-80x60.jpeg 80w, https://kichuu.com/wp-content/uploads/2021/03/800-2-678x509.jpeg 678w, https://kichuu.com/wp-content/uploads/2021/03/800-2-326x245.jpeg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/egypt-president-el-sissi-visits-sudan-amid-rapprochement/" title="Egypt president el-Sissi visits Sudan amid rapprochement"> Egypt president el-Sissi visits Sudan amid rapprochement </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89495 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/abin-bakka-buuun-magaalaa-asallaa-irratti-filanoof-dorgoma-abo-fi-kfo-filannoo-keessaa-baasanii-abin-dorgomshisuuree/" title="ABIN bakka bu&#8217;uun magaalaa Asallaa irratti filanoof dorgoma. ABO fi KFO filannoo keessaa baasanii ABIN dorgomshisuuree?"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/pizap-82-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="ABO fi KFO" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/pizap-82-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/pizap-82-300x225.jpg 300w, https://kichuu.com/wp-content/uploads/2021/03/pizap-82-e1615030644507.jpg 700w, https://kichuu.com/wp-content/uploads/2021/03/pizap-82-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2021/03/pizap-82-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/03/pizap-82-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/abin-bakka-buuun-magaalaa-asallaa-irratti-filanoof-dorgoma-abo-fi-kfo-filannoo-keessaa-baasanii-abin-dorgomshisuuree/" title="ABIN bakka bu&#8217;uun magaalaa Asallaa irratti filanoof dorgoma. ABO fi KFO filannoo keessaa baasanii ABIN dorgomshisuuree?"> ABIN bakka bu&#8217;uun magaalaa Asallaa irratti filanoof dorgoma. ABO fi KFO filannoo keessaa baasanii ABIN dorgomshisuuree? </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89492 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/risch-cardin-colleagues-re-introduce-resolution-encouraging-peaceful-resolution-to-conflict-in-tigray-ethiopia/" title="RISCH, CARDIN, COLLEAGUES RE-INTRODUCE RESOLUTION ENCOURAGING PEACEFUL RESOLUTION TO CONFLICT IN TIGRAY, ETHIOPIA"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/Untitled-16-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="ETHIOPIA" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/Untitled-16-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/03/Untitled-16-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/risch-cardin-colleagues-re-introduce-resolution-encouraging-peaceful-resolution-to-conflict-in-tigray-ethiopia/" title="RISCH, CARDIN, COLLEAGUES RE-INTRODUCE RESOLUTION ENCOURAGING PEACEFUL RESOLUTION TO CONFLICT IN TIGRAY, ETHIOPIA"> RISCH, CARDIN, COLLEAGUES RE-INTRODUCE RESOLUTION ENCOURAGING PEACEFUL RESOLUTION TO CONFLICT IN TIGRAY, ETHIOPIA </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89488 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/as-crisis-deepens-in-ethiopia-need-for-committed-diplomatic-response-grows/" title="As Crisis Deepens in Ethiopia, Need for Committed Diplomatic Response Grows"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/rtx8fxf2-min-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/rtx8fxf2-min-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/rtx8fxf2-min-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/03/rtx8fxf2-min-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/as-crisis-deepens-in-ethiopia-need-for-committed-diplomatic-response-grows/" title="As Crisis Deepens in Ethiopia, Need for Committed Diplomatic Response Grows"> As Crisis Deepens in Ethiopia, Need for Committed Diplomatic Response Grows </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89485 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/high-stakes-as-regional-leaders-gather-in-south-sudan-and-sudan/" title="High stakes as regional leaders gather in South Sudan and Sudan"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/Untitled-15-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="South Sudan" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/Untitled-15-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/03/Untitled-15-678x509.png 678w, https://kichuu.com/wp-content/uploads/2021/03/Untitled-15-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/high-stakes-as-regional-leaders-gather-in-south-sudan-and-sudan/" title="High stakes as regional leaders gather in South Sudan and Sudan"> High stakes as regional leaders gather in South Sudan and Sudan </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89477 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/9-things-to-know-about-the-unfolding-crisis-in-ethiopias-tigray-region/" title="9 Things To Know About The Unfolding Crisis In Ethiopia&#8217;s Tigray Region"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/ap_21054463707129_wide-c73dc15f98e51db06e565553101bac90776fa5ea-s800-c85-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tigray Region" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/ap_21054463707129_wide-c73dc15f98e51db06e565553101bac90776fa5ea-s800-c85-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/ap_21054463707129_wide-c73dc15f98e51db06e565553101bac90776fa5ea-s800-c85-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/9-things-to-know-about-the-unfolding-crisis-in-ethiopias-tigray-region/" title="9 Things To Know About The Unfolding Crisis In Ethiopia&#8217;s Tigray Region"> 9 Things To Know About The Unfolding Crisis In Ethiopia&#8217;s Tigray Region </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 5, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89473 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/situation-report-eepa-horn-no-98-05-march-2021/" title="Situation Report EEPA HORN No. 98 – 05 March 2021"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/war-in-tigray-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="EEPA HORN" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/war-in-tigray-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/war-in-tigray-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/situation-report-eepa-horn-no-98-05-march-2021/" title="Situation Report EEPA HORN No. 98 – 05 March 2021"> Situation Report EEPA HORN No. 98 – 05 March 2021 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 5, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89463 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/u-n-and-u-s-demand-eritrean-forces-leave-ethiopia-amid-mass-killings-rapes-and-abductions-in-tigray/" title="U.N. and U.S. demand Eritrean forces leave Ethiopia amid &#8220;mass killings, rapes and abductions&#8221; in Tigray"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/ethiopia-tigray-1231435668-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Eritrean forces" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/ethiopia-tigray-1231435668-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/ethiopia-tigray-1231435668-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/u-n-and-u-s-demand-eritrean-forces-leave-ethiopia-amid-mass-killings-rapes-and-abductions-in-tigray/" title="U.N. and U.S. demand Eritrean forces leave Ethiopia amid &#8220;mass killings, rapes and abductions&#8221; in Tigray"> U.N. and U.S. demand Eritrean forces leave Ethiopia amid &#8220;mass killings, rapes and abductions&#8221; in Tigray </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 5, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89457 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-eritrean-forces-massacre-tigray-civilians/" title="Ethiopia: Eritrean Forces Massacre Tigray Civilians"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/1200px-Hrw_logo.svg_-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/1200px-Hrw_logo.svg_-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/03/1200px-Hrw_logo.svg_-678x509.png 678w, https://kichuu.com/wp-content/uploads/2021/03/1200px-Hrw_logo.svg_-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/ethiopia-eritrean-forces-massacre-tigray-civilians/" title="Ethiopia: Eritrean Forces Massacre Tigray Civilians"> Ethiopia: Eritrean Forces Massacre Tigray Civilians </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 5, 2021</a></span></div></div></li></ul></div></aside></div></div><footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter"><div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix"><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1"><div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89221 post type-post status-publish format-standard has-post-thumbnail category-health"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/breast-awareness-self%e2%80%90reported-abnormalities-and-breast-cancer-in-rural-ethiopia-a-survey-of-7573-women-and-predictions-of-the-national-burden/" title="Breast awareness, self‐reported abnormalities, and breast cancer in rural Ethiopia: A survey of 7,573 women and predictions of the national burden"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/41breastcancer-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Breast awareness" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/41breastcancer-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/03/41breastcancer-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/03/41breastcancer-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/breast-awareness-self%e2%80%90reported-abnormalities-and-breast-cancer-in-rural-ethiopia-a-survey-of-7573-women-and-predictions-of-the-national-burden/" title="Breast awareness, self‐reported abnormalities, and breast cancer in rural Ethiopia: A survey of 7,573 women and predictions of the national burden"> Breast awareness, self‐reported abnormalities, and breast cancer in rural Ethiopia: A survey of 7,573 women and predictions of the national burden </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 2, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86091 post type-post status-publish format-standard has-post-thumbnail category-health"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/warri-qabdan-naaf-hiixadhaa-warri-hin-qabne-waaqa-naaf-kadhadhaa/" title="Warri qabdan naaf hiixadhaa, warri hin qabne Waaqa naaf kadhadhaa"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/pizap-55-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Warri qabdan" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/pizap-55-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-e1610138038655.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/warri-qabdan-naaf-hiixadhaa-warri-hin-qabne-waaqa-naaf-kadhadhaa/" title="Warri qabdan naaf hiixadhaa, warri hin qabne Waaqa naaf kadhadhaa"> Warri qabdan naaf hiixadhaa, warri hin qabne Waaqa naaf kadhadhaa </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 8, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86075 post type-post status-publish format-standard has-post-thumbnail category-health"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/a-second-chinese-coronavirus-vaccine-is-said-to-be-effective/" title="A Second Chinese Coronavirus Vaccine Is Said to Be Effective"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/a-second-chinese-coronavirus-vaccine-is-said-to-be-effective/" title="A Second Chinese Coronavirus Vaccine Is Said to Be Effective"> A Second Chinese Coronavirus Vaccine Is Said to Be Effective </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 7, 2021</a></span></div></div></li></ul></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2"><div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86239 post type-post status-publish format-standard has-post-thumbnail category-fun-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/gaafa-tokko-harreetu-waraabessaf-tola-olltefi-turte-kana-harreen/" title="Gaafa Tokko harreetu Waraabessaf Tola olltefi turte kana Harreen .."><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/pizap-70-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Harreen" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/pizap-70-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-e1610278501681.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/gaafa-tokko-harreetu-waraabessaf-tola-olltefi-turte-kana-harreen/" title="Gaafa Tokko harreetu Waraabessaf Tola olltefi turte kana Harreen .."> Gaafa Tokko harreetu Waraabessaf Tola olltefi turte kana Harreen .. </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 10, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-75646 post type-post status-publish format-standard has-post-thumbnail category-fun-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/isaias-isaiah-to-hit-america/" title="Isaias (Isaiah) to Hit America!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Isaias" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/isaias-isaiah-to-hit-america/" title="Isaias (Isaiah) to Hit America!"> Isaias (Isaiah) to Hit America! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 1, 2020</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Mohammed Hajjii" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"> Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span></div></div></li></ul></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3"><div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89397 post type-post status-publish format-standard has-post-thumbnail category-musics"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ahmed-umer-waa-sadi-ethiopian-oromo-music-2021-official-video/" title="Ahmed Umer &#8211; Waa Sadi- Ethiopian Oromo Music 2021 [Official Video]"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/Untitled-11-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ahmed Umer" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/Untitled-11-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/03/Untitled-11-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/ahmed-umer-waa-sadi-ethiopian-oromo-music-2021-official-video/" title="Ahmed Umer &#8211; Waa Sadi- Ethiopian Oromo Music 2021 [Official Video]"> Ahmed Umer &#8211; Waa Sadi- Ethiopian Oromo Music 2021 [Official Video] </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 4, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89322 post type-post status-publish format-standard has-post-thumbnail category-musics"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/caalaa-daggafaa-hacaluu-gaafa-adwa-new-oromoo-music-2021-video/" title="Caalaa Daggafaa HACALUU GAAFA ADWA New Oromoo Music 2021 Video"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/Untitled-8-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Caalaa Daggafaa" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/03/Untitled-8-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/03/Untitled-8-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/caalaa-daggafaa-hacaluu-gaafa-adwa-new-oromoo-music-2021-video/" title="Caalaa Daggafaa HACALUU GAAFA ADWA New Oromoo Music 2021 Video"> Caalaa Daggafaa HACALUU GAAFA ADWA New Oromoo Music 2021 Video </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 3, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86978 post type-post status-publish format-standard has-post-thumbnail category-musics"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/nagugubee-waaeen-kee-haacaaluu-hundeessaa-new-oromo-music/" title="Nagugubee Waa&#8217;een Kee Haacaaluu Hundeessaa New Oromo music"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/pizap-12-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Haacaaluu Hundeessaa" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/pizap-12-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-e1611609594455.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/nagugubee-waaeen-kee-haacaaluu-hundeessaa-new-oromo-music/" title="Nagugubee Waa&#8217;een Kee Haacaaluu Hundeessaa New Oromo music"> Nagugubee Waa&#8217;een Kee Haacaaluu Hundeessaa New Oromo music </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 25, 2021</a></span></div></div></li></ul></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4"><div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89518 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/world-bank-group-statement-on-current-situation-in-ethiopia/" title="World Bank Group Statement on Current Situation in Ethiopia"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/03/download-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="World Bank Group" loading="lazy" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/world-bank-group-statement-on-current-situation-in-ethiopia/" title="World Bank Group Statement on Current Situation in Ethiopia"> World Bank Group Statement on Current Situation in Ethiopia </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/03/">March 6, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89090 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-lest-backbreaking-inflation-boils-over-into-instability-chaos/" title="Ethiopia: Lest Backbreaking Inflation Boils Over Into Instability, Chaos"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/154924997_2564078693892056_3488534002629359277_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Inflation" loading="lazy" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/ethiopia-lest-backbreaking-inflation-boils-over-into-instability-chaos/" title="Ethiopia: Lest Backbreaking Inflation Boils Over Into Instability, Chaos"> Ethiopia: Lest Backbreaking Inflation Boils Over Into Instability, Chaos </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 28, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88863 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/imf-ethiopia-agree-framework-for-loan-deal-reviews/" title="IMF, Ethiopia agree framework for loan deal reviews"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-65-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="IMF," loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-65-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-65-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/imf-ethiopia-agree-framework-for-loan-deal-reviews/" title="IMF, Ethiopia agree framework for loan deal reviews"> IMF, Ethiopia agree framework for loan deal reviews </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 24, 2021</a></span></div></div></li></ul></div></div></div></footer><div class="mh-footer-nav-mobile"></div><nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="mh-container mh-container-inner clearfix"><div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li></ul></div></div></nav><div class="mh-copyright-wrap"><div class="mh-container mh-container-inner clearfix"><p class="mh-copyright"> Copyright @2016 kichuu.com</p></div></div> <a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a></div><div id="fb-root"></div> <script>(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/i18n.min.js?ver=ac389435e7fd4ded01cf603f3aaba6a6' id='wp-i18n-js'></script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' id='lodash-js'></script> <script type='text/javascript' id='lodash-js-after'>window.lodash = _.noConflict();</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/url.min.js?ver=98645f0502e5ed8dadffd161e39072d2' id='wp-url-js'></script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/hooks.min.js?ver=84b89ab09cbfb4469f02183611cc0939' id='wp-hooks-js'></script> <script type='text/javascript' id='wp-api-fetch-js-translations'>( function( domain, translations ) {
var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;
wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/api-fetch.min.js?ver=4dec825c071b87c57f687eb90f7c23c3' id='wp-api-fetch-js'></script> <script type='text/javascript' id='wp-api-fetch-js-after'>wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://kichuu.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "0a5492c617" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://kichuu.com/wp-admin/admin-ajax.php?action=rest-nonce";</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = [];</script> <script defer type='text/javascript' src='https://kichuu.com/wp-content/cache/autoptimize/js/autoptimize_single_2fdf3cc1d0fcf824759f5287d4bd7b74.js?ver=5.4' id='contact-form-7-js'></script> <script defer type='text/javascript' src='https://kichuu.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script> <script defer type='text/javascript' src='https://kichuu.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script> <script defer="async" type='text/javascript' src='https://kichuu.com/wp-content/cache/autoptimize/js/autoptimize_single_270f0cd7341bce6c2afacf2682e7690e.js?ver=4.1.9' id='akismet-form-js'></script> </body></html><!-- WP Fastest Cache file was created in 0.27513885498047 seconds, on 06-03-21 9:23:23 --><!-- via php -->