<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More Kichuu</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few MoreMyanmar’s onetime champion of democracy and Ethiopia’s"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More Kichuu" />
<meta property="og:description" content="With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few MoreMyanmar’s onetime champion of democracy and Ethiopia’s" />
<meta property="og:url" content="https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:publisher" content="https://www.facebook.com/kichuu.info/" />
<meta property="article:section" content="World" />
<meta property="article:published_time" content="2020-03-12T16:55:16+00:00" />
<meta property="og:image" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?fit=700%2C467&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?fit=700%2C467&#038;ssl=1" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="467" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507","name":"fmegersa","logo":{"@id":"https://kichuu.com/#personlogo"},"sameAs":[]},{"@type":"WebSite","@id":"https://kichuu.com/#website","url":"https://kichuu.com/","name":"Kichuu","inLanguage":"en-US","publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"potentialAction":{"@type":"SearchAction","target":"https://kichuu.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?fit=700%2C467&ssl=1","width":700,"height":467,"caption":"Nobel Peace Prize"},{"@type":"WebPage","@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#webpage","url":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/","name":"With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More Kichuu","isPartOf":{"@id":"https://kichuu.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#primaryimage"},"datePublished":"2020-03-12T16:55:16+00:00","dateModified":"2020-03-12T16:55:16+00:00","description":"With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few MoreMyanmar\u2019s onetime champion of democracy and Ethiopia\u2019s"},{"@type":"Article","@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#article","isPartOf":{"@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#webpage"},"author":{"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330"},"headline":"With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More","datePublished":"2020-03-12T16:55:16+00:00","dateModified":"2020-03-12T16:55:16+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#webpage"},"publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"image":{"@id":"https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#primaryimage"},"articleSection":"World","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330","name":"kichuu_admin","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More Comments Feed" href="https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/feed/" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/style.css?ver=3.8.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/dhrvjwy1/hdxi.css" media="all"/>
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.6'></script>
<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://kichuu.com/?p=66677' />
<link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&#038;format=xml" />
<script>
document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
</script>
<style>
.no-js img.lazyload { display: none; }
figure.wp-block-image img.lazyloading { min-width: 150px; }
.lazyload, .lazyloading { opacity: 0; }
.lazyloaded {
opacity: 1;
transition: opacity 400ms;
transition-delay: 0ms;
}
</style>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>
<link rel="icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=270%2C270&#038;ssl=1" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-66677 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-top">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kichuu" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?w=331&amp;ssl=1 331w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=300%2C73&amp;ssl=1 300w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=326%2C81&amp;ssl=1 326w" data-lazy-sizes="(max-width: 331px) 100vw, 331px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20190303 -->
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3737122119"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
News Ticker<i class="fa fa-chevron-right"></i>		</div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/dn-daanieel-kibrat-hardha-aangoo-akka-argatan-dhageenye/" title="Dn Daani&#8217;eel Kibrat hardha aangoo akka argatan dhageenye.">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Dn Daani&#8217;eel Kibrat hardha aangoo akka argatan dhageenye.						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/bahrain-oman-support-egypt-in-renaissance-dam-dispute-with-ethiopia/" title="Bahrain, Oman Support Egypt in Renaissance Dam Dispute With Ethiopia">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Bahrain, Oman Support Egypt in Renaissance Dam Dispute With Ethiopia						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/the-covid-19-virus-reminds-us-dont-fully-trust-dictators-or-their-enablers/" title="THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Health							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/help-girls-stay-in-school-in-ethiopia/" title="Help Girls Stay in School in Ethiopia">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Help Girls Stay in School in Ethiopia						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/abiy-ahmed-waraabesa-halkan-fi-guyyaa-angoo-irratti-basaa-jira/" title="Abiy Ahmed: Waraabesa halkan fi guyyaa angoo irratti basaa jira !">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Abiy Ahmed: Waraabesa halkan fi guyyaa angoo irratti basaa jira !						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/record-number-mps-vote-against-daniel-kibrets-place-in-media-board/" title="Record Number MPs Vote against Daniel Kibret&#8217;s Place in Media Board">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Record Number MPs Vote against Daniel Kibret&#8217;s Place in Media Board						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/" title="With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/free-all-political-prisoners-stop-politically-motivated-intimidations/" title="Free All Political Prisoners &#038; Stop Politically Motivated Intimidations">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Free All Political Prisoners &#038; Stop Politically Motivated Intimidations						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/look-this-stupid-task-the-naqamte-administration-requests-donation-on-behalf-of-pp-rip-democracy/" title="RIP democracy!!The Naqamte Administration requests donation on behalf of PP.">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
RIP democracy!!The Naqamte Administration requests donation on behalf of PP.						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/paarlaamaa-itoophiyaa-miseensonni-paarlaamaa-muudama-diyaaqon-daaniel-kibrat-morman/" title="Paarlaamaa Itoophiyaa: Miseensonni paarlaamaa muudama Diyaaqon Daani&#8217;el Kibrat morman">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ March 12, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Paarlaamaa Itoophiyaa: Miseensonni paarlaamaa muudama Diyaaqon Daani&#8217;el Kibrat morman						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>		</ul>
</div>
</div>						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/news/">News</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com/category/news/world/" itemprop="url"><span itemprop="title">World</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More</nav>
<article id="post-66677" class="post-66677 post type-post status-publish format-standard has-post-thumbnail hentry category-world">
<header class="entry-header clearfix"><h1 class="entry-title">With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</header>
<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&t=With+Many+Dents+to+Its+Image%2C+Nobel+Peace+Prize+Is+Hit+With+a+Few+More', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=With+Many+Dents+to+Its+Image%2C+Nobel+Peace+Prize+Is+Hit+With+a+Few+More:&url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&media=https://kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg&description=With+Many+Dents+to+Its+Image%2C+Nobel+Peace+Prize+Is+Hit+With+a+Few+More', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=With%20Many%20Dents%20to%20Its%20Image%2C%20Nobel%20Peace%20Prize%20Is%20Hit%20With%20a%20Few%20More&amp;body=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
<div class="css-1vkm6nb ehdk2mb0"><strong id="link-e2415b3" class="css-1s4ffep e1h9rw200"><span class="balancedHeadline">With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More</span></strong></div>
<p id="article-summary" class="css-ns7wfp e1wiw3jv0">Myanmar’s onetime champion of democracy and <a href="https://kichuu.com/oromia-ethiopia-this-is-what-happening-in-current-ethiopia-under-abiy-ahmed-who-was-awarded-the-nobel-peace-prize-in-2019/">Ethiopia’s prime</a> minister join a roster of figures who, one way or another, have given the Nobel Peace Prize a contentious image.</p>
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- k20200225 -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3156329304"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong>“Motivating killers was not an intention of Alfred Nobel.”</strong></p>
<figure id="attachment_66678" aria-describedby="caption-attachment-66678" style="width: 600px" class="wp-caption alignnone"><img class="wp-image-66678 size-large jetpack-lazy-image" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo.jpg?resize=600%2C400&#038;ssl=1" alt width="600" height="400" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?resize=600%2C400&amp;ssl=1 600w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?resize=250%2C167&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 600px) 100vw, 600px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo.jpg?resize=600%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-66678 size-large" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo.jpg?resize=600%2C400&#038;ssl=1" alt="" width="600" height="400" srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?resize=600%2C400&amp;ssl=1 600w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?resize=250%2C167&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 600px) 100vw, 600px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-66678" class="wp-caption-text">Prime Minister Abiy Ahmed of Ethiopia, second from left, received the Nobel Peace Prize on Tuesday.Credit&#8230;Erik Valestrand/Getty Images</figcaption></figure>
<p>By <a class="css-brehiz e1jsehar0" href="https://www.nytimes.com/by/rick-gladstone"><span class="css-1baulvz last-byline">Rick Gladstone</span></a></p>
<p class="css-exrw3m evys1bk0">(<a href="https://www.nytimes.com/2019/12/11/world/europe/Nobel-Peace-Prize-image-history.html?smid=fb-share&amp;fbclid=IwAR0zsCyX4js5-JuMsVRKdZFndb2NLFvFx5kpLGSMsbFkkESPRH2ylGhqifk">nytimes</a>)&#8211;The Nobel Peace Prize has long been contentious, beginning with its origins in the will of Alfred Nobel, the 19th-century inventor of dynamite. But it is extraordinary that two winners are almost simultaneously battling accusations of behavior that is widely regarded as antithetical to the spirit and purpose of the award, first given in 1901.</p>
<p class="css-exrw3m evys1bk0">On Wednesday, Daw Aung San Suu Kyi, the Myanmar leader who won the prize in 1991, appeared before the International Court of Justice and <a class="css-1g7m0tk" title="" href="https://www.nytimes.com/2019/12/11/world/asia/aung-san-suu-kyi-rohingya-myanmar-genocide-hague.html">denied accusations that her government had committed genocide</a> against the Rohingya minority. Her defense of Myanmar at the court was a jarring contrast to her onetime identity as an intrepid champion of human rights and democracy.</p>
<p class="css-exrw3m evys1bk0">And on Tuesday, the <a class="css-1g7m0tk" title="" href="https://www.nytimes.com/2019/10/11/world/africa/nobel-peace-prize.html">2019 winner</a>, Prime Minister Abiy Ahmed of Ethiopia, facing accusations of a heavy-handed crackdown on political protests, skipped a news conference after <a class="css-1g7m0tk" title="" href="https://www.nytimes.com/2019/12/10/world/africa/nobel-peace-abiy-ahmed.html">his acceptance speech</a>.</p>
<p><img class="alignnone size-large wp-image-66679 jetpack-lazy-image" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo.jpg?resize=517%2C400&#038;ssl=1" alt width="517" height="400" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?resize=517%2C400&amp;ssl=1 517w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?resize=250%2C193&amp;ssl=1 250w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?resize=768%2C594&amp;ssl=1 768w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 517px) 100vw, 517px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo.jpg?resize=517%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-large wp-image-66679" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo.jpg?resize=517%2C400&#038;ssl=1" alt="" width="517" height="400" srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?resize=517%2C400&amp;ssl=1 517w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?resize=250%2C193&amp;ssl=1 250w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?resize=768%2C594&amp;ssl=1 768w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165783420_9160e1a0-7dda-438f-a14a-58dcb2f6ec18-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 517px) 100vw, 517px" data-recalc-dims="1" /></noscript></p>
<p><span class="css-16f3y1r e13ogyst0" aria-hidden="true">Daw Aung San Suu Kyi, center, delivered a denial at the International Court of Justice on Wednesday that her government had engaged in genocide against the Rohingya minority.</span><span class="css-cnj6d5 e1z0qqy90"><span class="css-1ly73wi e1tej78p0">Credit&#8230;</span>Koen Van Weel/EPA, via Shutterstock</span></p>
<p>In some years, critics have questioned the worthiness of winners without marquee accomplishments — like the 2012 award to the European Union, for example, or the 2009 award to President Barack Obama, just months into his first term.</p>
<p>n other instances — perhaps most famously the 1973 award to Henry A. Kissinger and his North Vietnamese counterpart, Le Duc Tho, as the Vietnam War was still raging — the track records of winners have been ridiculed. (The singer Tom Lehrer famously said that the choice of Mr. Kissinger had <a class="css-1g7m0tk" title="" href="https://www.goodreads.com/quotes/6485828-political-satire-became-obsolete-when-henry-kissinger-was-awarded-the" target="_blank" rel="noopener noreferrer">rendered political satire obsolete.</a>)</p>
<p class="css-exrw3m evys1bk0">In the case of Ms. Aung San Suu Kyi, some critics have suggested that the criteria for selecting winners should be reassessed — including the possibility that the honor could be rescinded. Such questions are inherent to the prize regardless who is chosen, said Dr. Richard B. Gunderman, a professor at Indiana University who has written about the prize’s history.</p>
<p class="css-exrw3m evys1bk0">“The awarding of the Nobel Peace Prize has always been fraught with peril, subject to the current drift of public opinion and political and nationalistic motives and prejudices,” Dr. Gunderman said.</p>
<p class="css-exrw3m evys1bk0">“Like all human judgments, the Nobel committee’s decisions are prone to error,” he said. “It should do the best it can and then live with the consequences.”</p>
<p class="css-exrw3m evys1bk0">Here are some other notably contentious Nobel Peace Prize nominees and winners:</p>
<h2 id="link-3d5c8446" class="css-3ez4hu eoo0vm40">Hitler and Stalin</h2>
<figure id="attachment_66680" aria-describedby="caption-attachment-66680" style="width: 515px" class="wp-caption alignnone"><img class="wp-image-66680 size-large jetpack-lazy-image" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo.jpg?resize=515%2C400&#038;ssl=1" alt width="515" height="400" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?resize=515%2C400&amp;ssl=1 515w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?resize=250%2C194&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?resize=768%2C596&amp;ssl=1 768w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 515px) 100vw, 515px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo.jpg?resize=515%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-66680 size-large" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo.jpg?resize=515%2C400&#038;ssl=1" alt="" width="515" height="400" srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?resize=515%2C400&amp;ssl=1 515w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?resize=250%2C194&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?resize=768%2C596&amp;ssl=1 768w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804216_23dbfa26-5180-41ff-a852-c376a86e20ac-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 515px) 100vw, 515px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-66680" class="wp-caption-text">Joseph Stalin was nominated for a Nobel prize in 1945 and in 1948.Credit&#8230;Keystone/Getty Images</figcaption></figure>
<p class="css-exrw3m evys1bk0">Adolf Hitler was nominated in 1939 by a member of Sweden’s Parliament, E.G.C. Brandt, who apparently meant it as a satire against the leader of Nazi Germany, and never intended the choice to be seriously considered. But the nomination created such outrage that it was quickly withdrawn.</p>
<p class="css-exrw3m evys1bk0">Joseph Stalin, Hitler’s nemesis and the leader of the Soviet Communist Party, was nominated twice — in 1945 and 1948 — for his efforts to end World War II. Despite Stalin’s murderous purges and pogroms, those nominations were taken in earnest.</p>
<h2 id="link-238abb71" class="css-3ez4hu eoo0vm40">Cordell Hull</h2>
<p><img class="alignnone size-large wp-image-66681 jetpack-lazy-image" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo.jpg?resize=465%2C400&#038;ssl=1" alt width="465" height="400" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?resize=465%2C400&amp;ssl=1 465w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?resize=232%2C200&amp;ssl=1 232w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?resize=768%2C661&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 465px) 100vw, 465px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo.jpg?resize=465%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-large wp-image-66681" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo.jpg?resize=465%2C400&#038;ssl=1" alt="" width="465" height="400" srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?resize=465%2C400&amp;ssl=1 465w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?resize=232%2C200&amp;ssl=1 232w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?resize=768%2C661&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804207_9c3a5a2e-8432-4bf3-862f-09e6e13436ae-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 465px) 100vw, 465px" data-recalc-dims="1" /></noscript></p>
<p><span class="css-16f3y1r e13ogyst0" aria-hidden="true">Secretary of State Cordell Hull in 1939.</span><span class="css-cnj6d5 e1z0qqy90"><span class="css-1ly73wi e1tej78p0">Credit&#8230;</span>Associated Press</span></p>
<p class="css-exrw3m evys1bk0">The American statesmen Cordell Hull won in 1945 for his role in establishing the United Nations. Six years earlier, as President Franklin D. Roosevelt’s secretary of state, he took steps that led Roosevelt to <a class="css-1g7m0tk" title="" href="https://visitpearlharbor.org/cordell-hull-flawed-american-statesman/" target="_blank" rel="noopener noreferrer">deny permission for 950 Jewish refugees </a>aboard the liner St. Louis, fleeing Nazi persecution, to seek asylum in the United States.</p>
<p class="css-exrw3m evys1bk0">Many of the passengers on the trip, known as the <a class="css-1g7m0tk" title="" href="https://www.britannica.com/topic/MS-St-Louis-German-ship" target="_blank" rel="noopener noreferrer">Voyage of the Damned,</a> later died in the Holocaust.</p>
<h2 id="link-6db364" class="css-3ez4hu eoo0vm40">Yasir Arafat</h2>
<figure id="attachment_66682" aria-describedby="caption-attachment-66682" style="width: 602px" class="wp-caption alignnone"><img class="wp-image-66682 size-large jetpack-lazy-image" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo.jpg?resize=602%2C400&#038;ssl=1" alt width="602" height="400" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?resize=602%2C400&amp;ssl=1 602w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?resize=250%2C166&amp;ssl=1 250w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?resize=768%2C510&amp;ssl=1 768w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 602px) 100vw, 602px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo.jpg?resize=602%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-66682 size-large" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo.jpg?resize=602%2C400&#038;ssl=1" alt="" width="602" height="400" srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?resize=602%2C400&amp;ssl=1 602w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?resize=250%2C166&amp;ssl=1 250w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?resize=768%2C510&amp;ssl=1 768w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804243_32310ec8-20f8-498f-9716-62c14ff7ce87-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 602px) 100vw, 602px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-66682" class="wp-caption-text">Yasir Arafat received the Nobel Peace Prize in 1994.Credit&#8230;Menahem Kahana/Agence France-Presse — Getty Images</figcaption></figure>
<p>The chairman of the Palestine Liberation Organization shared the 1994 prize with the Israeli leaders Yitzhak Rabin and Shimon Peres for the Oslo Accords, still widely regarded as the basis for a peace process. But many critics assailed the choice of Mr. Arafat because of his role in acts of terrorism against Israelis.</p>
<div class="css-1fanzo5 StoryBodyCompanionColumn">
<div class="css-53u6y8">
<h2 id="link-17537858" class="css-3ez4hu eoo0vm40">Henry Kissinger and Le Duc Tho</h2>
</div>
<aside class="css-ew4tgv" aria-label="companion column"></aside>
</div>
<div class="css-79elbk" data-testid="photoviewer-wrapper">
<div class="css-z3e15g" data-testid="photoviewer-wrapper-hidden"></div>
<div class="css-16yp27a ehw59r12">
<div class="css-tux0zj ehw59r13" data-testid="photoviewer-overlay">
<div class="css-1bd1bv2 ehw59r14">
<figure id="attachment_66683" aria-describedby="caption-attachment-66683" style="width: 613px" class="wp-caption alignnone"><img class="wp-image-66683 size-large jetpack-lazy-image" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo.jpg?resize=613%2C400&#038;ssl=1" alt width="613" height="400" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?resize=613%2C400&amp;ssl=1 613w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?resize=250%2C163&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?resize=768%2C501&amp;ssl=1 768w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 613px) 100vw, 613px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo.jpg?resize=613%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-66683 size-large" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo.jpg?resize=613%2C400&#038;ssl=1" alt="" width="613" height="400" srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?resize=613%2C400&amp;ssl=1 613w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?resize=250%2C163&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?resize=768%2C501&amp;ssl=1 768w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/merlin_165804309_f002376f-bc92-4922-b367-c68e054b0bed-jumbo-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 613px) 100vw, 613px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-66683" class="wp-caption-text">Le Duc Tho, center left, and Henry Kissinger, center right, during a meeting days before signing a cease-fire agreement in 1973.Credit&#8230;Agence France-Presse — Getty Images</figcaption></figure>
<p class="css-exrw3m evys1bk0">The 1973 prize was awarded to Secretary of State Henry A. Kissinger and the North Vietnam statesman Le Duc Tho for having negotiated a cease-fire in the Vietnam War.</p>
<p class="css-exrw3m evys1bk0">Many critics of the war — which would not be over for two more years — ridiculed the choice of Mr. Kissinger, and his Vietnamese counterpart <a class="css-1g7m0tk" title="" href="https://www.nobelprize.org/prizes/peace/1973/tho/facts/" target="_blank" rel="noopener noreferrer">refused to accept the award</a> on grounds that the United States had violated the cease-fire.</p>
<p class="css-exrw3m evys1bk0"><em class="css-2fg4z9 e1gzwzxm0">An earlier version of this article referred incorrectly to Daw Aung San Suu Kyi’s Nobel Peace Prize. She received it in 1991, not 1994.</em></p>
</div>
</div>
</div>
</div>
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&t=With+Many+Dents+to+Its+Image%2C+Nobel+Peace+Prize+Is+Hit+With+a+Few+More', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=With+Many+Dents+to+Its+Image%2C+Nobel+Peace+Prize+Is+Hit+With+a+Few+More:&url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F&media=https://kichuu.com/wp-content/uploads/2020/03/merlin_165726498_1c40f1db-8aaa-4f72-9888-5b0ab7fa949b-jumbo-scaled.jpg&description=With+Many+Dents+to+Its+Image%2C+Nobel+Peace+Prize+Is+Hit+With+a+Few+More', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=With%20Many%20Dents%20to%20Its%20Image%2C%20Nobel%20Peace%20Prize%20Is%20Hit%20With%20a%20Few%20More&amp;body=https%3A%2F%2Fkichuu.com%2Fwith-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
</div><div id="custom_html-7" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20190303 -->
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3737122119"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/free-all-political-prisoners-stop-politically-motivated-intimidations/" rel="prev"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Political Prisoners" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?w=700&amp;ssl=1 700w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=250%2C187&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=534%2C400&amp;ssl=1 534w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-14-2-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Previous</span><p>Free All Political Prisoners &#038; Stop Politically Motivated Intimidations</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://kichuu.com/record-number-mps-vote-against-daniel-kibrets-place-in-media-board/" rel="next"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-12.04.13-PM-e1584037789512.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Daniel Kibret&#039;s" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-12.04.13-PM-e1584037789512.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-12.04.13-PM-e1584037789512.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/Screen-Shot-2020-03-12-at-12.04.13-PM-e1584037789512.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Next</span><p>Record Number MPs Vote against Daniel Kibret&#8217;s Place in Media Board</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='66677' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2203295603" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="32"/></p></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-64607 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation."><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Human Rights" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">
Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation. Click here to download in PDF OMRHO  presents the state of Human Rights in Ethiopia since the incumbent <a class="mh-excerpt-more" href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-63213 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps"><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Autocrat" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">
Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 9, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps By Jabessa Gurmessa, Finfinne, Oromia, January 09, 2020 1. Introduction The freedom lovers and proponents <a class="mh-excerpt-more" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62609 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Gammaachuu Ayaanaa Gemechu" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit">
Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit By Worku Burayu (PhD), January 1, 2020 During the times of apartheid, it was said that some prisons reached almost 200% of what the prison was built to hold. The exact copy of <a class="mh-excerpt-more" href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62599 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Berhanu Nega" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama">
EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama By Guluma Gemeda,  Ph.D., December 31, 2019 Dr. Berhanu Nega, leader of the Ethiopian Citizens for Social Justice (EZEMA) party, made a <a class="mh-excerpt-more" href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62290 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="IRBUU Struggle" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">
Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa By Bilisummaa Jaalataa, December 26, 2019 Like all African countries, the Oromo (hereafter We/Our/Us) were colonized in the last quarter of the <a class="mh-excerpt-more" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-59364 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Finfinnee" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">
TEN POINTS WHY FINFINNEE IS OROMO CITY											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/10/">October 28, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">TEN POINTS WHY FINFINNEE IS OROMO CITY BY Worku Gadissa, October 29, 2019 Note: Sheger is another name for Finfinnee and both name are used in this article. We are all aware of present highly <a class="mh-excerpt-more" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">[Read More]</a></div>								</div>
</div>
</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66716 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/dn-daanieel-kibrat-hardha-aangoo-akka-argatan-dhageenye/" title="Dn Daani&#8217;eel Kibrat hardha aangoo akka argatan dhageenye.">
Dn Daani&#8217;eel Kibrat hardha aangoo akka argatan dhageenye.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66713 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/bahrain-oman-support-egypt-in-renaissance-dam-dispute-with-ethiopia/" title="Bahrain, Oman Support Egypt in Renaissance Dam Dispute With Ethiopia">
Bahrain, Oman Support Egypt in Renaissance Dam Dispute With Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66703 post type-post status-publish format-standard has-post-thumbnail category-health">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/the-covid-19-virus-reminds-us-dont-fully-trust-dictators-or-their-enablers/" title="THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS">
THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66695 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/help-girls-stay-in-school-in-ethiopia/" title="Help Girls Stay in School in Ethiopia">
Help Girls Stay in School in Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66690 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/abiy-ahmed-waraabesa-halkan-fi-guyyaa-angoo-irratti-basaa-jira/" title="Abiy Ahmed: Waraabesa halkan fi guyyaa angoo irratti basaa jira !">
Abiy Ahmed: Waraabesa halkan fi guyyaa angoo irratti basaa jira !									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66685 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/record-number-mps-vote-against-daniel-kibrets-place-in-media-board/" title="Record Number MPs Vote against Daniel Kibret&#8217;s Place in Media Board">
Record Number MPs Vote against Daniel Kibret&#8217;s Place in Media Board									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66677 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/with-many-dents-to-its-image-nobel-peace-prize-is-hit-with-a-few-more/" title="With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More">
With Many Dents to Its Image, Nobel Peace Prize Is Hit With a Few More									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66674 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/free-all-political-prisoners-stop-politically-motivated-intimidations/" title="Free All Political Prisoners &#038; Stop Politically Motivated Intimidations">
Free All Political Prisoners &#038; Stop Politically Motivated Intimidations									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66670 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/look-this-stupid-task-the-naqamte-administration-requests-donation-on-behalf-of-pp-rip-democracy/" title="RIP democracy!!The Naqamte Administration requests donation on behalf of PP.">
RIP democracy!!The Naqamte Administration requests donation on behalf of PP.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66663 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/paarlaamaa-itoophiyaa-miseensonni-paarlaamaa-muudama-diyaaqon-daaniel-kibrat-morman/" title="Paarlaamaa Itoophiyaa: Miseensonni paarlaamaa muudama Diyaaqon Daani&#8217;el Kibrat morman">
Paarlaamaa Itoophiyaa: Miseensonni paarlaamaa muudama Diyaaqon Daani&#8217;el Kibrat morman									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66655 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/aaddee-adaanach-abeebee-ministeera-galii-irraa-maalif-kaafamte-iddoo-kana-eenyutu-gaafachaa-ture-maalif-gaafatan/" title="&#8220;Aaddee Adaanach Abeebee ministeera galii irraa maalif kaafamte? Iddoo kana eenyutu gaafachaa ture? Maalif gaafatan?">
&#8220;Aaddee Adaanach Abeebee ministeera galii irraa maalif kaafamte? Iddoo kana eenyutu gaafachaa ture? Maalif gaafatan?									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66648 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopias-ambo-city-from-freedom-to-repression-under-abiy-ahmed/" title="Ethiopia’s Ambo city: ‘From freedom to repression under Abiy Ahmed’">
Ethiopia’s Ambo city: ‘From freedom to repression under Abiy Ahmed’									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66645 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/news-alert-saudi-arabia-bans-travel-to-and-from-ethiopia-cites-corona-virus-threat/" title="NEWS ALERT: SAUDI ARABIA BANS TRAVEL TO AND FROM ETHIOPIA, CITES CORONA VIRUS THREAT">
NEWS ALERT: SAUDI ARABIA BANS TRAVEL TO AND FROM ETHIOPIA, CITES CORONA VIRUS THREAT									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66640 post type-post status-publish format-standard has-post-thumbnail category-health">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/eritreas-coronavirus-rules-chinese-italians-iranians-to-be-quarantined/" title="Eritrea&#8217;s coronavirus rules: Chinese, Italians, Iranians to be quarantined">
Eritrea&#8217;s coronavirus rules: Chinese, Italians, Iranians to be quarantined									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66633 post type-post status-publish format-standard has-post-thumbnail category-health">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/coronavirus-hits-senegals-holy-city-as-cleric-declares-faithful-are-immune/" title="Coronavirus hits Senegal&#8217;s holy city as cleric declares faithful are immune">
Coronavirus hits Senegal&#8217;s holy city as cleric declares faithful are immune									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66630 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/news-update-on-detention-of-journalists-by-security-forces/" title="News update on detention of journalists by security forces">
News update on detention of journalists by security forces									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66623 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/breaking-news-%e1%88%b0%e1%89%a0%e1%88%ad-%e1%8b%9c%e1%8a%93-%e1%8b%b6%e1%88%ad-%e1%8c%88%e1%88%98%e1%8b%b6-%e1%8b%b3%e1%88%8c-%e1%89%a0%e1%8d%96%e1%88%8a%e1%88%b5-%e1%89%b3%e1%8d%8d%e1%8a%90/" title="Breaking News  ሰበር ዜና: ዶር ገመዶ ዳሌ በፖሊስ ታፍነው ወደ ሶስተኛ ፖሊስ ጣቢያ መወሰዳቸው ተሰማ!">
Breaking News  ሰበር ዜና: ዶር ገመዶ ዳሌ በፖሊስ ታፍነው ወደ ሶስተኛ ፖሊስ ጣቢያ መወሰዳቸው ተሰማ!									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66577 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8b%88%e1%8a%95%e1%8b%b0%e1%88%b0%e1%8a%95-%e1%8a%a0%e1%8a%95%e1%8b%b1%e1%8a%a0%e1%88%88%e1%88%9d-%e1%8b%ad%e1%89%a3%e1%88%8b%e1%88%8d%e1%8d%a2-%e1%8b%a8%e1%89%a5%e1%88%ae%e1%8b%b5%e1%8a%ab/" title="ወንደሰን አንዱአለም ይባላል። የብሮድካስት ባለስልጣን ምክትል ስራ አስኪያጅ ሲሆን በቅርቡ OMNን ዘግቼ አሳያችኋለሁ ብሎ ለቅርብ የስራ አጋሮቹ በመፎከር ላይ ይገኛል።">
ወንደሰን አንዱአለም ይባላል። የብሮድካስት ባለስልጣን ምክትል ስራ አስኪያጅ ሲሆን በቅርቡ OMNን ዘግቼ አሳያችኋለሁ ብሎ ለቅርብ የስራ አጋሮቹ በመፎከር ላይ ይገኛል።									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 11, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66574 post type-post status-publish format-standard has-post-thumbnail category-health">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/covid-19-is-only-slowly-reaching-africa-thats-no-surprise/" title="COVID-19 is only slowly reaching Africa. That’s no surprise.">
COVID-19 is only slowly reaching Africa. That’s no surprise.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 11, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66571 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/prosperity-partys-fundraising-via-extorsionthe-ruling-party-has-been-forcing-the-business-community-to-give-money/" title="Prosperity Party&#8217;s Fundraising via extorsion!!The ruling party has been forcing the business community to give money">
Prosperity Party&#8217;s Fundraising via extorsion!!The ruling party has been forcing the business community to give money									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 11, 2020</a></span>
</div>
</div>
</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://kichuu.com/2020/03/'> March 2020 </option>
<option value='https://kichuu.com/2020/02/'> February 2020 </option>
<option value='https://kichuu.com/2020/01/'> January 2020 </option>
<option value='https://kichuu.com/2019/12/'> December 2019 </option>
<option value='https://kichuu.com/2019/11/'> November 2019 </option>
<option value='https://kichuu.com/2019/10/'> October 2019 </option>
<option value='https://kichuu.com/2019/09/'> September 2019 </option>
<option value='https://kichuu.com/2019/08/'> August 2019 </option>
<option value='https://kichuu.com/2019/07/'> July 2019 </option>
<option value='https://kichuu.com/2019/06/'> June 2019 </option>
<option value='https://kichuu.com/2019/05/'> May 2019 </option>
<option value='https://kichuu.com/2019/04/'> April 2019 </option>
<option value='https://kichuu.com/2019/03/'> March 2019 </option>
<option value='https://kichuu.com/2019/02/'> February 2019 </option>
<option value='https://kichuu.com/2019/01/'> January 2019 </option>
<option value='https://kichuu.com/2018/12/'> December 2018 </option>
<option value='https://kichuu.com/2018/11/'> November 2018 </option>
<option value='https://kichuu.com/2018/10/'> October 2018 </option>
<option value='https://kichuu.com/2018/09/'> September 2018 </option>
<option value='https://kichuu.com/2018/08/'> August 2018 </option>
<option value='https://kichuu.com/2018/07/'> July 2018 </option>
<option value='https://kichuu.com/2018/06/'> June 2018 </option>
<option value='https://kichuu.com/2018/05/'> May 2018 </option>
<option value='https://kichuu.com/2018/04/'> April 2018 </option>
<option value='https://kichuu.com/2018/03/'> March 2018 </option>
<option value='https://kichuu.com/2018/02/'> February 2018 </option>
<option value='https://kichuu.com/2018/01/'> January 2018 </option>
<option value='https://kichuu.com/2017/12/'> December 2017 </option>
<option value='https://kichuu.com/2017/11/'> November 2017 </option>
<option value='https://kichuu.com/2017/10/'> October 2017 </option>
<option value='https://kichuu.com/2017/09/'> September 2017 </option>
<option value='https://kichuu.com/2017/08/'> August 2017 </option>
<option value='https://kichuu.com/2017/07/'> July 2017 </option>
<option value='https://kichuu.com/2017/06/'> June 2017 </option>
<option value='https://kichuu.com/2017/05/'> May 2017 </option>
<option value='https://kichuu.com/2017/04/'> April 2017 </option>
<option value='https://kichuu.com/2017/03/'> March 2017 </option>
<option value='https://kichuu.com/2017/02/'> February 2017 </option>
<option value='https://kichuu.com/2017/01/'> January 2017 </option>
<option value='https://kichuu.com/2016/12/'> December 2016 </option>
<option value='https://kichuu.com/2016/11/'> November 2016 </option>
<option value='https://kichuu.com/2013/11/'> November 2013 </option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
var dropdown = document.getElementById( "archives-dropdown-2" );
function onSelectChange() {
if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
document.location.href = this.options[ this.selectedIndex ].value;
}
}
dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
<div class="mh-video-container">
<iframe seamless width="1280" height="720"  allowfullscreen data-src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe>
</div>
</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
<caption>March 2020</caption>
<thead>
<tr>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
<th scope="col" title="Sunday">S</th>
</tr>
</thead>
<tfoot>
<tr>
<td colspan="3" id="prev"><a href="https://kichuu.com/2020/02/">&laquo; Feb</a></td>
<td class="pad">&nbsp;</td>
<td colspan="3" id="next" class="pad">&nbsp;</td>
</tr>
</tfoot>
<tbody>
<tr>
<td colspan="6" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2020/03/01/" aria-label="Posts published on March 1, 2020">1</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2020/03/02/" aria-label="Posts published on March 2, 2020">2</a></td><td><a href="https://kichuu.com/2020/03/03/" aria-label="Posts published on March 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/03/04/" aria-label="Posts published on March 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/03/05/" aria-label="Posts published on March 5, 2020">5</a></td><td><a href="https://kichuu.com/2020/03/06/" aria-label="Posts published on March 6, 2020">6</a></td><td><a href="https://kichuu.com/2020/03/07/" aria-label="Posts published on March 7, 2020">7</a></td><td><a href="https://kichuu.com/2020/03/08/" aria-label="Posts published on March 8, 2020">8</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2020/03/09/" aria-label="Posts published on March 9, 2020">9</a></td><td><a href="https://kichuu.com/2020/03/10/" aria-label="Posts published on March 10, 2020">10</a></td><td><a href="https://kichuu.com/2020/03/11/" aria-label="Posts published on March 11, 2020">11</a></td><td id="today"><a href="https://kichuu.com/2020/03/12/" aria-label="Posts published on March 12, 2020">12</a></td><td>13</td><td>14</td><td>15</td>
</tr>
<tr>
<td>16</td><td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td>
</tr>
<tr>
<td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
</tr>
<tr>
<td>30</td><td>31</td>
<td class="pad" colspan="5">&nbsp;</td>
</tr>
</tbody>
</table></div></div>	</aside>	</div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66703 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/the-covid-19-virus-reminds-us-dont-fully-trust-dictators-or-their-enablers/" title="THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="COVID-19 VIRUS" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/coronavirus3223523-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/the-covid-19-virus-reminds-us-dont-fully-trust-dictators-or-their-enablers/" title="THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS">
THE COVID-19 VIRUS REMINDS US: DON&#8217;T FULLY TRUST DICTATORS OR THEIR ENABLERS									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66640 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/eritreas-coronavirus-rules-chinese-italians-iranians-to-be-quarantined/" title="Eritrea&#8217;s coronavirus rules: Chinese, Italians, Iranians to be quarantined"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Eritrea&#039;s coronavirus rules" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045731-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/eritreas-coronavirus-rules-chinese-italians-iranians-to-be-quarantined/" title="Eritrea&#8217;s coronavirus rules: Chinese, Italians, Iranians to be quarantined">
Eritrea&#8217;s coronavirus rules: Chinese, Italians, Iranians to be quarantined									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66633 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/coronavirus-hits-senegals-holy-city-as-cleric-declares-faithful-are-immune/" title="Coronavirus hits Senegal&#8217;s holy city as cleric declares faithful are immune"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Coronavirus" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/03/1024x576_1045403-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/coronavirus-hits-senegals-holy-city-as-cleric-declares-faithful-are-immune/" title="Coronavirus hits Senegal&#8217;s holy city as cleric declares faithful are immune">
Coronavirus hits Senegal&#8217;s holy city as cleric declares faithful are immune									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 12, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Mohammed Hajjii" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66261 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/oromo-music-2020-jambo-jote-jira-jirtu-sabo-koo-new-2020-songs/" title="Oromo Music 2020 Jambo Jote Jira Jirtu Sabo Koo New 2020 Songs"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Jambo Jote" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?w=700&amp;ssl=1 700w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=250%2C187&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=534%2C400&amp;ssl=1 534w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=768%2C576&amp;ssl=1 768w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/pizap-2-2-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/oromo-music-2020-jambo-jote-jira-jirtu-sabo-koo-new-2020-songs/" title="Oromo Music 2020 Jambo Jote Jira Jirtu Sabo Koo New 2020 Songs">
Oromo Music 2020 Jambo Jote Jira Jirtu Sabo Koo New 2020 Songs									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 7, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-65057 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/saliha-sami-walloo-new-oromo-music-2020-official-video/" title="Saliha Sami **Walloo** New  Oromo Music 2020 Official Video."><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-7-4-e1582026024391.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Saliha Sami" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-7-4-e1582026024391.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/saliha-sami-walloo-new-oromo-music-2020-official-video/" title="Saliha Sami **Walloo** New  Oromo Music 2020 Official Video.">
Saliha Sami **Walloo** New  Oromo Music 2020 Official Video.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 18, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64343 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/new-oromo-music-bilsigina-diina-kenyaa-2020-ofk-dhaba-kenya-walisa-abdi-fadis/" title="New Oromo Music Bilsigina Diina Kenyaa 2020 OFK Dhaba Kenya Walisa Abdi Fadis"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-4-1-e1580647503244.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Bilsigina" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-4-1-e1580647503244.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/new-oromo-music-bilsigina-diina-kenyaa-2020-ofk-dhaba-kenya-walisa-abdi-fadis/" title="New Oromo Music Bilsigina Diina Kenyaa 2020 OFK Dhaba Kenya Walisa Abdi Fadis">
New Oromo Music Bilsigina Diina Kenyaa 2020 OFK Dhaba Kenya Walisa Abdi Fadis									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 2, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66348 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/drilling-officially-kicked-off-for-tulu-moye-geothermal-project-in-ethiopia/" title="Drilling officially kicked off for Tulu Moye geothermal project in Ethiopia"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Tulu Moye geothermal project" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/drilling-officially-kicked-off-for-tulu-moye-geothermal-project-in-ethiopia/" title="Drilling officially kicked off for Tulu Moye geothermal project in Ethiopia">
Drilling officially kicked off for Tulu Moye geothermal project in Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66161 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/heat-from-the-earth-toshiba-and-toyota-win-geothermal-deal-in-ethiopia/" title="Heat from the earth: Toshiba and Toyota win geothermal deal in Ethiopia"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Geothermal" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/heat-from-the-earth-toshiba-and-toyota-win-geothermal-deal-in-ethiopia/" title="Heat from the earth: Toshiba and Toyota win geothermal deal in Ethiopia">
Heat from the earth: Toshiba and Toyota win geothermal deal in Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66073 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/us-ready-to-back-ethiopian-reform-with-5bn-investment/" title="US ready to back Ethiopian reform with $5bn investment"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/http___com.ft_.imagepublish.upp-prod-us.s3.amazonaws.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethiopian reform" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/http___com.ft_.imagepublish.upp-prod-us.s3.amazonaws.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/http___com.ft_.imagepublish.upp-prod-us.s3.amazonaws.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/http___com.ft_.imagepublish.upp-prod-us.s3.amazonaws.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/http___com.ft_.imagepublish.upp-prod-us.s3.amazonaws.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/http___com.ft_.imagepublish.upp-prod-us.s3.amazonaws.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/us-ready-to-back-ethiopian-reform-with-5bn-investment/" title="US ready to back Ethiopian reform with $5bn investment">
US ready to back Ethiopian reform with $5bn investment									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 5, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
</div>
</footer>
<div class="mh-footer-nav-mobile"></div>
<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
</nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright @2016 kichuu.com              		</p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-58166095-1', 'auto');
ga('send', 'pageview');
</script>			<div id="fb-root"></div>
<script>
(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.6.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://kichuu.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202011.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'111820558',post:'66677',tz:'-4',srv:'kichuu.com'} ]);
_stq.push([ 'clickTrackerInit', '111820558', '66677' ]);
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.831283092499 seconds, on 12-03-20 19:27:52 -->