<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#039;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa Kichuu</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v12.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#039;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#039;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa Kichuu" />
<meta property="og:description" content="ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#039;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa" />
<meta property="og:url" content="https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:publisher" content="https://www.facebook.com/kichuu.info/" />
<meta property="article:section" content="TV" />
<meta property="article:published_time" content="2019-12-27T11:52:54+00:00" />
<meta property="og:image" content="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-19-3-e1577447176669.jpg?fit=650%2C487&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-19-3-e1577447176669.jpg?fit=650%2C487&#038;ssl=1" />
<meta property="og:image:width" content="650" />
<meta property="og:image:height" content="487" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507","name":"fmegersa","logo":{"@id":"https://kichuu.com/#personlogo"},"sameAs":[]},{"@type":"WebSite","@id":"https://kichuu.com/#website","url":"https://kichuu.com/","name":"Kichuu","publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"potentialAction":{"@type":"SearchAction","target":"https://kichuu.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#primaryimage","url":"https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-19-3-e1577447176669.jpg?fit=650%2C487&ssl=1","width":650,"height":487,"caption":"Koloneel Gammachuu Ayyaanaa"},{"@type":"WebPage","@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#webpage","url":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/","inLanguage":"en-US","name":"ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#039;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa Kichuu","isPartOf":{"@id":"https://kichuu.com/#website"},"primaryImageOfPage":{"@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#primaryimage"},"datePublished":"2019-12-27T11:52:54+00:00","dateModified":"2019-12-27T11:52:54+00:00","description":"ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji'oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa"},{"@type":"Article","@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#article","isPartOf":{"@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#webpage"},"author":{"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330"},"headline":"ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa","datePublished":"2019-12-27T11:52:54+00:00","dateModified":"2019-12-27T11:52:54+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#webpage"},"publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"image":{"@id":"https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#primaryimage"},"articleSection":"TV"},{"@type":["Person"],"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330","name":"kichuu_admin","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa Comments Feed" href="https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/feed/" />
<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ -->		<script>
//@formatter:off
advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
</script><link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/style.css?ver=3.8.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/dhrvjwy1/853o7.css" media="all"/>
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.6'></script>
<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://kichuu.com/?p=62294' />
<link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>
<script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=270%2C270&#038;ssl=1" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-62294 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-top">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kichuu" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?w=331&amp;ssl=1 331w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=300%2C73&amp;ssl=1 300w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=326%2C81&amp;ssl=1 326w" data-lazy-sizes="(max-width: 331px) 100vw, 331px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="6220502696"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
News Ticker<i class="fa fa-chevron-right"></i>		</div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/%e1%88%b2%e1%8c%80%e1%88%98%e1%88%ad-%e1%8a%90%e1%8d%8d%e1%8c%a0%e1%8a%9b-%e1%88%8b%e1%89%83%e1%8c%a0%e1%88%88%e1%8b%8d-%e1%8a%a6%e1%88%ae%e1%88%9d%e1%8b%ab-%e1%8b%8d%e1%88%b5%e1%8c%a5-%e1%8b%ab/" title="ሲጀመር ነፍጠኛ ላቃጠለው ኦሮምያ ውስጥ ያሉ የኦሮሞ ህዝብ ንብረት የሆኑ ቤተ እምነቶች ሊነኩ አይችሉም ጥበቃም አያስፈልግም ።">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
ሲጀመር ነፍጠኛ ላቃጠለው ኦሮምያ ውስጥ ያሉ የኦሮሞ ህዝብ ንብረት የሆኑ ቤተ እምነቶች ሊነኩ አይችሉም ጥበቃም አያስፈልግም ።						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Videos							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/hiriira-mormii-guddaa-lafa-shochoosu-ganama-hara-guutuu-biyyatti-keessatti-gaggeeffamaa-jira-iddoo-hiriira-mormii-gaggeessa-jiran/" title="Hiriira Mormii guddaa Lafa shochoosu ganama har&#8217;a guutuu biyyatti keessatti gaggeeffamaa jira! &#8220;">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Hiriira Mormii guddaa Lafa shochoosu ganama har&#8217;a guutuu biyyatti keessatti gaggeeffamaa jira! &#8220;						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Amharic							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/%e1%8a%a8%e1%8b%9a%e1%88%85-%e1%88%81%e1%88%89-%e1%8c%8d%e1%8d%8d-%e1%8a%a5%e1%8a%93-%e1%88%98%e1%8a%a8%e1%88%ab-%e1%89%a0%e1%8a%8b%e1%88%8b%e1%88%9d-%e1%89%a2%e1%88%86%e1%8a%95-%e1%8a%ae-%e1%88%8d/" title="ከዚህ ሁሉ ግፍ እና መከራ በኋላም ቢሆን ኮ/ል ገመቹ አያና ዶ/ር አብይን ONN ላይ እንዲህ ገልፆታል  ONN ላይ እንዲህ ገልፆታል">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
ከዚህ ሁሉ ግፍ እና መከራ በኋላም ቢሆን ኮ/ል ገመቹ አያና ዶ/ር አብይን ONN ላይ እንዲህ ገልፆታል  ONN ላይ እንዲህ ገልፆታል						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Amharic							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/omn-qophii-xiyyeeffannaa-turtiin-kolonel-gammaachuu-ayaanaa-waliin-mudde-27-2019/" title="OMN: Qophii Xiyyeeffannaa, turtiin Kolonel Gammaachuu Ayaanaa waliin (Mudde 27/2019)">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
OMN: Qophii Xiyyeeffannaa, turtiin Kolonel Gammaachuu Ayaanaa waliin (Mudde 27/2019)						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
TV							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/%e1%8a%a6%e1%8a%90%e1%8c%8d-%e1%8a%a8%e1%8a%a6%e1%88%ae%e1%88%9e-%e1%8b%a8%e1%8d%96%e1%88%88%e1%89%b2%e1%8a%ab-%e1%8d%93%e1%88%ad%e1%89%b2%e1%8b%8e%e1%89%bd-%e1%8a%a5%e1%8a%93-%e1%8a%a8%e1%88%8c/" title="ኦነግ ከኦሮሞ የፖለቲካ ፓርቲዎች እና ከሌሎችም ኃይሎች ጋር ግንባር በመፍጠር በመጪው">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
ኦነግ ከኦሮሞ የፖለቲካ ፓርቲዎች እና ከሌሎችም ኃይሎች ጋር ግንባር በመፍጠር በመጪው						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Videos							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/ethiopia-among-countries-listed-by-foreign-policy-magazines-10-conflicts-to-watch-in-2020/" title="Ethiopia:  Among countries listed by Foreign Policy magazine&#8217;s &#8220;10 Conflicts to watch in 2020.&#8221;">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Ethiopia:  Among countries listed by Foreign Policy magazine&#8217;s &#8220;10 Conflicts to watch in 2020.&#8221;						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/21st-century-leaders-use-their-brain-cells-more-than-their-muscle-tissues-%e2%80%95-israelmore-ayivo/" title="“&#8230;21st century leaders use their brain cells more than their muscle tissues!” ― Israelmore Ayivo">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
“&#8230;21st century leaders use their brain cells more than their muscle tissues!” ― Israelmore Ayivo						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/mootummaan-amma-jiru-kuni-kan-inni-ijaarame-qubattotaa-miniliki-fi-daldaltoota-lafa-oromoo-kan-taate-opdoti-dha/" title="Mootummaan amma jiru kuni kan inni ijaarame qubattotaa miniliki fi daldaltoota lafa Oromoo kan taate OPDOti dha.">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Mootummaan amma jiru kuni kan inni ijaarame qubattotaa miniliki fi daldaltoota lafa Oromoo kan taate OPDOti dha.						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
TV							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/" title="ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 27, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
TV							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ December 26, 2019 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Odaa Post							</span>
</a>
</li>		</ul>
</div>
</div>						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com/category/afaan-oromoo/tv/" itemprop="url"><span itemprop="title">TV</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa</nav>
<article id="post-62294" class="post-62294 post type-post status-publish format-standard has-post-thumbnail hentry category-tv">
<header class="entry-header clearfix"><h1 class="entry-title">ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</header>
<div id="custom_html-2" class="widget_text mh-widget mh-posts-1 widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Above Single Post</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div>	<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&t=ONN%3A+Gaaffii+fi+deebii+Qondaala+ABO+Hidhaa+Ji%E2%80%99oota+11+booda+Kan+Mana+Hidhaarraa+gadi+lakkifame+Koloneel+Gammachuu+Ayyaanaa+waliin+Taasifame+-Kutaa+1ffaa', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=ONN%3A+Gaaffii+fi+deebii+Qondaala+ABO+Hidhaa+Ji%E2%80%99oota+11+booda+Kan+Mana+Hidhaarraa+gadi+lakkifame+Koloneel+Gammachuu+Ayyaanaa+waliin+Taasifame+-Kutaa+1ffaa:&url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&media=https://kichuu.com/wp-content/uploads/2019/12/pizap-19-3-e1577447176669.jpg&description=ONN%3A+Gaaffii+fi+deebii+Qondaala+ABO+Hidhaa+Ji%E2%80%99oota+11+booda+Kan+Mana+Hidhaarraa+gadi+lakkifame+Koloneel+Gammachuu+Ayyaanaa+waliin+Taasifame+-Kutaa+1ffaa', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=ONN%3A%20Gaaffii%20fi%20deebii%20Qondaala%20ABO%20Hidhaa%20Ji%E2%80%99oota%2011%20booda%20Kan%20Mana%20Hidhaarraa%20gadi%20lakkifame%20Koloneel%20Gammachuu%20Ayyaanaa%20waliin%20Taasifame%20-Kutaa%201ffaa&amp;body=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
<div class="kichu-before-content" id="kichu-1222940229"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><p><strong>ONN: Muddee 26, 2019. Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa</strong></p>
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20191026 -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="2237740205"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><iframe style="border: none; overflow: hidden;" src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FONNRoom%2Fvideos%2F840131959751391%2F&amp;show_text=0&amp;width=560" width="560" height="315" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></p>
<hr />
<p><strong>Haadha Oromoo : Ilmoon ishee murtii dhabee mana hidhaatti dararamu!!</strong></p>
<p><img class="alignnone size-large wp-image-62295 jetpack-lazy-image" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=300%2C400&#038;ssl=1" alt width="300" height="400" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=300%2C400&amp;ssl=1 300w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=150%2C200&amp;ssl=1 150w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?w=712&amp;ssl=1 712w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=300%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-large wp-image-62295" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=300%2C400&#038;ssl=1" alt="" width="300" height="400" srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=300%2C400&amp;ssl=1 300w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?resize=150%2C200&amp;ssl=1 150w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/80861812_2276193066012922_5722166623310184448_n.jpg?w=712&amp;ssl=1 712w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript></p>
<hr />
<p><strong class="pg-title">Koloneel Gammachuu Ayyaanaa Utuu Hin Se’in Maqaan Koo Warra Hiikaman Waliin Waamame Jedhan</strong></p>
<figure id="attachment_62296" aria-describedby="caption-attachment-62296" style="width: 650px" class="wp-caption alignnone"><img class="wp-image-62296 size-large jetpack-lazy-image" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/5B6E9181-9736-4F71-8D8F-5AF97D8E57E0_w1023_r1_s.jpg?resize=650%2C365&#038;ssl=1" alt width="650" height="365" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/5B6E9181-9736-4F71-8D8F-5AF97D8E57E0_w1023_r1_s.jpg?resize=650%2C365&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-62296 size-large" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/5B6E9181-9736-4F71-8D8F-5AF97D8E57E0_w1023_r1_s.jpg?resize=650%2C365&#038;ssl=1" alt="" width="650" height="365" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-62296" class="wp-caption-text">Koloneel Gammachuu Ayyaanaa</figcaption></figure>
<p><span class="dateline">FINFINNEE — (<a href="https://www.voaafaanoromoo.com/a/5221304.html?fbclid=IwAR0Pzb_kbCrD6hH42tm0bffrEkoV98sSm5xEHldqhbSgRcNbL5_ipOqf2ns" target="_blank" rel="noopener noreferrer">voaafaanoromoo</a>)&#8211;</span>Aangwaan waraanaa Adda Bilisummaa Oromoo duraanii Koloneel Gammachuu Ayyaanaa shoroorkeessummaa fi saamicha baankilee Lixa Oromiya qindeessuun shakkamanii hidhaa baatilee 11 booda gadhiifamanii jiru.</p>
<p>Beellamni koloneel Gammachuu fi namoota 19 isaan <a href="https://kichuu.com/manni-hidhaa-maakalaawii-ummataaf-banaa-tae/">waliin galmee tokko</a> irratti himataman akka lakkoofsa Itoophiyaatti Muddee 21bara 2012 kan bellamamee kan qabameef yoo ta’u/ Konoleel Gammachuun gaafa Muddee 14/2012 hiikaman jedhan Abukaatoon isaanii Dr. Tokkummaa Dhaabaa.</p>
<p>Abbaan alangaa himata addaan kutuuf mirga qaba, sababa maalinis jedhamee hin gaafatamu. Haalli konoleer Gammachuun itti hiikamanis kanumaan wal fakkaata jechuun Raadiyoon Sagalee ameerikaatti himan Abukaatoon kun.<br />
<iframe src="https://www.voaafaanoromoo.com/embed/player/0/5202717.html?type=audio" width="100%" height="144" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></p>
<hr />
<blockquote class="twitter-tweet">
<p dir="ltr" lang="in">Profeser Mohammed hasan : Dr Abiyyi Ahmed seenaa Oromoo waan tokko beeka natti infakkaatu seenaa Ethiopias inbeeku <a href="https://t.co/8JMZXyQKo8">https://t.co/8JMZXyQKo8</a> <a href="https://t.co/cPDNoNGb8p">pic.twitter.com/cPDNoNGb8p</a></p>
<p>— Kichuu (@kichuu24) <a href="https://twitter.com/kichuu24/status/1210175579485540352?ref_src=twsrc%5Etfw">December 26, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="et">“Mootummaan amma jiru kun, kan eenyuuti kan jedhu deebi’ee gaaffii nutti ta’eera!” Obbo Leencoo Lataa <a href="https://t.co/XhPlbn58Kj">https://t.co/XhPlbn58Kj</a> <a href="https://t.co/PMlrPyiyN6">pic.twitter.com/PMlrPyiyN6</a></p>
<p>— Kichuu (@kichuu24) <a href="https://twitter.com/kichuu24/status/1209863324399292416?ref_src=twsrc%5Etfw">December 25, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="kichu-k20191225below" id="kichu-1755949472"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&t=ONN%3A+Gaaffii+fi+deebii+Qondaala+ABO+Hidhaa+Ji%E2%80%99oota+11+booda+Kan+Mana+Hidhaarraa+gadi+lakkifame+Koloneel+Gammachuu+Ayyaanaa+waliin+Taasifame+-Kutaa+1ffaa', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=ONN%3A+Gaaffii+fi+deebii+Qondaala+ABO+Hidhaa+Ji%E2%80%99oota+11+booda+Kan+Mana+Hidhaarraa+gadi+lakkifame+Koloneel+Gammachuu+Ayyaanaa+waliin+Taasifame+-Kutaa+1ffaa:&url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F&media=https://kichuu.com/wp-content/uploads/2019/12/pizap-19-3-e1577447176669.jpg&description=ONN%3A+Gaaffii+fi+deebii+Qondaala+ABO+Hidhaa+Ji%E2%80%99oota+11+booda+Kan+Mana+Hidhaarraa+gadi+lakkifame+Koloneel+Gammachuu+Ayyaanaa+waliin+Taasifame+-Kutaa+1ffaa', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=ONN%3A%20Gaaffii%20fi%20deebii%20Qondaala%20ABO%20Hidhaa%20Ji%E2%80%99oota%2011%20booda%20Kan%20Mana%20Hidhaarraa%20gadi%20lakkifame%20Koloneel%20Gammachuu%20Ayyaanaa%20waliin%20Taasifame%20-Kutaa%201ffaa&amp;body=https%3A%2F%2Fkichuu.com%2Fonn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
</div><div id="text-3" class="mh-widget mh-posts-2 widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Below Single Post</span></h4>			<div class="textwidget"><p><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></p>
</div>
</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" rel="prev"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="IRBUU Struggle" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Previous</span><p>Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://kichuu.com/mootummaan-amma-jiru-kuni-kan-inni-ijaarame-qubattotaa-miniliki-fi-daldaltoota-lafa-oromoo-kan-taate-opdoti-dha/" rel="next"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-22-3-e1577449755493.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-22-3-e1577449755493.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Next</span><p>Mootummaan amma jiru kuni kan inni ijaarame qubattotaa miniliki fi daldaltoota lafa Oromoo kan taate OPDOti dha.</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='62294' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b10b560a01" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="77"/></p></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62290 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="IRBUU Struggle" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">
Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa By Bilisummaa Jaalataa, December 26, 2019 Like all African countries, the Oromo (hereafter We/Our/Us) were colonized in the last quarter of the <a class="mh-excerpt-more" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-59364 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Finfinnee" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">
TEN POINTS WHY FINFINNEE IS OROMO CITY											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/10/">October 28, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">TEN POINTS WHY FINFINNEE IS OROMO CITY BY Worku Gadissa, October 29, 1019 Note: Sheger is another name for Finfinnee and both name are used in this article. We are all aware of present highly <a class="mh-excerpt-more" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-57157 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/citizenship-versus-identity-the-current-political-discourse-in-ethiopia/" title="Citizenship versus Identity: the current political discourse in Ethiopia"><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Citizenship" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?zoom=3&amp;resize=326%2C245&amp;ssl=1 978w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/citizenship-versus-identity-the-current-political-discourse-in-ethiopia/" title="Citizenship versus Identity: the current political discourse in Ethiopia">
Citizenship versus Identity: the current political discourse in Ethiopia											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/09/">September 26, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Citizenship versus Identity: the current political discourse in Ethiopia By Alemayehu Biru (PhD), September 26, 2019 This topic bears a very common binary way of putting complex sociopolitical issues by politicians and, at times, even <a class="mh-excerpt-more" href="https://kichuu.com/citizenship-versus-identity-the-current-political-discourse-in-ethiopia/" title="Citizenship versus Identity: the current political discourse in Ethiopia">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-49518 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/personal-experience-when-visiting-oromia-cultural-center-in-finfinnee/" title="Personal experience when visiting Oromia Cultural Center in Finfinnee!"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/IMG_7964-e1554554568939.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Oromia Cultural Center" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/IMG_7964-e1554554568939.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/personal-experience-when-visiting-oromia-cultural-center-in-finfinnee/" title="Personal experience when visiting Oromia Cultural Center in Finfinnee!">
Personal experience when visiting Oromia Cultural Center in Finfinnee!											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 7, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Personal Experience when visiting Oromia Cultural Center in Finfinnee! I was happy that I was able to go back to my beautiful, native country Oromia/Ethiopia! The trip was pleasant and comfortable, luckily I was sitting <a class="mh-excerpt-more" href="https://kichuu.com/personal-experience-when-visiting-oromia-cultural-center-in-finfinnee/" title="Personal experience when visiting Oromia Cultural Center in Finfinnee!">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-49374 post type-post status-publish format-standard has-post-thumbnail category-africa category-news-afaan-oromoo category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/misooma-oromiyaaf-lafaa-fi-qabeenya-oromiyaa-bilisoomsu/" title="Misooma Oromiyaaf Lafaa fi Qabeenya Oromiyaa .."><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/03/Misoma55-e1554105543487.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Oromiyaa" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/03/Misoma55-e1554105543487.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/misooma-oromiyaaf-lafaa-fi-qabeenya-oromiyaa-bilisoomsu/" title="Misooma Oromiyaaf Lafaa fi Qabeenya Oromiyaa ..">
Misooma Oromiyaaf Lafaa fi Qabeenya Oromiyaa ..											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 1, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Misooma Oromiyaaf Lafaa fi Qabeenya Oromiyaa Bilisoomsu; Liberating the Land and Resources for the Development of Oromiyaa Itana Gammada, March 31, 2019 Afaan Oromoo fi Afaan Englizi (Afaan Oromo and English translation follows) Walbarsiisa Sabi <a class="mh-excerpt-more" href="https://kichuu.com/misooma-oromiyaaf-lafaa-fi-qabeenya-oromiyaa-bilisoomsu/" title="Misooma Oromiyaaf Lafaa fi Qabeenya Oromiyaa ..">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-49152 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/desperation-frustration-and-violence-against-the-oromo-ginbot-7-ethsat-and-the-dawit-wolde-giorgis-factor/" title="Desperation, Frustration and Violence against the Oromo: Ginbot-7, Ethsat and the Dawit Wolde Giorgis Factor"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/03/castro.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Ginbot-7" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/03/castro.jpg?w=367&amp;ssl=1 367w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/03/castro.jpg?resize=250%2C187&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/03/castro.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/03/castro.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/03/castro.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/desperation-frustration-and-violence-against-the-oromo-ginbot-7-ethsat-and-the-dawit-wolde-giorgis-factor/" title="Desperation, Frustration and Violence against the Oromo: Ginbot-7, Ethsat and the Dawit Wolde Giorgis Factor">
Desperation, Frustration and Violence against the Oromo: Ginbot-7, Ethsat and the Dawit Wolde Giorgis Factor											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/03/">March 18, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Desperation, Frustration and Violence against the Oromo: Ginbot-7, Ethsat and the Dawit Wolde Giorgis Factor By Leencoo Gidiraa (PhD), March 14, 2019 On March 13, 2019, in an apparently coordinated fashion, Ginbot-7[1], Ethsat[2] and Dawit <a class="mh-excerpt-more" href="https://kichuu.com/desperation-frustration-and-violence-against-the-oromo-ginbot-7-ethsat-and-the-dawit-wolde-giorgis-factor/" title="Desperation, Frustration and Violence against the Oromo: Ginbot-7, Ethsat and the Dawit Wolde Giorgis Factor">[Read More]</a></div>								</div>
</div>
</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62331 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%88%b2%e1%8c%80%e1%88%98%e1%88%ad-%e1%8a%90%e1%8d%8d%e1%8c%a0%e1%8a%9b-%e1%88%8b%e1%89%83%e1%8c%a0%e1%88%88%e1%8b%8d-%e1%8a%a6%e1%88%ae%e1%88%9d%e1%8b%ab-%e1%8b%8d%e1%88%b5%e1%8c%a5-%e1%8b%ab/" title="ሲጀመር ነፍጠኛ ላቃጠለው ኦሮምያ ውስጥ ያሉ የኦሮሞ ህዝብ ንብረት የሆኑ ቤተ እምነቶች ሊነኩ አይችሉም ጥበቃም አያስፈልግም ።">
ሲጀመር ነፍጠኛ ላቃጠለው ኦሮምያ ውስጥ ያሉ የኦሮሞ ህዝብ ንብረት የሆኑ ቤተ እምነቶች ሊነኩ አይችሉም ጥበቃም አያስፈልግም ።									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62324 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/hiriira-mormii-guddaa-lafa-shochoosu-ganama-hara-guutuu-biyyatti-keessatti-gaggeeffamaa-jira-iddoo-hiriira-mormii-gaggeessa-jiran/" title="Hiriira Mormii guddaa Lafa shochoosu ganama har&#8217;a guutuu biyyatti keessatti gaggeeffamaa jira! &#8220;">
Hiriira Mormii guddaa Lafa shochoosu ganama har&#8217;a guutuu biyyatti keessatti gaggeeffamaa jira! &#8220;									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62321 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8a%a8%e1%8b%9a%e1%88%85-%e1%88%81%e1%88%89-%e1%8c%8d%e1%8d%8d-%e1%8a%a5%e1%8a%93-%e1%88%98%e1%8a%a8%e1%88%ab-%e1%89%a0%e1%8a%8b%e1%88%8b%e1%88%9d-%e1%89%a2%e1%88%86%e1%8a%95-%e1%8a%ae-%e1%88%8d/" title="ከዚህ ሁሉ ግፍ እና መከራ በኋላም ቢሆን ኮ/ል ገመቹ አያና ዶ/ር አብይን ONN ላይ እንዲህ ገልፆታል  ONN ላይ እንዲህ ገልፆታል">
ከዚህ ሁሉ ግፍ እና መከራ በኋላም ቢሆን ኮ/ል ገመቹ አያና ዶ/ር አብይን ONN ላይ እንዲህ ገልፆታል  ONN ላይ እንዲህ ገልፆታል									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62318 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/omn-qophii-xiyyeeffannaa-turtiin-kolonel-gammaachuu-ayaanaa-waliin-mudde-27-2019/" title="OMN: Qophii Xiyyeeffannaa, turtiin Kolonel Gammaachuu Ayaanaa waliin (Mudde 27/2019)">
OMN: Qophii Xiyyeeffannaa, turtiin Kolonel Gammaachuu Ayaanaa waliin (Mudde 27/2019)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62313 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8a%a6%e1%8a%90%e1%8c%8d-%e1%8a%a8%e1%8a%a6%e1%88%ae%e1%88%9e-%e1%8b%a8%e1%8d%96%e1%88%88%e1%89%b2%e1%8a%ab-%e1%8d%93%e1%88%ad%e1%89%b2%e1%8b%8e%e1%89%bd-%e1%8a%a5%e1%8a%93-%e1%8a%a8%e1%88%8c/" title="ኦነግ ከኦሮሞ የፖለቲካ ፓርቲዎች እና ከሌሎችም ኃይሎች ጋር ግንባር በመፍጠር በመጪው">
ኦነግ ከኦሮሞ የፖለቲካ ፓርቲዎች እና ከሌሎችም ኃይሎች ጋር ግንባር በመፍጠር በመጪው									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62310 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-among-countries-listed-by-foreign-policy-magazines-10-conflicts-to-watch-in-2020/" title="Ethiopia:  Among countries listed by Foreign Policy magazine&#8217;s &#8220;10 Conflicts to watch in 2020.&#8221;">
Ethiopia:  Among countries listed by Foreign Policy magazine&#8217;s &#8220;10 Conflicts to watch in 2020.&#8221;									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62303 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/21st-century-leaders-use-their-brain-cells-more-than-their-muscle-tissues-%e2%80%95-israelmore-ayivo/" title="“&#8230;21st century leaders use their brain cells more than their muscle tissues!” ― Israelmore Ayivo">
“&#8230;21st century leaders use their brain cells more than their muscle tissues!” ― Israelmore Ayivo									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62299 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/mootummaan-amma-jiru-kuni-kan-inni-ijaarame-qubattotaa-miniliki-fi-daldaltoota-lafa-oromoo-kan-taate-opdoti-dha/" title="Mootummaan amma jiru kuni kan inni ijaarame qubattotaa miniliki fi daldaltoota lafa Oromoo kan taate OPDOti dha.">
Mootummaan amma jiru kuni kan inni ijaarame qubattotaa miniliki fi daldaltoota lafa Oromoo kan taate OPDOti dha.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62294 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/onn-gaaffii-fi-deebii-qondaala-abo-hidhaa-jioota-11-booda-kan-mana-hidhaarraa-ga/" title="ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa">
ONN: Gaaffii fi deebii Qondaala ABO Hidhaa Ji&#8217;oota 11 booda Kan Mana Hidhaarraa gadi lakkifame Koloneel Gammachuu Ayyaanaa waliin Taasifame -Kutaa 1ffaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 27, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62290 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">
Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62280 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/lammaa-magarsaa-pireezidantiin-duraanii-oromiyaa-attamiin-siyaasa-itoophiyaa-keessatti-gurra-horatan/" title="Lammaa Magarsaa: Pireezidantiin duraanii Oromiyaa attamiin siyaasa Itoophiyaa keessatti gurra horatan?">
Lammaa Magarsaa: Pireezidantiin duraanii Oromiyaa attamiin siyaasa Itoophiyaa keessatti gurra horatan?									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62275 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/profeser-mohammed-hasan-dr-abiyyi-ahmed-seenaa-oromoo-waan-tokko-beeka-natti-infakkaatu-seenaa-ethiopias-inbeeku/" title="Profeser Mohammed hasan : Dr Abiyyi Ahmed seenaa Oromoo waan tokko beeka natti infakkaatu seenaa Ethiopias inbeeku">
Profeser Mohammed hasan : Dr Abiyyi Ahmed seenaa Oromoo waan tokko beeka natti infakkaatu seenaa Ethiopias inbeeku									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62263 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/lixa-shaggar-hanga-ammaatti-mormii-malee-deeggarsi-hin-jiru-paartiin-bilginnaa-salphachuun-ittuma-fufeera/" title="Lixa Shaggar !! Hanga Ammaatti mormii malee deeggarsi Hin jiru.Paartiin bilginnaa salphachuun ittuma fufeera.">
Lixa Shaggar !! Hanga Ammaatti mormii malee deeggarsi Hin jiru.Paartiin bilginnaa salphachuun ittuma fufeera.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62255 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/oromoo-nafxanyaa-taee-fi-nafxanyaa-oromoo-taetu-waan-lammaa-magarsaa-afarsaa-jira/" title="Oromoo nafxanyaa ta&#8217;ee fi nafxanyaa oromoo ta&#8217;etu waan Lammaa Magarsaa afarsaa jira.">
Oromoo nafxanyaa ta&#8217;ee fi nafxanyaa oromoo ta&#8217;etu waan Lammaa Magarsaa afarsaa jira.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62238 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%89%a0%e1%8c%8b%e1%88%9d%e1%89%a4%e1%88%8b-%e1%8a%ad%e1%88%8d%e1%88%8d-%e1%89%a0%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%a5%e1%89%b5-%e1%88%98%e1%8a%aa%e1%8a%93-%e1%8b%a8%e1%8c%a6%e1%88%ad-%e1%88%98/" title="በጋምቤላ ክልል በመንግሥት መኪና የጦር መሳሪያ ሲያዘዋውሩ የተገኙ ግለሰቦች በቁጥጥር ስር ዋሉ">
በጋምቤላ ክልል በመንግሥት መኪና የጦር መሳሪያ ሲያዘዋውሩ የተገኙ ግለሰቦች በቁጥጥር ስር ዋሉ									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62233 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/six-things-to-know-about-ethiopias-new-program/" title="Six Things to Know about Ethiopia&#8217;s New Program">
Six Things to Know about Ethiopia&#8217;s New Program									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62226 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/winning-hearts-and-minds-the-long-history-of-a-failed-strategy-for-the-opdos-and-now-prosperity-party-in-oromia/" title="“Winning Hearts and Minds” The Long History of a Failed Strategy for the OPDOS and now Prosperity party in Oromia">
“Winning Hearts and Minds” The Long History of a Failed Strategy for the OPDOS and now Prosperity party in Oromia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62221 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/mootummaan-amma-jiru-kun-kan-eenyuuti-kan-jedhu-deebiee-gaaffii-nutti-taeera-obbo-leencoo-lataa/" title="“Mootummaan amma jiru kun, kan eenyuuti kan jedhu deebi’ee gaaffii nutti ta’eera!” Obbo Leencoo Lataa">
“Mootummaan amma jiru kun, kan eenyuuti kan jedhu deebi’ee gaaffii nutti ta’eera!” Obbo Leencoo Lataa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62218 post type-post status-publish format-standard has-post-thumbnail category-radio">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/wbon-kaambii-raayyaa-ittisaa-magaalaa-moyyaalee-keessatti-argamurratti-tarkaanfii-fudhachuu-rswo/" title="WBOn kaambii Raayyaa Ittisaa Magaalaa Moyyaalee keessatti argamu&#8217;rratti tarkaanfii fudhachuu | RSWO">
WBOn kaambii Raayyaa Ittisaa Magaalaa Moyyaalee keessatti argamu&#8217;rratti tarkaanfii fudhachuu | RSWO									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62208 post type-post status-publish format-standard has-post-thumbnail category-musics">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/dajanaa-jaalataa-fashinii-jabanaa-2020-new-oromoo-video-clip/" title="Dajanaa Jaalataa Fashinii Jabanaa 2020 New Oromoo Video Clip">
Dajanaa Jaalataa Fashinii Jabanaa 2020 New Oromoo Video Clip									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://kichuu.com/2019/12/'> December 2019 </option>
<option value='https://kichuu.com/2019/11/'> November 2019 </option>
<option value='https://kichuu.com/2019/10/'> October 2019 </option>
<option value='https://kichuu.com/2019/09/'> September 2019 </option>
<option value='https://kichuu.com/2019/08/'> August 2019 </option>
<option value='https://kichuu.com/2019/07/'> July 2019 </option>
<option value='https://kichuu.com/2019/06/'> June 2019 </option>
<option value='https://kichuu.com/2019/05/'> May 2019 </option>
<option value='https://kichuu.com/2019/04/'> April 2019 </option>
<option value='https://kichuu.com/2019/03/'> March 2019 </option>
<option value='https://kichuu.com/2019/02/'> February 2019 </option>
<option value='https://kichuu.com/2019/01/'> January 2019 </option>
<option value='https://kichuu.com/2018/12/'> December 2018 </option>
<option value='https://kichuu.com/2018/11/'> November 2018 </option>
<option value='https://kichuu.com/2018/10/'> October 2018 </option>
<option value='https://kichuu.com/2018/09/'> September 2018 </option>
<option value='https://kichuu.com/2018/08/'> August 2018 </option>
<option value='https://kichuu.com/2018/07/'> July 2018 </option>
<option value='https://kichuu.com/2018/06/'> June 2018 </option>
<option value='https://kichuu.com/2018/05/'> May 2018 </option>
<option value='https://kichuu.com/2018/04/'> April 2018 </option>
<option value='https://kichuu.com/2018/03/'> March 2018 </option>
<option value='https://kichuu.com/2018/02/'> February 2018 </option>
<option value='https://kichuu.com/2018/01/'> January 2018 </option>
<option value='https://kichuu.com/2017/12/'> December 2017 </option>
<option value='https://kichuu.com/2017/11/'> November 2017 </option>
<option value='https://kichuu.com/2017/10/'> October 2017 </option>
<option value='https://kichuu.com/2017/09/'> September 2017 </option>
<option value='https://kichuu.com/2017/08/'> August 2017 </option>
<option value='https://kichuu.com/2017/07/'> July 2017 </option>
<option value='https://kichuu.com/2017/06/'> June 2017 </option>
<option value='https://kichuu.com/2017/05/'> May 2017 </option>
<option value='https://kichuu.com/2017/04/'> April 2017 </option>
<option value='https://kichuu.com/2017/03/'> March 2017 </option>
<option value='https://kichuu.com/2017/02/'> February 2017 </option>
<option value='https://kichuu.com/2017/01/'> January 2017 </option>
<option value='https://kichuu.com/2016/12/'> December 2016 </option>
<option value='https://kichuu.com/2016/11/'> November 2016 </option>
<option value='https://kichuu.com/2013/11/'> November 2013 </option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
var dropdown = document.getElementById( "archives-dropdown-2" );
function onSelectChange() {
if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
document.location.href = this.options[ this.selectedIndex ].value;
}
}
dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
<div class="mh-video-container">
<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
</div>
</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
<caption>December 2019</caption>
<thead>
<tr>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
<th scope="col" title="Sunday">S</th>
</tr>
</thead>
<tfoot>
<tr>
<td colspan="3" id="prev"><a href="https://kichuu.com/2019/11/">&laquo; Nov</a></td>
<td class="pad">&nbsp;</td>
<td colspan="3" id="next" class="pad">&nbsp;</td>
</tr>
</tfoot>
<tbody>
<tr>
<td colspan="6" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2019/12/01/" aria-label="Posts published on December 1, 2019">1</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2019/12/02/" aria-label="Posts published on December 2, 2019">2</a></td><td><a href="https://kichuu.com/2019/12/03/" aria-label="Posts published on December 3, 2019">3</a></td><td><a href="https://kichuu.com/2019/12/04/" aria-label="Posts published on December 4, 2019">4</a></td><td><a href="https://kichuu.com/2019/12/05/" aria-label="Posts published on December 5, 2019">5</a></td><td><a href="https://kichuu.com/2019/12/06/" aria-label="Posts published on December 6, 2019">6</a></td><td><a href="https://kichuu.com/2019/12/07/" aria-label="Posts published on December 7, 2019">7</a></td><td><a href="https://kichuu.com/2019/12/08/" aria-label="Posts published on December 8, 2019">8</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2019/12/09/" aria-label="Posts published on December 9, 2019">9</a></td><td><a href="https://kichuu.com/2019/12/10/" aria-label="Posts published on December 10, 2019">10</a></td><td><a href="https://kichuu.com/2019/12/11/" aria-label="Posts published on December 11, 2019">11</a></td><td><a href="https://kichuu.com/2019/12/12/" aria-label="Posts published on December 12, 2019">12</a></td><td><a href="https://kichuu.com/2019/12/13/" aria-label="Posts published on December 13, 2019">13</a></td><td><a href="https://kichuu.com/2019/12/14/" aria-label="Posts published on December 14, 2019">14</a></td><td><a href="https://kichuu.com/2019/12/15/" aria-label="Posts published on December 15, 2019">15</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2019/12/16/" aria-label="Posts published on December 16, 2019">16</a></td><td><a href="https://kichuu.com/2019/12/17/" aria-label="Posts published on December 17, 2019">17</a></td><td><a href="https://kichuu.com/2019/12/18/" aria-label="Posts published on December 18, 2019">18</a></td><td><a href="https://kichuu.com/2019/12/19/" aria-label="Posts published on December 19, 2019">19</a></td><td><a href="https://kichuu.com/2019/12/20/" aria-label="Posts published on December 20, 2019">20</a></td><td><a href="https://kichuu.com/2019/12/21/" aria-label="Posts published on December 21, 2019">21</a></td><td><a href="https://kichuu.com/2019/12/22/" aria-label="Posts published on December 22, 2019">22</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2019/12/23/" aria-label="Posts published on December 23, 2019">23</a></td><td><a href="https://kichuu.com/2019/12/24/" aria-label="Posts published on December 24, 2019">24</a></td><td><a href="https://kichuu.com/2019/12/25/" aria-label="Posts published on December 25, 2019">25</a></td><td><a href="https://kichuu.com/2019/12/26/" aria-label="Posts published on December 26, 2019">26</a></td><td id="today"><a href="https://kichuu.com/2019/12/27/" aria-label="Posts published on December 27, 2019">27</a></td><td>28</td><td>29</td>
</tr>
<tr>
<td>30</td><td>31</td>
<td class="pad" colspan="5">&nbsp;</td>
</tr>
</tbody>
</table></div></div>	</aside>	</div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62073 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-gears-up-for-increased-cancer-control-with-new-equipment-training-and-smooth-licensing/" title="Ethiopia Gears Up for Increased Cancer Control with New Equipment, Training and Smooth Licensing"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethiopia" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-gears-up-for-increased-cancer-control-with-new-equipment-training-and-smooth-licensing/" title="Ethiopia Gears Up for Increased Cancer Control with New Equipment, Training and Smooth Licensing">
Ethiopia Gears Up for Increased Cancer Control with New Equipment, Training and Smooth Licensing									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 23, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61612 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/us-congress-inching-closer-to-raising-legal-smoking-age-to-21/" title="US Congress inching closer to raising legal smoking age to 21."><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="smoking age" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/us-congress-inching-closer-to-raising-legal-smoking-age-to-21/" title="US Congress inching closer to raising legal smoking age to 21.">
US Congress inching closer to raising legal smoking age to 21.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 17, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61575 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/hiv-aids-ibsee-jira-waaeen-eedsii-dagatamuu-hin-qabu/" title="HIV/ AIDS ibsee Jira: &#8220;Waa’een Eedsii Dagatamuu Hin Qabu&#8221;"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/yeswq.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="HIV/ AIDS" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/yeswq.png?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/yeswq.png?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/yeswq.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/yeswq.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/yeswq.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/hiv-aids-ibsee-jira-waaeen-eedsii-dagatamuu-hin-qabu/" title="HIV/ AIDS ibsee Jira: &#8220;Waa’een Eedsii Dagatamuu Hin Qabu&#8221;">
HIV/ AIDS ibsee Jira: &#8220;Waa’een Eedsii Dagatamuu Hin Qabu&#8221;									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 16, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Mohammed Hajjii" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62208 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/dajanaa-jaalataa-fashinii-jabanaa-2020-new-oromoo-video-clip/" title="Dajanaa Jaalataa Fashinii Jabanaa 2020 New Oromoo Video Clip"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-11-6-e1577285171607.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Dajanaa Jaalataa" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-11-6-e1577285171607.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/dajanaa-jaalataa-fashinii-jabanaa-2020-new-oromoo-video-clip/" title="Dajanaa Jaalataa Fashinii Jabanaa 2020 New Oromoo Video Clip">
Dajanaa Jaalataa Fashinii Jabanaa 2020 New Oromoo Video Clip									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 25, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62093 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/nanati-yami-hiree-new-ethiopian-oromo-music-2019-official-video/" title="Nanati Yami &#8211; Hiree &#8211; New Ethiopian Oromo Music 2019 [Official Video]"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-35-1-e1577131369304.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Oromo Music" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-35-1-e1577131369304.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/nanati-yami-hiree-new-ethiopian-oromo-music-2019-official-video/" title="Nanati Yami &#8211; Hiree &#8211; New Ethiopian Oromo Music 2019 [Official Video]">
Nanati Yami &#8211; Hiree &#8211; New Ethiopian Oromo Music 2019 [Official Video]									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 23, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61825 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/aadam-mohaammad-fi-daraartuu-guutamaa-dansoolee-new-oromo-music-2020/" title="Aadam Mohaammad fi Daraartuu Guutamaa **Dansoolee** New Oromo  Music 2020"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-3-6-e1576843982792.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Aadam Mohaammad" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-3-6-e1576843982792.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/aadam-mohaammad-fi-daraartuu-guutamaa-dansoolee-new-oromo-music-2020/" title="Aadam Mohaammad fi Daraartuu Guutamaa **Dansoolee** New Oromo  Music 2020">
Aadam Mohaammad fi Daraartuu Guutamaa **Dansoolee** New Oromo  Music 2020									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 20, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61264 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/over-83-of-ethiopians-suffer-from-multidimensional-poverty/" title="Over 83% Of Ethiopians Suffer From Multidimensional Poverty"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Poverty" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/over-83-of-ethiopians-suffer-from-multidimensional-poverty/" title="Over 83% Of Ethiopians Suffer From Multidimensional Poverty">
Over 83% Of Ethiopians Suffer From Multidimensional Poverty									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 12, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61222 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-orange-ceo-tempers-ambitions-for-ethio-telecom/" title="Ethiopia: Orange CEO tempers ambitions for Ethio Telecom"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/Screen-Shot-2019-12-09-at-10.14.06-e1576003221572.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethio Telecom" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/Screen-Shot-2019-12-09-at-10.14.06-e1576003221572.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/Screen-Shot-2019-12-09-at-10.14.06-e1576003221572.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/Screen-Shot-2019-12-09-at-10.14.06-e1576003221572.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-orange-ceo-tempers-ambitions-for-ethio-telecom/" title="Ethiopia: Orange CEO tempers ambitions for Ethio Telecom">
Ethiopia: Orange CEO tempers ambitions for Ethio Telecom									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 10, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-60797 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-to-keep-control-of-its-banks-as-other-sectors-open-up/" title="Ethiopia to Keep Control of Its Banks as Other Sectors Open Up"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/1000x-1-e1575300697372.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethiopia" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/1000x-1-e1575300697372.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/1000x-1-e1575300697372.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/1000x-1-e1575300697372.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-to-keep-control-of-its-banks-as-other-sectors-open-up/" title="Ethiopia to Keep Control of Its Banks as Other Sectors Open Up">
Ethiopia to Keep Control of Its Banks as Other Sectors Open Up									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 2, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
</div>
</footer>
<div class="mh-footer-nav-mobile"></div>
<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
</nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright @2016 kichuu.com              		</p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-58166095-1', 'auto');
ga('send', 'pageview');
</script>			<div id="fb-root"></div>
<script>
(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201952'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://kichuu.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201952.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'111820558',post:'62294',tz:'-4',srv:'kichuu.com'} ]);
_stq.push([ 'clickTrackerInit', '111820558', '62294' ]);
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.52786898613 seconds, on 27-12-19 11:52:44 --><!-- need to refresh to see cached version -->