<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14, Kichuu</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v12.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,20200)"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14, Kichuu" />
<meta property="og:description" content="OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,20200)" />
<meta property="og:url" content="https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:publisher" content="https://www.facebook.com/kichuu.info/" />
<meta property="article:section" content="Videos" />
<meta property="article:published_time" content="2020-01-14T13:37:26+00:00" />
<meta property="og:image" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-6-4-e1579005564522.jpg?fit=650%2C487&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-6-4-e1579005564522.jpg?fit=650%2C487&#038;ssl=1" />
<meta property="og:image:width" content="650" />
<meta property="og:image:height" content="487" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507","name":"fmegersa","logo":{"@id":"https://kichuu.com/#personlogo"},"sameAs":[]},{"@type":"WebSite","@id":"https://kichuu.com/#website","url":"https://kichuu.com/","name":"Kichuu","publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"potentialAction":{"@type":"SearchAction","target":"https://kichuu.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#primaryimage","url":"https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-6-4-e1579005564522.jpg?fit=650%2C487&ssl=1","width":650,"height":487,"caption":"KFO"},{"@type":"WebPage","@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#webpage","url":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/","inLanguage":"en-US","name":"OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14, Kichuu","isPartOf":{"@id":"https://kichuu.com/#website"},"primaryImageOfPage":{"@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#primaryimage"},"datePublished":"2020-01-14T13:37:26+00:00","dateModified":"2020-01-14T13:37:26+00:00","description":"OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,20200)"},{"@type":"Article","@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#article","isPartOf":{"@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#webpage"},"author":{"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330"},"headline":"OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,","datePublished":"2020-01-14T13:37:26+00:00","dateModified":"2020-01-14T13:37:26+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#webpage"},"publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"image":{"@id":"https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#primaryimage"},"articleSection":"Videos"},{"@type":["Person"],"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330","name":"kichuu_admin","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14, Comments Feed" href="https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/feed/" />
<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ -->		<script>
//@formatter:off
advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
</script><link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/style.css?ver=3.8.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/dhrvjwy1/bjolr.css" media="all"/>
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.6'></script>
<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://kichuu.com/?p=63411' />
<link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>
<script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=270%2C270&#038;ssl=1" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-63411 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-top">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kichuu" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?w=331&amp;ssl=1 331w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=300%2C73&amp;ssl=1 300w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=326%2C81&amp;ssl=1 326w" data-lazy-sizes="(max-width: 331px) 100vw, 331px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="6220502696"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
News Ticker<i class="fa fa-chevron-right"></i>		</div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/obs-marii-adda-bilisummaa-oromoo-hawaasa-finfinnee-waliinbarii-finfinnee-kutaa1/" title="OBS &#8211; Marii Adda Bilisummaa Oromoo Hawaasa Finfinnee waliin(Barii Finfinnee) kutaa1">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 14, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
OBS &#8211; Marii Adda Bilisummaa Oromoo Hawaasa Finfinnee waliin(Barii Finfinnee) kutaa1						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
TV							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/diredhawaa305-305-the-number-of-our-youth-in-prison-for-no-reason-other-than-speaking-for-their-rights-release-them-now/" title="DireDhawaa305: 305 the number of our youth in prison for no reason other than speaking for their rights! Release them now!">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 14, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
DireDhawaa305: 305 the number of our youth in prison for no reason other than speaking for their rights! Release them now!						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/assistant-secretary-tibor-nagy-to-visit-5-african-countries/" title="Assistant Secretary Tibor Nagy to Visit 5 African Countries">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 14, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Assistant Secretary Tibor Nagy to Visit 5 African Countries						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/turkey-joins-united-states-france-on-list-of-countries-with-troops-in-africa/" title="Turkey joins United States, France on list of countries with troops in Africa">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 14, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Turkey joins United States, France on list of countries with troops in Africa						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/" title="OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 14, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Videos							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/siidaalee-yaadannoo-hammeenya-sirna-nafxanyaa-yaadachiisuuf-oromiyaa-keessatti-jaaramaniin-hara-oromoo-gowwoomsuun-hin-dandaamtu/" title="Siidaalee yaadannoo hammeenya sirna Nafxanyaa yaadachiisuuf Oromiyaa keessatti jaaramaniin har&#8217;a Oromoo gowwoomsuun hin danda&#8217;amtu.">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 13, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Siidaalee yaadannoo hammeenya sirna Nafxanyaa yaadachiisuuf Oromiyaa keessatti jaaramaniin har&#8217;a Oromoo gowwoomsuun hin danda&#8217;amtu.						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/oduu-nama-gaddiisisu-rajiidham-dambi-doolloo-oduu-fokkisaa-kan-hiyyeessaa-hin-toluu-godootu-dhimmisa-jedhan/" title="Oduu nama gaddiisisu rajiidham ! Dambi Doolloo Oduu Fokkisaa">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 13, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Oduu nama gaddiisisu rajiidham ! Dambi Doolloo Oduu Fokkisaa						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Videos							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/qophii-barii-finfinnee-galma-miliniyam-ykn-barkumee-keessattii-abo-tin/" title="Qophii BARII FINFINNEE galma Miliniyam ykn Barkumee keessattii ABO tin">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 13, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Qophii BARII FINFINNEE galma Miliniyam ykn Barkumee keessattii ABO tin						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
TV							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/amantii-moo-burjaajiidha-kun/" title="Amantii moo burjaajiidha kun?">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 13, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Amantii moo burjaajiidha kun?						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/egypt-ethiopia-row-the-trouble-over-a-giant-nile-dam/" title="Egypt-Ethiopia row: The trouble over a giant Nile dam">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ January 13, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Egypt-Ethiopia row: The trouble over a giant Nile dam						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>		</ul>
</div>
</div>						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com/category/afaan-oromoo/videos/" itemprop="url"><span itemprop="title">Videos</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,</nav>
<article id="post-63411" class="post-63411 post type-post status-publish format-standard has-post-thumbnail hentry category-videos">
<header class="entry-header clearfix"><h1 class="entry-title">OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 14, 2020</a></span>
</div>
</header>
<div id="custom_html-2" class="widget_text mh-widget mh-posts-1 widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Above Single Post</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div>	<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&t=OMN%3A+Turtii+Jila+KFO+Magaalota+Harar%2C+Dadarii+fi+Dirree+Dhawaatti+%28Amajji+14%2C', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=OMN%3A+Turtii+Jila+KFO+Magaalota+Harar%2C+Dadarii+fi+Dirree+Dhawaatti+%28Amajji+14%2C:&url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&media=https://kichuu.com/wp-content/uploads/2020/01/pizap-6-4-e1579005564522.jpg&description=OMN%3A+Turtii+Jila+KFO+Magaalota+Harar%2C+Dadarii+fi+Dirree+Dhawaatti+%28Amajji+14%2C', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=OMN%3A%20Turtii%20Jila%20KFO%20Magaalota%20Harar%2C%20Dadarii%20fi%20Dirree%20Dhawaatti%20%28Amajji%2014%2C&amp;body=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
<div class="kichu-before-content" id="kichu-799683174"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><p><strong>OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,2020)</strong><br />
<iframe style="border: none; overflow: hidden;" src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FOromiaMedia%2Fvideos%2F646506522824929%2F&amp;show_text=1&amp;width=560" width="560" height="407" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></p>
<hr />
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20191026 -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="2237740205"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong>14,Odeessa jajjabduu fi amanamtuu &#8211; obsaan dubbisaa</strong></p>
<p>&#8220;Dhimma muudama gidduu kana bilxiginnaan raawwatte:<br />
1)  Bulchiinsaa fi nageenna Oromiyaa-<a href="https://kichuu.com/kaadirootni-bilxiginnaa-sun-kana-arganii-laata/"> Nama Jibril jedhamu kaayani</a>. Dr Qana’a nama jedhamu caasaa Lammaati jedhanii shaaran.<br />
2)  Komishinera poolisii Oromiyaa: nama Araarsaa Mardaasaa jedhamau, deninnatii wayyaanee ta’ee nama fixaa ture, OPDO dullattii fidanii shuuman.<span class="text_exposed_show"><br />
3)  Biiroo IMX- horii guddaa qeerroo Oromiyaaf jedhamee qarshii billiona 5 dhihoo ramadame biiroo kanatu joolleef raabsuu qaba ture. Amma biiroo tanarra nafxenyaa Boggaalee Fallaqee jedhamu, ka Lammaan ari’ee ture du’aa kaasanii muudan.<br />
4) Poolisii Oromiyaa- Damee poolisa idilee kaadiroota kaayan. Dachaasaa Magarsaa achii dhiibanii liyyuu hayilii qofa akka qajeelchu godhani. Kana jechuun dachaasaan komaandaroota magaalotaa fi godinaa irratti aangoo dhorkatan jechuudha. Dachaasaan poolisa magaalota qajeelchan oromoo taasisee ture. San duubatti deebisuufi, filannoo dhufu nama hidhuuf mijeeffatu.<br />
5)  Bulcha Walagga Bahaa: kaadiree durii ka Kaffaalo Ayyaana jedhamu, Lammaan ari’atee ture muudan.<br />
6)  Jabaa Addunyaa Bulcha Horroo Lammaa deeggarte jechuun ari’atani.<br />
7)  Dr Milkeessaa Miidhagaa, hogganaa Biiroo Lafa Oromiyaa, Bilxiginnaan qoratameera jedhu, innis ka’uu hin oolle.<br />
Ergamaan Bilxiginnaa kan ta’e Taakkalee Uumaan, joollee Laammaa jala deemti jedhu maqaa bilxiginnaa deeggaruu diddan jedhuun birolee fi kutaa magaalaa irraa ari’aa jira. Fatiya Mohammad, sia lama qorachiisuu quba qabna. Garuu, Taakkaleenis sababa mussinnaatiin walumaan shaarama kan jedhu dininnatiin biyyaatti huursee odeessaa jira.<br />
8) Kan nama raaju ammoo gurbaa Tarrafee jedhamu kantiibaa Amboo ture san Abiyyi irratti hiriira mormii situ baase jechuun ari’uu isaaniiti. Sana qofa miti, mana isaa irratti boombii darbatte bilxiginnaan. Waliifuu hin toltu.<br />
9) Wanti bilxiginnaan gaarii goote yoo jiraate, gowwaa halkaniif guyyaa alaaku san gaangee ofii godhattee itti fufuudha.<br />
10) Addisu Araggaa, Adaanach fi Alamuu Simeen walii galanii Abiyyiin amansiisaniiru Shamallisiin achii kaasanii Adaanachiin perezidaantii gochuuf. Shimallis kana baree silumaayyuu na kaasaa, hin fedhu, ani dadhabeera jedhee Fiqaaduu Tasammaan dubbate. Walmarqaa jirti.<br />
11) Magaalota, godinaalee, aanaalee fi gandoota Oromiyaa irraa qeerroo dhihoo tana haaromsaan OPDOn makan hunda haxaayanii baasaa jiru. OPDO durii dachaafataa jiru.&#8221;Yayaa Basher<img class="alignnone size-large wp-image-63414 jetpack-lazy-image" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=650%2C341&#038;ssl=1" alt width="650" height="341" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=650%2C341&amp;ssl=1 650w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=250%2C131&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?w=750&amp;ssl=1 750w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=650%2C341&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-large wp-image-63414" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=650%2C341&#038;ssl=1" alt="" width="650" height="341" srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=650%2C341&amp;ssl=1 650w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?resize=250%2C131&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/82214940_2490051054438763_417626685534371840_n.jpg?w=750&amp;ssl=1 750w" sizes="(max-width: 650px) 100vw, 650px" data-recalc-dims="1" /></noscript></span><br />
ጠቅላይሚኒስትሩ ከሰይፉ ጋር በነበራቸው ኢንተርቪው ከስልጣን በኋላ ምን እደሚያደርጉ ለተጠየቁት ካመነቱ በኋላ &#8220;በንባብ እና በመጻፍ አሳልፋለው&#8221; ብለዋል። ጠቅላይ ሚኒስትርነቱን ከጨረሱ በኋላ ከሚያነቡ አንብበው ጠቅላይሚኒስተር ቢሆኑ መልካም ነበር  ካነበቡት መጽሀፍ ሌላው ሰው ቢያነበው ብለው የሚመኙት መጽሀፍ ተብለው ለተጠየቁት ሲመልሱ &#8220;የመጽሀፍ መጥፎ የለውም። ስም ላለመጥራት ብዬ ነው&#8221; ያሉት ከአንድ አስቂኝ ታሪክ ጋር ተመሳስሎብኛል። በአንደ ወቅት ለአሜሪካ ፕሬዝዳንትነት የተወዳደሩት ጆን ማኬይን ካሸነፉ ምክትላቸው እንድትሆን በጣም ወግ አጥባቂ የነበረችውን ሳራ ፓሊንን መርጠው ነበር። ታዲያ ሳራ የምታወራውን በቅጡ የማታጤን ከእውቀት ጋር የተቀያየመች ግለሰብ ነበረች። በአንድ ወቅት መረጃ ለማግኘት አዘውትረሽ የምታነቢው ጋዜጣ ምንድር ነው ተብላ ስትጠየቅ ስም መጥቀስ ተቸግራ &#8220;Um, all of them&#8221; የሚል መልስ ሰጥታ ነበር። ያው መልሱ በአጭሩ አታነብም ነው።. Radiet Tamire</p>
<p>&nbsp;</p>
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="kichu-k20191225below" id="kichu-1371893711"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&t=OMN%3A+Turtii+Jila+KFO+Magaalota+Harar%2C+Dadarii+fi+Dirree+Dhawaatti+%28Amajji+14%2C', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=OMN%3A+Turtii+Jila+KFO+Magaalota+Harar%2C+Dadarii+fi+Dirree+Dhawaatti+%28Amajji+14%2C:&url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F&media=https://kichuu.com/wp-content/uploads/2020/01/pizap-6-4-e1579005564522.jpg&description=OMN%3A+Turtii+Jila+KFO+Magaalota+Harar%2C+Dadarii+fi+Dirree+Dhawaatti+%28Amajji+14%2C', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=OMN%3A%20Turtii%20Jila%20KFO%20Magaalota%20Harar%2C%20Dadarii%20fi%20Dirree%20Dhawaatti%20%28Amajji%2014%2C&amp;body=https%3A%2F%2Fkichuu.com%2Fomn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
</div><div id="text-3" class="mh-widget mh-posts-2 widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Below Single Post</span></h4>			<div class="textwidget"><p><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></p>
</div>
</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/siidaalee-yaadannoo-hammeenya-sirna-nafxanyaa-yaadachiisuuf-oromiyaa-keessatti-jaaramaniin-hara-oromoo-gowwoomsuun-hin-dandaamtu/" rel="prev"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/82355785_1074326399621065_2621491400021114880_n-e1578936933660.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Nafxanyaa" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/82355785_1074326399621065_2621491400021114880_n-e1578936933660.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Previous</span><p>Siidaalee yaadannoo hammeenya sirna Nafxanyaa yaadachiisuuf Oromiyaa keessatti jaaramaniin har&#8217;a Oromoo gowwoomsuun hin danda&#8217;amtu.</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://kichuu.com/turkey-joins-united-states-france-on-list-of-countries-with-troops-in-africa/" rel="next"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_991263-e1579010221898.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="France" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_991263-e1579010221898.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_991263-e1579010221898.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_991263-e1579010221898.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Next</span><p>Turkey joins United States, France on list of countries with troops in Africa</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='63411' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="67e866f76c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="106"/></p></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-63213 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Autocrat" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">
Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 9, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps By Jabessa Gurmessa, Finfinne, Oromia, January 09, 2020 1. Introduction The freedom lovers and proponents <a class="mh-excerpt-more" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62609 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Gammaachuu Ayaanaa Gemechu" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit">
Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit By Worku Burayu (PhD), January 1, 2020 During the times of apartheid, it was said that some prisons reached almost 200% of what the prison was built to hold. The exact copy of <a class="mh-excerpt-more" href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62599 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Berhanu Nega" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama">
EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama By Guluma Gemeda,  Ph.D., December 31, 2019 Dr. Berhanu Nega, leader of the Ethiopian Citizens for Social Justice (EZEMA) party, made a <a class="mh-excerpt-more" href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62290 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="IRBUU Struggle" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">
Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa By Bilisummaa Jaalataa, December 26, 2019 Like all African countries, the Oromo (hereafter We/Our/Us) were colonized in the last quarter of the <a class="mh-excerpt-more" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-59364 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Finfinnee" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">
TEN POINTS WHY FINFINNEE IS OROMO CITY											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/10/">October 28, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">TEN POINTS WHY FINFINNEE IS OROMO CITY BY Worku Gadissa, October 29, 1019 Note: Sheger is another name for Finfinnee and both name are used in this article. We are all aware of present highly <a class="mh-excerpt-more" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-57157 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/citizenship-versus-identity-the-current-political-discourse-in-ethiopia/" title="Citizenship versus Identity: the current political discourse in Ethiopia"><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Citizenship" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?zoom=3&amp;resize=326%2C245&amp;ssl=1 978w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/09/abiy-yes-no-e1569508949329.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/citizenship-versus-identity-the-current-political-discourse-in-ethiopia/" title="Citizenship versus Identity: the current political discourse in Ethiopia">
Citizenship versus Identity: the current political discourse in Ethiopia											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/09/">September 26, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Citizenship versus Identity: the current political discourse in Ethiopia By Alemayehu Biru (PhD), September 26, 2019 This topic bears a very common binary way of putting complex sociopolitical issues by politicians and, at times, even <a class="mh-excerpt-more" href="https://kichuu.com/citizenship-versus-identity-the-current-political-discourse-in-ethiopia/" title="Citizenship versus Identity: the current political discourse in Ethiopia">[Read More]</a></div>								</div>
</div>
</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63431 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/obs-marii-adda-bilisummaa-oromoo-hawaasa-finfinnee-waliinbarii-finfinnee-kutaa1/" title="OBS &#8211; Marii Adda Bilisummaa Oromoo Hawaasa Finfinnee waliin(Barii Finfinnee) kutaa1">
OBS &#8211; Marii Adda Bilisummaa Oromoo Hawaasa Finfinnee waliin(Barii Finfinnee) kutaa1									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 14, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63426 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/diredhawaa305-305-the-number-of-our-youth-in-prison-for-no-reason-other-than-speaking-for-their-rights-release-them-now/" title="DireDhawaa305: 305 the number of our youth in prison for no reason other than speaking for their rights! Release them now!">
DireDhawaa305: 305 the number of our youth in prison for no reason other than speaking for their rights! Release them now!									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 14, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63422 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/assistant-secretary-tibor-nagy-to-visit-5-african-countries/" title="Assistant Secretary Tibor Nagy to Visit 5 African Countries">
Assistant Secretary Tibor Nagy to Visit 5 African Countries									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 14, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63419 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/turkey-joins-united-states-france-on-list-of-countries-with-troops-in-africa/" title="Turkey joins United States, France on list of countries with troops in Africa">
Turkey joins United States, France on list of countries with troops in Africa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 14, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63411 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/omn-turtii-jila-kfo-magaalota-harar-dadarii-fi-dirree-dhawaatti-amajji-142020/" title="OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,">
OMN: Turtii Jila KFO Magaalota Harar, Dadarii fi Dirree Dhawaatti (Amajji 14,									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 14, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63406 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/siidaalee-yaadannoo-hammeenya-sirna-nafxanyaa-yaadachiisuuf-oromiyaa-keessatti-jaaramaniin-hara-oromoo-gowwoomsuun-hin-dandaamtu/" title="Siidaalee yaadannoo hammeenya sirna Nafxanyaa yaadachiisuuf Oromiyaa keessatti jaaramaniin har&#8217;a Oromoo gowwoomsuun hin danda&#8217;amtu.">
Siidaalee yaadannoo hammeenya sirna Nafxanyaa yaadachiisuuf Oromiyaa keessatti jaaramaniin har&#8217;a Oromoo gowwoomsuun hin danda&#8217;amtu.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63395 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/oduu-nama-gaddiisisu-rajiidham-dambi-doolloo-oduu-fokkisaa-kan-hiyyeessaa-hin-toluu-godootu-dhimmisa-jedhan/" title="Oduu nama gaddiisisu rajiidham ! Dambi Doolloo Oduu Fokkisaa">
Oduu nama gaddiisisu rajiidham ! Dambi Doolloo Oduu Fokkisaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63392 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/qophii-barii-finfinnee-galma-miliniyam-ykn-barkumee-keessattii-abo-tin/" title="Qophii BARII FINFINNEE galma Miliniyam ykn Barkumee keessattii ABO tin">
Qophii BARII FINFINNEE galma Miliniyam ykn Barkumee keessattii ABO tin									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63386 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/amantii-moo-burjaajiidha-kun/" title="Amantii moo burjaajiidha kun?">
Amantii moo burjaajiidha kun?									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63378 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/egypt-ethiopia-row-the-trouble-over-a-giant-nile-dam/" title="Egypt-Ethiopia row: The trouble over a giant Nile dam">
Egypt-Ethiopia row: The trouble over a giant Nile dam									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63373 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/osa-responding-to-false-accusations/" title="OSA: Responding to False Accusations">
OSA: Responding to False Accusations									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63368 post type-post status-publish format-standard has-post-thumbnail category-radio">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/the-root-cause-of-political-problems-in-ethiopia-is-national-oppression/" title="&#8220;The root cause of political problems in Ethiopia is national oppression by the Ethiopian empire state and refusal by the state to respect the rights of oppressed peoples to self-determination.">
&#8220;The root cause of political problems in Ethiopia is national oppression by the Ethiopian empire state and refusal by the state to respect the rights of oppressed peoples to self-determination.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63366 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8a%a0%e1%89%b6-%e1%8b%b3%e1%8b%8d%e1%8b%b5-%e1%8a%a2%e1%89%a5%e1%88%b3-%e1%8a%a5%e1%8a%93-%e1%89%a5%e1%88%ad%e1%88%83%e1%8a%91-%e1%8a%90%e1%8c%8b-%e1%8d%95-%e1%88%ad-%e1%8a%ad%e1%8d%8d-2/" title="አቶ ዳውድ ኢብሳ እና ብርሃኑ ነጋ (ፕ/ር) | ክፍል 1-4/ AshamTV">
አቶ ዳውድ ኢብሳ እና ብርሃኑ ነጋ (ፕ/ር) | ክፍል 1-4/ AshamTV									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63362 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/imaammataa-fi-xiyyeeffannaa-abo-2020/" title="Imaammataa fi Xiyyeeffannaa ABO 2020">
Imaammataa fi Xiyyeeffannaa ABO 2020									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 13, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63356 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/duris-haras-misooma-dirqii-baadiyyaa-lafa-oromiyaa-keessatti-hawaasni-oromoo-kan-akka-dhuunfaatti-ufiisaatii-fuuree-biyya-tana-misoomsu-malee-irra-caalaa-mootummootath-dirqiin-baaseen-lafa-qochisi/" title="Duris Har&#8217;as Misooma Dirqii!!  Baadiyyaa lafa Oromiyaa keessatti Hawaasni Oromoo Kan akka dhuunfaatti Ufiisaatii Fuuree biyya tana misoomsu malee irra caalaa Mootummootath dirqiin baaseen lafa qochisiisa">
Duris Har&#8217;as Misooma Dirqii!!  Baadiyyaa lafa Oromiyaa keessatti Hawaasni Oromoo Kan akka dhuunfaatti Ufiisaatii Fuuree biyya tana misoomsu malee irra caalaa Mootummootath dirqiin baaseen lafa qochisiisa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63352 post type-post status-publish format-standard has-post-thumbnail category-tv">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/kmn-%e1%8b%a8%e1%8a%a2%e1%8b%9c%e1%88%9b%e1%8a%95-%e1%8d%8c%e1%8a%ad-%e1%8d%8c%e1%8b%b5%e1%88%ab%e1%88%8a%e1%8b%9d%e1%88%9d-%e1%8b%a8%e1%8b%b0%e1%89%a1%e1%89%a5-%e1%88%85%e1%8b%9d%e1%89%a6%e1%89%bd/" title="KMN: የኢዜማን ፌክ ፌድራሊዝም የደቡብ ህዝቦች ማወቅ አለባቸዉ, በግዜም አሰላለፋቸዉን ያስተካክሉ">
KMN: የኢዜማን ፌክ ፌድራሊዝም የደቡብ ህዝቦች ማወቅ አለባቸዉ, በግዜም አሰላለፋቸዉን ያስተካክሉ									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63344 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/kaadirootni-bilxiginnaa-sun-kana-arganii-laata/" title="Kaadirootni Bilxiginnaa sun kana arganii laata?">
Kaadirootni Bilxiginnaa sun kana arganii laata?									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63341 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/haa-deebinu-utuma-sirbinuu-nyaatamne-haras-utuma-sirbinuu-dubbiin-nu-jala-darbuuf-jirti/" title="Haa deebinu! Utuma sirbinuu nyaatamne. Har&#8217;as utuma sirbinuu dubbiin nu jala darbuuf jirti">
Haa deebinu! Utuma sirbinuu nyaatamne. Har&#8217;as utuma sirbinuu dubbiin nu jala darbuuf jirti									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63338 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/bilxiginnaan-sabboontotaaf-bakka-akka-hin-qabne-mirkaneessuu-itti-fufteerti/" title="Bilxiginnaan sabboontotaaf bakka akka hin qabne mirkaneessuu itti fufteerti.">
Bilxiginnaan sabboontotaaf bakka akka hin qabne mirkaneessuu itti fufteerti.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 12, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63335 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/the-international-waaqeffannaa-assembly-wrote-an-open-letter-to-the-offices-of-fdres-prime-minister-and-the-president-of-oromia-regional-state-among-others-%e2%80%ac/" title="The International Waaqeffannaa Assembly wrote an open letter to the Offices of FDRE’s Prime Minister and the President of Oromia Regional State, among others.‬">
The International Waaqeffannaa Assembly wrote an open letter to the Offices of FDRE’s Prime Minister and the President of Oromia Regional State, among others.‬									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 12, 2020</a></span>
</div>
</div>
</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://kichuu.com/2020/01/'> January 2020 </option>
<option value='https://kichuu.com/2019/12/'> December 2019 </option>
<option value='https://kichuu.com/2019/11/'> November 2019 </option>
<option value='https://kichuu.com/2019/10/'> October 2019 </option>
<option value='https://kichuu.com/2019/09/'> September 2019 </option>
<option value='https://kichuu.com/2019/08/'> August 2019 </option>
<option value='https://kichuu.com/2019/07/'> July 2019 </option>
<option value='https://kichuu.com/2019/06/'> June 2019 </option>
<option value='https://kichuu.com/2019/05/'> May 2019 </option>
<option value='https://kichuu.com/2019/04/'> April 2019 </option>
<option value='https://kichuu.com/2019/03/'> March 2019 </option>
<option value='https://kichuu.com/2019/02/'> February 2019 </option>
<option value='https://kichuu.com/2019/01/'> January 2019 </option>
<option value='https://kichuu.com/2018/12/'> December 2018 </option>
<option value='https://kichuu.com/2018/11/'> November 2018 </option>
<option value='https://kichuu.com/2018/10/'> October 2018 </option>
<option value='https://kichuu.com/2018/09/'> September 2018 </option>
<option value='https://kichuu.com/2018/08/'> August 2018 </option>
<option value='https://kichuu.com/2018/07/'> July 2018 </option>
<option value='https://kichuu.com/2018/06/'> June 2018 </option>
<option value='https://kichuu.com/2018/05/'> May 2018 </option>
<option value='https://kichuu.com/2018/04/'> April 2018 </option>
<option value='https://kichuu.com/2018/03/'> March 2018 </option>
<option value='https://kichuu.com/2018/02/'> February 2018 </option>
<option value='https://kichuu.com/2018/01/'> January 2018 </option>
<option value='https://kichuu.com/2017/12/'> December 2017 </option>
<option value='https://kichuu.com/2017/11/'> November 2017 </option>
<option value='https://kichuu.com/2017/10/'> October 2017 </option>
<option value='https://kichuu.com/2017/09/'> September 2017 </option>
<option value='https://kichuu.com/2017/08/'> August 2017 </option>
<option value='https://kichuu.com/2017/07/'> July 2017 </option>
<option value='https://kichuu.com/2017/06/'> June 2017 </option>
<option value='https://kichuu.com/2017/05/'> May 2017 </option>
<option value='https://kichuu.com/2017/04/'> April 2017 </option>
<option value='https://kichuu.com/2017/03/'> March 2017 </option>
<option value='https://kichuu.com/2017/02/'> February 2017 </option>
<option value='https://kichuu.com/2017/01/'> January 2017 </option>
<option value='https://kichuu.com/2016/12/'> December 2016 </option>
<option value='https://kichuu.com/2016/11/'> November 2016 </option>
<option value='https://kichuu.com/2013/11/'> November 2013 </option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
var dropdown = document.getElementById( "archives-dropdown-2" );
function onSelectChange() {
if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
document.location.href = this.options[ this.selectedIndex ].value;
}
}
dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
<div class="mh-video-container">
<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
</div>
</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
<caption>January 2020</caption>
<thead>
<tr>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
<th scope="col" title="Sunday">S</th>
</tr>
</thead>
<tfoot>
<tr>
<td colspan="3" id="prev"><a href="https://kichuu.com/2019/12/">&laquo; Dec</a></td>
<td class="pad">&nbsp;</td>
<td colspan="3" id="next" class="pad">&nbsp;</td>
</tr>
</tfoot>
<tbody>
<tr>
<td colspan="2" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2020/01/01/" aria-label="Posts published on January 1, 2020">1</a></td><td><a href="https://kichuu.com/2020/01/02/" aria-label="Posts published on January 2, 2020">2</a></td><td><a href="https://kichuu.com/2020/01/03/" aria-label="Posts published on January 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/01/04/" aria-label="Posts published on January 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/01/05/" aria-label="Posts published on January 5, 2020">5</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2020/01/06/" aria-label="Posts published on January 6, 2020">6</a></td><td><a href="https://kichuu.com/2020/01/07/" aria-label="Posts published on January 7, 2020">7</a></td><td><a href="https://kichuu.com/2020/01/08/" aria-label="Posts published on January 8, 2020">8</a></td><td><a href="https://kichuu.com/2020/01/09/" aria-label="Posts published on January 9, 2020">9</a></td><td><a href="https://kichuu.com/2020/01/10/" aria-label="Posts published on January 10, 2020">10</a></td><td><a href="https://kichuu.com/2020/01/11/" aria-label="Posts published on January 11, 2020">11</a></td><td><a href="https://kichuu.com/2020/01/12/" aria-label="Posts published on January 12, 2020">12</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2020/01/13/" aria-label="Posts published on January 13, 2020">13</a></td><td id="today"><a href="https://kichuu.com/2020/01/14/" aria-label="Posts published on January 14, 2020">14</a></td><td>15</td><td>16</td><td>17</td><td>18</td><td>19</td>
</tr>
<tr>
<td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td>
</tr>
<tr>
<td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
<td class="pad" colspan="2">&nbsp;</td>
</tr>
</tbody>
</table></div></div>	</aside>	</div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62737 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%8a%a5%e1%8a%95%e1%8a%b3%e1%8a%95-%e1%8b%b0%e1%88%b5-%e1%8a%a0%e1%88%8b%e1%89%bd%e1%88%81-congratulations-%e1%8c%a4%e1%8a%93-%e1%88%9a%e1%8a%92%e1%88%b5%e1%89%b4%e1%88%ad-%e1%8b%a8%e1%8a%a0/" title="እንኳን ደስ አላችሁ!! CONGRATULATIONS!  ጤና ሚኒስቴር የአዲስ አበባ ዩኒቨርስቲ ለዶ/ር ዋቅጋሪ ዴሬሳ አመንቴ የፕሮፌሰርነት ማዕረግ በመስጠቱ የተሰማውን ደስታ ይገልጻል፡፡"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/81025283_1407756686061797_5311938164972060672_o-e1578079006312.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="እንኳን ደስ አላችሁ" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/81025283_1407756686061797_5311938164972060672_o-e1578079006312.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/81025283_1407756686061797_5311938164972060672_o-e1578079006312.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/81025283_1407756686061797_5311938164972060672_o-e1578079006312.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8a%a5%e1%8a%95%e1%8a%b3%e1%8a%95-%e1%8b%b0%e1%88%b5-%e1%8a%a0%e1%88%8b%e1%89%bd%e1%88%81-congratulations-%e1%8c%a4%e1%8a%93-%e1%88%9a%e1%8a%92%e1%88%b5%e1%89%b4%e1%88%ad-%e1%8b%a8%e1%8a%a0/" title="እንኳን ደስ አላችሁ!! CONGRATULATIONS!  ጤና ሚኒስቴር የአዲስ አበባ ዩኒቨርስቲ ለዶ/ር ዋቅጋሪ ዴሬሳ አመንቴ የፕሮፌሰርነት ማዕረግ በመስጠቱ የተሰማውን ደስታ ይገልጻል፡፡">
እንኳን ደስ አላችሁ!! CONGRATULATIONS!  ጤና ሚኒስቴር የአዲስ አበባ ዩኒቨርስቲ ለዶ/ር ዋቅጋሪ ዴሬሳ አመንቴ የፕሮፌሰርነት ማዕረግ በመስጠቱ የተሰማውን ደስታ ይገልጻል፡፡									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 3, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62073 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-gears-up-for-increased-cancer-control-with-new-equipment-training-and-smooth-licensing/" title="Ethiopia Gears Up for Increased Cancer Control with New Equipment, Training and Smooth Licensing"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethiopia" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/osman-1140x640-1.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-gears-up-for-increased-cancer-control-with-new-equipment-training-and-smooth-licensing/" title="Ethiopia Gears Up for Increased Cancer Control with New Equipment, Training and Smooth Licensing">
Ethiopia Gears Up for Increased Cancer Control with New Equipment, Training and Smooth Licensing									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 23, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61612 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/us-congress-inching-closer-to-raising-legal-smoking-age-to-21/" title="US Congress inching closer to raising legal smoking age to 21."><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="smoking age" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/yes4.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/us-congress-inching-closer-to-raising-legal-smoking-age-to-21/" title="US Congress inching closer to raising legal smoking age to 21.">
US Congress inching closer to raising legal smoking age to 21.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 17, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Mohammed Hajjii" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63280 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/keekiyyaa-lammesaa-haleelii-eegi-ofirraa-new-%f0%9f%8e%b6oromo-%f0%9f%8e%b6music-2020/" title="Keekiyyaa Lammesaa **Haleelii Eegi Ofirraa** New 🎶Oromo 🎶Music 2020"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-4-1-e1578679255417.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Oromo Music" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-4-1-e1578679255417.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/keekiyyaa-lammesaa-haleelii-eegi-ofirraa-new-%f0%9f%8e%b6oromo-%f0%9f%8e%b6music-2020/" title="Keekiyyaa Lammesaa **Haleelii Eegi Ofirraa** New 🎶Oromo 🎶Music 2020">
Keekiyyaa Lammesaa **Haleelii Eegi Ofirraa** New 🎶Oromo 🎶Music 2020									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 10, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62855 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%88%8b%e1%88%8c-lale-%e1%8a%a0%e1%8b%b2%e1%88%b5-%e1%8b%a8%e1%8a%a6%e1%88%ae%e1%88%9d%e1%8a%9b-%e1%8a%a5%e1%8a%93-%e1%88%b5%e1%88%8d%e1%8c%a5%e1%8a%9b-%e1%88%99%e1%8b%9a%e1%89%83-new-oromo-and-si/" title="ላሌ-Lale &#8211; አዲስ የኦሮምኛ እና ስልጥኛ ሙዚቃ New Oromo and Siltie Music Video HD 2019(Official)"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-22-e1578238078705.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="ስልጥኛ ሙዚቃ" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-22-e1578238078705.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%88%8b%e1%88%8c-lale-%e1%8a%a0%e1%8b%b2%e1%88%b5-%e1%8b%a8%e1%8a%a6%e1%88%ae%e1%88%9d%e1%8a%9b-%e1%8a%a5%e1%8a%93-%e1%88%b5%e1%88%8d%e1%8c%a5%e1%8a%9b-%e1%88%99%e1%8b%9a%e1%89%83-new-oromo-and-si/" title="ላሌ-Lale &#8211; አዲስ የኦሮምኛ እና ስልጥኛ ሙዚቃ New Oromo and Siltie Music Video HD 2019(Official)">
ላሌ-Lale &#8211; አዲስ የኦሮምኛ እና ስልጥኛ ሙዚቃ New Oromo and Siltie Music Video HD 2019(Official)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 5, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62376 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/caalaa-birruu-new-ethiopian-oromoo-music-video-2020-diigee-cabseera-best-oromiffa-music-chala-biru/" title="Caalaa Birruu New Ethiopian Oromoo Music Video 2020 (Diigee Cabseera) Best Oromiffa Music Chala biru"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-5-6-e1577558505846.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Caalaa Birruu" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/pizap-5-6-e1577558505846.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/caalaa-birruu-new-ethiopian-oromoo-music-video-2020-diigee-cabseera-best-oromiffa-music-chala-biru/" title="Caalaa Birruu New Ethiopian Oromoo Music Video 2020 (Diigee Cabseera) Best Oromiffa Music Chala biru">
Caalaa Birruu New Ethiopian Oromoo Music Video 2020 (Diigee Cabseera) Best Oromiffa Music Chala biru									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 28, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63100 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/eagle-hills-launches-addis-ababa-luxury-apartments-sales/" title="Eagle Hills launches Addis Ababa luxury apartments’ sales"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-12-3-e1578491232428.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-12-3-e1578491232428.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/eagle-hills-launches-addis-ababa-luxury-apartments-sales/" title="Eagle Hills launches Addis Ababa luxury apartments’ sales">
Eagle Hills launches Addis Ababa luxury apartments’ sales									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-62928 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-inflation-continues-growing-in-double-digits/" title="Ethiopia inflation continues growing in double digits"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/inflaTION.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethiopia inflation" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/inflaTION.png?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/inflaTION.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/inflaTION.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/inflaTION.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-inflation-continues-growing-in-double-digits/" title="Ethiopia inflation continues growing in double digits">
Ethiopia inflation continues growing in double digits									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-61264 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/over-83-of-ethiopians-suffer-from-multidimensional-poverty/" title="Over 83% Of Ethiopians Suffer From Multidimensional Poverty"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Poverty" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/12/77121411_2353446398093760_1533623909620908032_n-e1575815877419.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/over-83-of-ethiopians-suffer-from-multidimensional-poverty/" title="Over 83% Of Ethiopians Suffer From Multidimensional Poverty">
Over 83% Of Ethiopians Suffer From Multidimensional Poverty									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 12, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
</div>
</footer>
<div class="mh-footer-nav-mobile"></div>
<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
</nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright @2016 kichuu.com              		</p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-58166095-1', 'auto');
ga('send', 'pageview');
</script>			<div id="fb-root"></div>
<script>
(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202003'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.0/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://kichuu.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202003.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:8.0',blog:'111820558',post:'63411',tz:'-4',srv:'kichuu.com'} ]);
_stq.push([ 'clickTrackerInit', '111820558', '63411' ]);
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.524859905243 seconds, on 14-01-20 13:02:50 -->