<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head><style>img.lazy{min-height:1px}</style><link rel="preload" href="https://kichuu.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js" as="script">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo &#x2d; Kichuu</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="robots" content="max-snippet:-1,max-image-preview:standard,max-video-preview:-1" />
<meta name="description" content="Oromia deputy president Addisu Arega blames Oromo discontent on Egypt and TPLF and promises to use plenty of force against protesters." />
<meta property="og:image" content="https://kichuu.com/wp-content/uploads/2020/06/pizap-6-scaled.jpg" />
<meta property="og:image:width" content="667" />
<meta property="og:image:height" content="500" />
<meta property="og:image:alt" content="Bilxigina" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo &#x2d; Kichuu" />
<meta property="og:description" content="Oromia deputy president Addisu Arega blames Oromo discontent on Egypt and TPLF and promises to use plenty of force against protesters." />
<meta property="og:url" content="https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:published_time" content="2020-06-06T18:08+00:00" />
<meta property="article:modified_time" content="2020-06-06T18:08+00:00" />
<meta property="og:updated_time" content="2020-06-06T18:08+00:00" />
<link rel="canonical" href="https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://kichuu.com/","name":"Kichuu is an online news publisher focusing on East Africa"}},{"@type":"ListItem","position":2,"item":{"@id":"https://kichuu.com/category/afaan-oromoo/","name":"Afaan Oromoo"}},{"@type":"ListItem","position":3,"item":{"@id":"https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/","name":"News"}},{"@type":"ListItem","position":4,"item":{"@id":"https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/","name":"ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 14.06ms meta | 43.47ms boot -->

<link rel="amphtml" href="https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/amp/" /><meta name="generator" content="AMP for WP 1.0.52"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo Comments Feed" href="https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/feed/" />
<link rel="stylesheet" href="https://kichuu.com/wp-content/cache/minify/45b8c.css" media="all" />





<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script src="https://kichuu.com/wp-content/cache/minify/e7d24.js"></script>



<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
	<link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-270x270.png" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-71781 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-top">
							<form role="search" method="get" class="search-form" action="https://kichuu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81"   alt="Kichuu" data-srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" data-sizes="(max-width: 331px) 100vw, 331px" class="custom-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="331" height="81" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20331%2081'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" class="custom-logo lazy" alt="Kichuu" data-srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w" data-sizes="(max-width: 331px) 100vw, 331px" /></noscript></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ads20171214 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3403389782"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
	<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
	<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
	<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
	<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
	<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
	<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
	<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/" title="ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/bilxiginnaan-farra-tokkummaa-oromooti/" title="Bilxiginnaan farra tokkummaa Oromooti!!">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Bilxiginnaan farra tokkummaa Oromooti!!						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Videos							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/godina-arsii-aanna-muuneessaa/" title="Godina Arsii Aanna Muuneessaa!!">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Godina Arsii Aanna Muuneessaa!!						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/oromia-these-are-some-of-the-political-prisoners-currently-held-with-no-charge-in-borana-zone-alone/" title="Oromia: These are some of the political prisoners currently held with no charge, in Borana Zone alone.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Oromia: These are some of the political prisoners currently held with no charge, in Borana Zone alone.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/ethiopia-needs-an-inclusive-two-year-transitional-period/" title="Ethiopia needs an inclusive two-year transitional period">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Ethiopia needs an inclusive two-year transitional period						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/oromia-government-warns-against-planned-protests/" title="Oromia Government Warns Against Planned Protests">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Oromia Government Warns Against Planned Protests						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/the-barbaric-ethiopian-security-forces-are-out-of-control-killing-the-oromo-people-indiscriminately/" title="The Barbaric Ethiopian security forces are out of control killing the Oromo people indiscriminately!">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							The Barbaric Ethiopian security forces are out of control killing the Oromo people indiscriminately!						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/ethiopia-in-quagmire-the-regression-of-the-transition/" title="Ethiopia in Quagmire: the regression of the transition">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Ethiopia in Quagmire: the regression of the transition						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/oromia-ethiopia-alert-violation-of-human-rights-is-happening-under-the-premiership-of-a-nobel-peace-laurate-abiy-ahmed/" title="Oromia/Ethiopia : Alert! Violation of human rights is happening under the premiership of a Nobel Peace Laurate Abiy Ahmed.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 6, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Oromia/Ethiopia : Alert! Violation of human rights is happening under the premiership of a Nobel Peace Laurate Abiy Ahmed.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/ethiopian-migrants-forced-home-empty-handed-by-coronavirus/" title="Ethiopian migrants forced home empty-handed by coronavirus">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ June 5, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Ethiopian migrants forced home empty-handed by coronavirus						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://kichuu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/" itemprop="item"><span itemprop="name">News</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo</nav>
<article id="post-71781" class="post-71781 post type-post status-publish format-standard has-post-thumbnail hentry category-news-afaan-oromoo">
	<header class="entry-header clearfix"><h1 class="entry-title">ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F&t=ODUU+Hatattama+Iccitii+Bilxigina+ABO+TPLF+PBO+Jaal+Marroo+kuno+itii+dhiyadha+%7C+Moha+oromo', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=ODUU+Hatattama+Iccitii+Bilxigina+ABO+TPLF+PBO+Jaal+Marroo+kuno+itii+dhiyadha+%7C+Moha+oromo:&url=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F&media=https://kichuu.com/wp-content/uploads/2020/06/pizap-6-scaled.jpg&description=ODUU+Hatattama+Iccitii+Bilxigina+ABO+TPLF+PBO+Jaal+Marroo+kuno+itii+dhiyadha+%7C+Moha+oromo', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=ODUU%20Hatattama%20Iccitii%20Bilxigina%20ABO%20TPLF%20PBO%20Jaal%20Marroo%20kuno%20itii%20dhiyadha%20%7C%20Moha%20oromo&amp;body=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
<p><strong>ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaa Marroo kuno itii dhiyadha | Moha Oromo</strong></p>
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- k20200225 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3156329304"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><iframe  width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-src="https://www.youtube.com/embed/_5-iUNcTSvQ" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Oromia deputy president Addisu Arega blames Oromo discontent on Egypt and TPLF and promises to use plenty of force against protesters.</p>
<p>This is same old EPRDF-era externalisation and authoritarian zero-sum politics; you&#8217;re either with us or against us. <a href="https://t.co/9IoP2xfebh">https://t.co/9IoP2xfebh</a> <a href="https://t.co/PTkDTe7Mwq">pic.twitter.com/PTkDTe7Mwq</a></p>
<p>— William Davison (@wdavison10) <a href="https://twitter.com/wdavison10/status/1269166333305946113?ref_src=twsrc%5Etfw">June 6, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<hr />
<h1 class="title style-scope ytd-video-primary-info-renderer">Haala Yeroo Irratti Akka Waa Jedhu Warroonni Nagaafattan Itti Dhiyaadhaa Tolchaa Huseen Maddaa</h1>
<p><iframe  width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-src="https://www.youtube.com/embed/_TuC02yHiwE" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<!-- AI CONTENT END 1 -->
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F&t=ODUU+Hatattama+Iccitii+Bilxigina+ABO+TPLF+PBO+Jaal+Marroo+kuno+itii+dhiyadha+%7C+Moha+oromo', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=ODUU+Hatattama+Iccitii+Bilxigina+ABO+TPLF+PBO+Jaal+Marroo+kuno+itii+dhiyadha+%7C+Moha+oromo:&url=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F&media=https://kichuu.com/wp-content/uploads/2020/06/pizap-6-scaled.jpg&description=ODUU+Hatattama+Iccitii+Bilxigina+ABO+TPLF+PBO+Jaal+Marroo+kuno+itii+dhiyadha+%7C+Moha+oromo', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=ODUU%20Hatattama%20Iccitii%20Bilxigina%20ABO%20TPLF%20PBO%20Jaal%20Marroo%20kuno%20itii%20dhiyadha%20%7C%20Moha%20oromo&amp;body=https%3A%2F%2Fkichuu.com%2Foduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
	</div><div id="custom_html-7" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20190303 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3737122119"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/bilxiginnaan-farra-tokkummaa-oromooti/" rel="prev"><img width="80" height="60"   alt="Bilxiginnaan" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/102305060_1191182457935458_2181444521546231513_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/102305060_1191182457935458_2181444521546231513_n-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/102305060_1191182457935458_2181444521546231513_n-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/102305060_1191182457935458_2181444521546231513_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Bilxiginnaan" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/102305060_1191182457935458_2181444521546231513_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/102305060_1191182457935458_2181444521546231513_n-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript><span>Previous</span><p>Bilxiginnaan farra tokkummaa Oromooti!!</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='71781' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="99b9c880c8" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="47"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-71565 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done"><img width="326" height="245"   alt="Ego Aside" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/say-oromia-80x60.jpg 80w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg" data-sizes="(max-width: 326px) 100vw, 326px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Ego Aside" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/say-oromia-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done">
												Putting Your Ego Aside and Getting the Job Done											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 3, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Putting Your Ego Aside and Getting the Job Done (Avoid Making the Same Mistake Twice) By Worku Burayu (Ph.D), June 3, 2020 Summary: Let’s load our Gada package that consists of seeing things intelligently, listening <a class="mh-excerpt-more" href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-70935 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia"><img width="209" height="241"   alt="Prospect for Uniting or Dismantling Ethiopia" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg 209w, https://kichuu.com/wp-content/uploads/2020/05/wbo-officers-173x200.jpg 173w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg" data-sizes="(max-width: 209px) 100vw, 209px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="209" height="241" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20209%20241'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Prospect for Uniting or Dismantling Ethiopia" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg 209w, https://kichuu.com/wp-content/uploads/2020/05/wbo-officers-173x200.jpg 173w" data-sizes="(max-width: 209px) 100vw, 209px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia">
												Prospect for Uniting or Dismantling Ethiopia											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 25, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Prospect for Uniting or Dismantling Ethiopia- “it is in our hand”-Oromo Liberation Army (OLA) By Worku Burayu (Ph.D.), May 25, 2020 Summary: “The remaining chance for united or dismantled Ethiopia falls on the hands of <a class="mh-excerpt-more" href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-70152 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion"><img width="326" height="245"   alt="crisis" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-80x60.jpg 80w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg" data-sizes="(max-width: 326px) 100vw, 326px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="crisis" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion">
												Ethiopia’s Dilemma and the Prime Minister’s Confusion											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 10, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Ethiopia’s Dilemma and the Prime Minister’s Confusion By Guluma Gemeda, PhD, May 10, 2020  Prime Minister Abiy Ahmed’s statements on Ethiopia’s election postponement, apparent constitutional crisis and the future of democracy in Ethiopia are full <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-69016 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia"><img width="325" height="217"   alt="Genocide" data-src="https://kichuu.com/wp-content/uploads/2018/08/Olf-flag.gif" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="325" height="217" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20325%20217'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2018/08/Olf-flag.gif" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Genocide" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia">
												Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 14, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia By: Itana Gammada, April 14, 2020 A people under colonial occupation have a maximum of two choices, either stand up and fight for their freedom <a class="mh-excerpt-more" href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-68078 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely"><img width="326" height="206"   alt="Abiy Ahmed" data-src="https://kichuu.com/wp-content/uploads/2020/04/close-326x206.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="206" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20206'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/04/close-326x206.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Abiy Ahmed" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">
												Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 1, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely (Our Struggle is Significantly Bigger than the Restoration of Internet/Phones Access) By Worku Burayu (PhD), April 1, 2020 Summary: Oromoo Sabakoo: Our struggle is <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-67990 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!"><img width="326" height="245"   alt="Democracy" data-srcset="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-80x60.jpg 80w"  data-src="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg" data-sizes="(max-width: 326px) 100vw, 326px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Democracy" data-srcset="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!">
												There were some false starts at democracy in Ethiopia – let us make it real this time round!											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 30, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">There were some false starts at democracy in Ethiopia – let us make it real this time round! By Taha Abdi, founder member of the OLF and former member of its executive committee February 20, <a class="mh-excerpt-more" href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!">[Read More]</a></div>								</div>
							</div>
						</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71781 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/oduu-hatattama-iccitii-bilxigina-abo-tplf-pbo-jaal-marroo-kuno-itii-dhiyadha-moha-oromo/" title="ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo">
										ODUU Hatattama Iccitii Bilxigina ABO TPLF PBO Jaal Marroo kuno itii dhiyadha | Moha oromo									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71773 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/bilxiginnaan-farra-tokkummaa-oromooti/" title="Bilxiginnaan farra tokkummaa Oromooti!!">
										Bilxiginnaan farra tokkummaa Oromooti!!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71766 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/godina-arsii-aanna-muuneessaa/" title="Godina Arsii Aanna Muuneessaa!!">
										Godina Arsii Aanna Muuneessaa!!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71759 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/oromia-these-are-some-of-the-political-prisoners-currently-held-with-no-charge-in-borana-zone-alone/" title="Oromia: These are some of the political prisoners currently held with no charge, in Borana Zone alone.">
										Oromia: These are some of the political prisoners currently held with no charge, in Borana Zone alone.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71750 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-needs-an-inclusive-two-year-transitional-period/" title="Ethiopia needs an inclusive two-year transitional period">
										Ethiopia needs an inclusive two-year transitional period									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71747 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/oromia-government-warns-against-planned-protests/" title="Oromia Government Warns Against Planned Protests">
										Oromia Government Warns Against Planned Protests									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71733 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/the-barbaric-ethiopian-security-forces-are-out-of-control-killing-the-oromo-people-indiscriminately/" title="The Barbaric Ethiopian security forces are out of control killing the Oromo people indiscriminately!">
										The Barbaric Ethiopian security forces are out of control killing the Oromo people indiscriminately!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71736 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-in-quagmire-the-regression-of-the-transition/" title="Ethiopia in Quagmire: the regression of the transition">
										Ethiopia in Quagmire: the regression of the transition									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71730 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/oromia-ethiopia-alert-violation-of-human-rights-is-happening-under-the-premiership-of-a-nobel-peace-laurate-abiy-ahmed/" title="Oromia/Ethiopia : Alert! Violation of human rights is happening under the premiership of a Nobel Peace Laurate Abiy Ahmed.">
										Oromia/Ethiopia : Alert! Violation of human rights is happening under the premiership of a Nobel Peace Laurate Abiy Ahmed.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 6, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71727 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopian-migrants-forced-home-empty-handed-by-coronavirus/" title="Ethiopian migrants forced home empty-handed by coronavirus">
										Ethiopian migrants forced home empty-handed by coronavirus									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71721 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/abiyot-must-goabiy-nobeeliis-yeroo-muraasaan-booda-ni-hiikkata/" title="Abiyot Must Go!Abiy nobeeliis yeroo muraasaan booda ni hiikkata:">
										Abiyot Must Go!Abiy nobeeliis yeroo muraasaan booda ni hiikkata:									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71718 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-our-deepest-concern-about-mr-abdi-regassas-mistreatment-in-prison/" title="Ethiopia: Our Deepest Concern about Mr. Abdi Regassa’s Mistreatment in Prison">
										Ethiopia: Our Deepest Concern about Mr. Abdi Regassa’s Mistreatment in Prison									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71715 post type-post status-publish format-standard has-post-thumbnail category-tv">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/biyya-norway-keessatti-gabaasa-amnastii-booda-waaee-badhaasa-noobelii-maaltu-jedhamaa-jira/" title="Biyya Norway keessatti gabaasa Amnastii booda waa&#8217;ee badhaasa Noobelii maaltu jedhamaa jira?">
										Biyya Norway keessatti gabaasa Amnastii booda waa&#8217;ee badhaasa Noobelii maaltu jedhamaa jira?									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71710 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/urban-layers-of-political-rupture-the-new-politics-of-addis-ababas-megaprojects/" title="Urban layers of political rupture: the ‘new’ politics of Addis Ababa’s megaprojects">
										Urban layers of political rupture: the ‘new’ politics of Addis Ababa’s megaprojects									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71705 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/jijjiramaa-osoo-eeganuu-micciramaa-mudannee/" title="Jijjiramaa Osoo eeganuu Micciramaa mudannee!!">
										Jijjiramaa Osoo eeganuu Micciramaa mudannee!!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 5, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71695 post type-post status-publish format-standard has-post-thumbnail category-amharic">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%88%8d%e1%8b%a9-%e1%88%98%e1%88%a8%e1%8c%83-%e1%8b%a8%e1%88%b6%e1%88%9b%e1%88%8c-%e1%8a%ad%e1%88%8d%e1%88%8d-%e1%88%9d%e1%8a%ad%e1%88%ad-%e1%89%a4%e1%89%b5-%e1%8a%a0%e1%89%a3%e1%88%8b%e1%89%b5/" title="ልዩ መረጃ! የሶማሌ ክልል ምክር ቤት አባላት ድብደባ ውዝግብ">
										ልዩ መረጃ! የሶማሌ ክልል ምክር ቤት አባላት ድብደባ ውዝግብ									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 4, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71688 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/whats-behind-the-ethiopia-sudan-border-row/" title="What’s behind the Ethiopia-Sudan border row?">
										What’s behind the Ethiopia-Sudan border row?									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 4, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71680 post type-post status-publish format-standard has-post-thumbnail category-radio">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/warraaqsa-galaana-uummataa-waxabajjii-8-2020-irraa-qabuun-goleelee-oromiyaa-cufa-keessatti/" title="Warraaqsa Galaana Uummataa, Waxabajjii 8, 2020 irraa qabuun, goleelee Oromiyaa cufa keessatti">
										Warraaqsa Galaana Uummataa, Waxabajjii 8, 2020 irraa qabuun, goleelee Oromiyaa cufa keessatti									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 4, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71674 post type-post status-publish format-standard has-post-thumbnail category-amharic">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/now-habeshas-are-openly-saying-we-are-from-levant/" title="Now Habeshas are openly saying &#8216;we are from Levant&#8217;!!">
										Now Habeshas are openly saying &#8216;we are from Levant&#8217;!!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 4, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71672 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/waaee-addisuu-araggaa-qixaa-kana-beektu-laata/" title="Waa&#8217;ee Addisuu Araggaa Qixaa Kana Beektu Laata?">
										Waa&#8217;ee Addisuu Araggaa Qixaa Kana Beektu Laata?									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 4, 2020</a></span>
</div>
							</div>
						</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://kichuu.com/2020/06/'> June 2020 </option>
	<option value='https://kichuu.com/2020/05/'> May 2020 </option>
	<option value='https://kichuu.com/2020/04/'> April 2020 </option>
	<option value='https://kichuu.com/2020/03/'> March 2020 </option>
	<option value='https://kichuu.com/2020/02/'> February 2020 </option>
	<option value='https://kichuu.com/2020/01/'> January 2020 </option>
	<option value='https://kichuu.com/2019/12/'> December 2019 </option>
	<option value='https://kichuu.com/2019/11/'> November 2019 </option>
	<option value='https://kichuu.com/2019/10/'> October 2019 </option>
	<option value='https://kichuu.com/2019/09/'> September 2019 </option>
	<option value='https://kichuu.com/2019/08/'> August 2019 </option>
	<option value='https://kichuu.com/2019/07/'> July 2019 </option>
	<option value='https://kichuu.com/2019/06/'> June 2019 </option>
	<option value='https://kichuu.com/2019/05/'> May 2019 </option>
	<option value='https://kichuu.com/2019/04/'> April 2019 </option>
	<option value='https://kichuu.com/2019/03/'> March 2019 </option>
	<option value='https://kichuu.com/2019/02/'> February 2019 </option>
	<option value='https://kichuu.com/2019/01/'> January 2019 </option>
	<option value='https://kichuu.com/2018/12/'> December 2018 </option>
	<option value='https://kichuu.com/2018/11/'> November 2018 </option>
	<option value='https://kichuu.com/2018/10/'> October 2018 </option>
	<option value='https://kichuu.com/2018/09/'> September 2018 </option>
	<option value='https://kichuu.com/2018/08/'> August 2018 </option>
	<option value='https://kichuu.com/2018/07/'> July 2018 </option>
	<option value='https://kichuu.com/2018/06/'> June 2018 </option>
	<option value='https://kichuu.com/2018/05/'> May 2018 </option>
	<option value='https://kichuu.com/2018/04/'> April 2018 </option>
	<option value='https://kichuu.com/2018/03/'> March 2018 </option>
	<option value='https://kichuu.com/2018/02/'> February 2018 </option>
	<option value='https://kichuu.com/2018/01/'> January 2018 </option>
	<option value='https://kichuu.com/2017/12/'> December 2017 </option>
	<option value='https://kichuu.com/2017/11/'> November 2017 </option>
	<option value='https://kichuu.com/2017/10/'> October 2017 </option>
	<option value='https://kichuu.com/2017/09/'> September 2017 </option>
	<option value='https://kichuu.com/2017/08/'> August 2017 </option>
	<option value='https://kichuu.com/2017/07/'> July 2017 </option>
	<option value='https://kichuu.com/2017/06/'> June 2017 </option>
	<option value='https://kichuu.com/2017/05/'> May 2017 </option>
	<option value='https://kichuu.com/2017/04/'> April 2017 </option>
	<option value='https://kichuu.com/2017/03/'> March 2017 </option>
	<option value='https://kichuu.com/2017/02/'> February 2017 </option>
	<option value='https://kichuu.com/2017/01/'> January 2017 </option>
	<option value='https://kichuu.com/2016/12/'> December 2016 </option>
	<option value='https://kichuu.com/2016/11/'> November 2016 </option>
	<option value='https://kichuu.com/2013/11/'> November 2013 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720"  allowfullscreen data-src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe>
        		</div>
			</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>June 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr><td><a href="https://kichuu.com/2020/06/01/" aria-label="Posts published on June 1, 2020">1</a></td><td><a href="https://kichuu.com/2020/06/02/" aria-label="Posts published on June 2, 2020">2</a></td><td><a href="https://kichuu.com/2020/06/03/" aria-label="Posts published on June 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/06/04/" aria-label="Posts published on June 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/06/05/" aria-label="Posts published on June 5, 2020">5</a></td><td id="today"><a href="https://kichuu.com/2020/06/06/" aria-label="Posts published on June 6, 2020">6</a></td><td>7</td>
	</tr>
	<tr>
		<td>8</td><td>9</td><td>10</td><td>11</td><td>12</td><td>13</td><td>14</td>
	</tr>
	<tr>
		<td>15</td><td>16</td><td>17</td><td>18</td><td>19</td><td>20</td><td>21</td>
	</tr>
	<tr>
		<td>22</td><td>23</td><td>24</td><td>25</td><td>26</td><td>27</td><td>28</td>
	</tr>
	<tr>
		<td>29</td><td>30</td>
		<td class="pad" colspan="5">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://kichuu.com/2020/05/">&laquo; May</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71669 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/a-renowned-geneticist-and-agronomist-cautions-against-the-adoption-of-gmo-crops/" title="A renowned geneticist and agronomist cautions against the adoption of GMO crops"><img width="80" height="60"   alt="GMO" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/melaku_worede_bonn-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/melaku_worede_bonn-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/melaku_worede_bonn-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/melaku_worede_bonn-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="GMO" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/melaku_worede_bonn-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/melaku_worede_bonn-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/a-renowned-geneticist-and-agronomist-cautions-against-the-adoption-of-gmo-crops/" title="A renowned geneticist and agronomist cautions against the adoption of GMO crops">
										A renowned geneticist and agronomist cautions against the adoption of GMO crops									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 4, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71616 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/omn-ibsa-biiroo-eegumsa-fayyaa-oromiyaa-waxabajjii-03-2020/" title="OMN: Ibsa Biiroo Eegumsa Fayyaa Oromiyaa Waxabajjii 03 2020"><img width="80" height="60"   alt="" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/Untitled-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/06/Untitled-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/Untitled-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/Untitled-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/Untitled-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/06/Untitled-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/omn-ibsa-biiroo-eegumsa-fayyaa-oromiyaa-waxabajjii-03-2020/" title="OMN: Ibsa Biiroo Eegumsa Fayyaa Oromiyaa Waxabajjii 03 2020">
										OMN: Ibsa Biiroo Eegumsa Fayyaa Oromiyaa Waxabajjii 03 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 3, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71581 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/cdc-as-schools-businesses-and-community-organizations-begin-to-resume-operations-during-covid-19-protect-yourself-and-others-when-using-public-transportation/" title="CDC: As schools, businesses, and community organizations begin to resume operations during COVID-19, protect yourself and others when using public transportation:"><img width="80" height="60"   alt="COVID-19" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/yes7-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/06/yes7-678x509.png 678w, https://kichuu.com/wp-content/uploads/2020/06/yes7-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/yes7-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/yes7-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="COVID-19" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/yes7-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/06/yes7-678x509.png 678w, https://kichuu.com/wp-content/uploads/2020/06/yes7-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/cdc-as-schools-businesses-and-community-organizations-begin-to-resume-operations-during-covid-19-protect-yourself-and-others-when-using-public-transportation/" title="CDC: As schools, businesses, and community organizations begin to resume operations during COVID-19, protect yourself and others when using public transportation:">
										CDC: As schools, businesses, and community organizations begin to resume operations during COVID-19, protect yourself and others when using public transportation:									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 3, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60"   alt="Mohammed Hajjii" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w"  data-src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Mohammed Hajjii" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
										Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60"   alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
										“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60"   alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/04/robe-678x509.png 678w, https://kichuu.com/wp-content/uploads/2019/04/robe-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/04/robe-678x509.png 678w, https://kichuu.com/wp-content/uploads/2019/04/robe-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
										Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71636 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/tulluu-taaddasaa-jalaa-bani-mee-new-oromo-music-2020/" title="Tulluu Taaddasaa JALAA BANI MEE New Oromo Music 2020!!"><img width="80" height="60"   alt="Tulluu Taaddasaa" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/pizap-62-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-scaled.jpg 667w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/pizap-62-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/pizap-62-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Tulluu Taaddasaa" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/pizap-62-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/pizap-62-scaled.jpg 667w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/tulluu-taaddasaa-jalaa-bani-mee-new-oromo-music-2020/" title="Tulluu Taaddasaa JALAA BANI MEE New Oromo Music 2020!!">
										Tulluu Taaddasaa JALAA BANI MEE New Oromo Music 2020!!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 3, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71424 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/tafarii-zarfuu-dirree-haqaa-new-oromo-music-2020/" title="Tafarii Zarfuu Dirree Haqaa New Oromo Music 2020."><img width="80" height="60"   alt="Tafarii Zarfuu" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/pizap-46-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-scaled.jpg 667w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/pizap-46-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/pizap-46-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Tafarii Zarfuu" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/pizap-46-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/pizap-46-scaled.jpg 667w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/tafarii-zarfuu-dirree-haqaa-new-oromo-music-2020/" title="Tafarii Zarfuu Dirree Haqaa New Oromo Music 2020.">
										Tafarii Zarfuu Dirree Haqaa New Oromo Music 2020.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 31, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-71400 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/keekiyyaa-badhaadhaa-baasii-dhugaa-new-oromo-music/" title="Keekiyyaa Badhaadhaa &#8211; Baasii Dhugaa &#8211; New Oromo Music"><img width="80" height="60"   alt="Keekiyyaa Badhaadhaa" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/kiya-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/05/kiya-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/kiya-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/kiya-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Keekiyyaa Badhaadhaa" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/kiya-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/05/kiya-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/keekiyyaa-badhaadhaa-baasii-dhugaa-new-oromo-music/" title="Keekiyyaa Badhaadhaa &#8211; Baasii Dhugaa &#8211; New Oromo Music">
										Keekiyyaa Badhaadhaa &#8211; Baasii Dhugaa &#8211; New Oromo Music									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 31, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-69600 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-al-amoudi-fires-midroc-ceo-dr-arega/" title="Ethiopia – Al Amoudi fires MIDROC CEO Dr. Arega"><img width="80" height="60"   alt="MIDROC" data-src="https://kichuu.com/wp-content/uploads/2020/04/aregapic-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/04/aregapic-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="MIDROC" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-al-amoudi-fires-midroc-ceo-dr-arega/" title="Ethiopia – Al Amoudi fires MIDROC CEO Dr. Arega">
										Ethiopia – Al Amoudi fires MIDROC CEO Dr. Arega									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 27, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-69446 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/how-new-proposed-us-restrictions-on-chip-making-equipment-will-affect-africa/" title="How new proposed US restrictions on chip-making equipment will affect Africa"><img width="80" height="60"   alt="chip-making equipment" data-srcset="https://kichuu.com/wp-content/uploads/2020/04/Untitled-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/04/Untitled-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/04/Untitled-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/04/Untitled-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="chip-making equipment" data-srcset="https://kichuu.com/wp-content/uploads/2020/04/Untitled-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/04/Untitled-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/how-new-proposed-us-restrictions-on-chip-making-equipment-will-affect-africa/" title="How new proposed US restrictions on chip-making equipment will affect Africa">
										How new proposed US restrictions on chip-making equipment will affect Africa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 24, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68927 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%8b%a8%e1%8a%a2%e1%89%b5%e1%8b%ae%e1%8c%b5%e1%8b%ab-%e1%8a%95%e1%8c%8d%e1%8b%b5-%e1%89%a3%e1%8a%95%e1%8a%ad-%e1%89%a6%e1%88%ad%e1%8b%b5-%e1%8b%98%e1%88%a8%e1%8a%9d%e1%8a%90%e1%89%b5-%e1%8a%a0/" title="የኢትዮጵያ ንግድ ባንክ ቦርድ ዘረኝነት አይኑን ስለወረው በጥድፊያ እየተወራጨ ነው።"><img width="80" height="60"   alt="የኢትዮጵያ ንግድ ባንክ ቦርድ" data-srcset="https://kichuu.com/wp-content/uploads/2020/04/Commercial-Bank-of-Ethiopia-_-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/04/Commercial-Bank-of-Ethiopia-_-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/04/Commercial-Bank-of-Ethiopia-_-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/04/Commercial-Bank-of-Ethiopia-_-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="የኢትዮጵያ ንግድ ባንክ ቦርድ" data-srcset="https://kichuu.com/wp-content/uploads/2020/04/Commercial-Bank-of-Ethiopia-_-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/04/Commercial-Bank-of-Ethiopia-_-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a2%e1%89%b5%e1%8b%ae%e1%8c%b5%e1%8b%ab-%e1%8a%95%e1%8c%8d%e1%8b%b5-%e1%89%a3%e1%8a%95%e1%8a%ad-%e1%89%a6%e1%88%ad%e1%8b%b5-%e1%8b%98%e1%88%a8%e1%8a%9d%e1%8a%90%e1%89%b5-%e1%8a%a0/" title="የኢትዮጵያ ንግድ ባንክ ቦርድ ዘረኝነት አይኑን ስለወረው በጥድፊያ እየተወራጨ ነው።">
										የኢትዮጵያ ንግድ ባንክ ቦርድ ዘረኝነት አይኑን ስለወረው በጥድፊያ እየተወራጨ ነው።									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 13, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright @2016 kichuu.com              		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-58166095-1', 'auto');
  ga('send', 'pageview');

</script>			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> <script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>

<script src="https://kichuu.com/wp-content/cache/minify/9cc9c.js"></script>

<script type='text/javascript'>
lazySizes.cfg.nativeLoading={setLoadingAttribute:false,disableListeners:{scroll:true}};lazySizes.init();
</script>


<script src="https://kichuu.com/wp-content/cache/minify/4ab7c.js"></script>

<script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src="https://kichuu.com/wp-content/cache/minify/1615d.js"></script>
</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 
Lazy Loading
Minified using disk
Database Caching 127/148 queries in 0.370 seconds using disk

Served from: kichuu.com @ 2020-06-06 14:08:25 by W3 Total Cache
-->