<!DOCTYPE html><html class="no-js mh-one-sb" lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11" /> <noscript id="aonoscrcss"></noscript><title>International media are urged to respect Ethiopian laws &#8211; Kichuu</title><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; International media are urged to respect Ethiopian laws Comments Feed" href="https://kichuu.com/international-media-are-urged-to-respect-ethiopian-laws/feed/" /><!-- <link rel='stylesheet' id='wp-block-library-css'  href='https://kichuu.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/cache/autoptimize/css/autoptimize_single_4bc19d35d9e5befbc0d4ac845aab7f5b.css?ver=5.4' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/cache/autoptimize/css/autoptimize_single_617c65fef3747d563db91bb13aa7bf68.css?ver=1.7.5' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/cache/autoptimize/css/autoptimize_single_99db444516eac8eeb6d4917ae34d2191.css?ver=3.9.8' type='text/css' media='all' /> --><!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/pfkb096/2lnqh.css" media="all"/><link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' /> <script src='//kichuu.com/wp-content/cache/wpfc-minified/33alo9g4/ab99k.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://kichuu.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> -->
<!-- <script defer type='text/javascript' src='https://kichuu.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> --> <!-- <script defer type='text/javascript' src='https://kichuu.com/wp-content/cache/autoptimize/js/autoptimize_single_c46dd8af747321bc408cc73d09d12b54.js?ver=3.9.8' id='mh-scripts-js'></script> --> <link rel="https://api.w.org/" href="https://kichuu.com/wp-json/" /><link rel="alternate" type="application/json" href="https://kichuu.com/wp-json/wp/v2/posts/89043" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /><link rel="canonical" href="https://kichuu.com/international-media-are-urged-to-respect-ethiopian-laws/" /><link rel='shortlink' href='https://kichuu.com/?p=89043' /><link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F" /><link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&#038;format=xml" /><style type="text/css">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</style><!--[if lt IE 9]> <script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script> <![endif]--><style type="text/css">.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }</style><style type="text/css" id="custom-background-css">body.custom-background { background-color: #e5e4e2; }</style><link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-32x32.png" sizes="32x32" /><link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-180x180.png" /><meta name="msapplication-TileImage" content="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-270x270.png" /></head><body id="mh-mobile" class="post-template-default single single-post postid-89043 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="mh-container mh-container-outer"><div class="mh-header-nav-mobile clearfix"></div><div class="mh-preheader"><div class="mh-container mh-container-inner mh-row clearfix"><div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix"><nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li><li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li><li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li><li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li><li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li><li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li></ul></div></nav></div><div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix"><aside class="mh-header-search mh-header-search-top"><form role="search" method="get" class="search-form" action="https://kichuu.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="mh-container mh-container-inner clearfix"><div class="mh-custom-header clearfix"><div class="mh-header-columns mh-row clearfix"><div class="mh-col-1-3 mh-site-identity"><div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand"> <a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" class="custom-logo" alt="Kichuu" srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w" sizes="(max-width: 331px) 100vw, 331px" /></a></div></div><aside class="mh-col-2-3 mh-header-widget-2"><div id="custom_html-14" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="5930196910"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></aside></div></div></div><div class="mh-main-nav-wrap"><nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li><li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li><li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li></ul></li><li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><ul class="sub-menu"><li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li><li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li><li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li><li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li></ul></li><li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li><li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a><ul class="sub-menu"><li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li><li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li></ul></li><li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li><li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li><li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li></ul></div></nav></div></header><div class="mh-subheader"><div class="mh-container mh-container-inner mh-row clearfix"><div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix"><div class="mh-header-ticker mh-header-ticker-bottom"><div class="mh-ticker-bottom"><div class="mh-ticker-title mh-ticker-title-bottom"> News Ticker<i class="fa fa-chevron-right"></i></div><div class="mh-ticker-content mh-ticker-content-bottom"><ul id="mh-ticker-loop-bottom"><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/international-media-are-urged-to-respect-ethiopian-laws/" title="International media are urged to respect Ethiopian laws"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> International media are urged to respect Ethiopian laws </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> World </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/maalitti-jiru/" title="Maalitti jiru?"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Maalitti jiru? </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/no-justice-in-ethiopia-gaaffii-tauu-baatus-yaadumatti-akka-qabannuufi/" title="No Justice In Ethiopia: Gaaffii ta’uu baatus yaadumatti akka qabannuufi"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> No Justice In Ethiopia: Gaaffii ta’uu baatus yaadumatti akka qabannuufi </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/no-justice-no-feast-how-hunger-strikers-are-keeping-the-protest-over-oromos-un-just-treatment-in-ethiopia-by-abiy-ahmes-government/" title="No justice, no feast: How hunger strikers are keeping the protest over Oromo&#8217;s un just treatment in Ethiopia by Abiy Ahme&#8217;s Government."> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> No justice, no feast: How hunger strikers are keeping the protest over Oromo&#8217;s un just treatment in Ethiopia by Abiy Ahme&#8217;s Government. </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Africa </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/%e1%8d%8a%e1%8a%95%e1%8d%8a%e1%8a%94-%e1%88%b8%e1%8c%88%e1%88%ad-%e1%8a%a0%e1%8b%b2%e1%88%b5-%e1%8a%a0%e1%89%a0%e1%89%a3-%e1%8a%a8-1973-2017/" title="ፊንፊኔ/ሸገር/አዲስ አበባ ከ 1973 -2017"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> ፊንፊኔ/ሸገር/አዲስ አበባ ከ 1973 -2017 </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Amharic </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/%e1%8a%a0%e1%88%9d%e1%8a%90%e1%88%b5%e1%89%b2%e1%8d%a4-%e1%89%a0%e1%8a%a0%e1%8a%ad%e1%88%b1%e1%88%9d-%e1%89%a0%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%8b%88%e1%89%b3%e1%8b%b0%e1%88%ae%e1%89%bd/" title="አምነስቲ፤ «በአክሱም በኤርትራ ወታደሮች የተፈጸመው የጅምላ ግድያ በሰብአዊ ፍጡር ላይ የተፈጸመ ወንጀል ሊሆን ይችላል»"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> አምነስቲ፤ «በአክሱም በኤርትራ ወታደሮች የተፈጸመው የጅምላ ግድያ በሰብአዊ ፍጡር ላይ የተፈጸመ ወንጀል ሊሆን ይችላል» </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> Amharic </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/time-is-running-out-urgent-action-needed-to-address-humanitarian-crisis-in-tigray/" title="Time is Running Out: Urgent Action Needed to Address Humanitarian Crisis in Tigray"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Time is Running Out: Urgent Action Needed to Address Humanitarian Crisis in Tigray </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> World </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/qaallittii_update-free-all-oromo-political-prisoners/" title="#Qaallittii_Update! Free all Oromo Political prisoners!"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> #Qaallittii_Update! Free all Oromo Political prisoners! </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/odeessa-qeerroo-intelligence-group/" title="Odeessa! Qeerroo Intelligence Group!"> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Odeessa! Qeerroo Intelligence Group! </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> World </span> </a></li><li class="mh-ticker-item mh-ticker-item-bottom"> <a href="https://kichuu.com/waatu-waatu-jira/" title="Waatu waatu jira."> <span class="mh-ticker-item-date mh-ticker-item-date-bottom"> [ February 26, 2021 ] </span> <span class="mh-ticker-item-title mh-ticker-item-title-bottom"> Waatu waatu jira. </span> <span class="mh-ticker-item-cat mh-ticker-item-cat-bottom"> <i class="fa fa-caret-right"></i> News </span> </a></li></ul></div></div></div></div><div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix"><aside class="mh-header-search mh-header-search-bottom"><form role="search" method="get" class="search-form" action="https://kichuu.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></aside></div></div></div><div class="mh-wrapper clearfix"><div class="mh-main clearfix"><div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/news/">News</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com/category/news/world/" itemprop="item"><span itemprop="name">World</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>International media are urged to respect Ethiopian laws</nav><article id="post-89043" class="post-89043 post type-post status-publish format-standard has-post-thumbnail hentry category-world"><header class="entry-header clearfix"><h1 class="entry-title">International media are urged to respect Ethiopian laws</h1><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></header><div id="custom_html-15" class="widget_text mh-widget mh-posts-1 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="4616959710"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div class="entry-content clearfix"><div class="mh-social-top"><div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&t=International+media+are+urged+to+respect+Ethiopian+laws', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=International+media+are+urged+to+respect+Ethiopian+laws:&url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&media=https://kichuu.com/wp-content/uploads/2021/02/155058826_2563429420623650_412584770833637003_n-e1614352917321.jpg&description=International+media+are+urged+to+respect+Ethiopian+laws', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-email" href="mailto:?subject=International%20media%20are%20urged%20to%20respect%20Ethiopian%20laws&amp;body=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div><div class="kvgmc6g5 cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><h2 dir="auto"><strong>International media are urged to respect Ethiopian laws</strong></h2><div dir="auto">Ethiopia Broadcasting Authority (EBA) on Friday urged the international media to respect the country&#8217;s laws and report accurately and truthfully on the situation in the regional state of Tigray.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">All professionals from radio stations, agencies, television stations or other media accredited Addis Ababa should be governed by the Constitution, criminal laws and humanitarian provisions established in our territory, the EBA stated. If journalists breach the rules or violate any of the regulations, the Authority will be forced to take corrective measures to guarantee the nation’s stability, peace, sovereignty and security, its Deputy Director-General Wondwosen Andualem told a local media.</div><div dir="auto"> </div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">This statement was released two days after the Ethiopian Government challenged before the United Nations an article in the Luzerner Zeitung, a Swiss German-language daily newspaper, for ‘issuing unfounded information’ about what happened in the Tigray region in recent months.</div></div><div class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q"><div dir="auto">Since November 2020, international media began to fabricate false stories and exaggerated reports about the conflict, with which they expressed their political prejudices and violated the country’s Broadcasting Proclamation, according to several government complaints released in the last few weeks</div><div dir="auto"><img loading="lazy" class="alignnone size-full wp-image-89044" src="https://kichuu.com/wp-content/uploads/2021/02/155058826_2563429420623650_412584770833637003_n-e1614352917321.jpg" alt="" width="700" height="373" /></div></div><div class="mh-social-bottom"><div class="mh-share-buttons clearfix"> <a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&t=International+media+are+urged+to+respect+Ethiopian+laws', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"> <span class="mh-share-button"><i class="fa fa-facebook"></i></span> </a> <a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=International+media+are+urged+to+respect+Ethiopian+laws:&url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"> <span class="mh-share-button"><i class="fa fa-twitter"></i></span> </a> <a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn"> <span class="mh-share-button"><i class="fa fa-linkedin"></i></span> </a> <a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F&media=https://kichuu.com/wp-content/uploads/2021/02/155058826_2563429420623650_412584770833637003_n-e1614352917321.jpg&description=International+media+are+urged+to+respect+Ethiopian+laws', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"> <span class="mh-share-button"><i class="fa fa-pinterest"></i></span> </a> <a class="mh-email" href="mailto:?subject=International%20media%20are%20urged%20to%20respect%20Ethiopian%20laws&amp;body=https%3A%2F%2Fkichuu.com%2Finternational-media-are-urged-to-respect-ethiopian-laws%2F" title="Send this article to a friend" target="_blank"> <span class="mh-share-button"><i class="fa fa-envelope-o"></i></span> </a> <a class="mh-print" href="javascript:window.print()" title="Print this article"> <span class="mh-share-button"><i class="fa fa-print"></i></span> </a></div></div></div><div id="custom_html-16" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="4120112176"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev"> <a href="https://kichuu.com/maalitti-jiru/" rel="prev"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Maalitti jiru" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Maalitti jiru?</p></a></div></nav><div id="comments" class="mh-comments-wrap"><h4 class="mh-widget-title mh-comment-form-title"> <span class="mh-widget-title-inner"> Be the first to comment </span></h4><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/international-media-are-urged-to-respect-ethiopian-laws/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p><p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='89043' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d87f4e6713" /></p><input type="hidden" id="ak_js" name="ak_js" value="145"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3980511370"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89040 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/maalitti-jiru/" title="Maalitti jiru?"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Maalitti jiru" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/154916688_2621616534803905_7089104986779589189_o-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/maalitti-jiru/" title="Maalitti jiru?"> Maalitti jiru? </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89037 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/no-justice-in-ethiopia-gaaffii-tauu-baatus-yaadumatti-akka-qabannuufi/" title="No Justice In Ethiopia: Gaaffii ta’uu baatus yaadumatti akka qabannuufi"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/153559074_4179119752101021_8314831838462149527_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/153559074_4179119752101021_8314831838462149527_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/153559074_4179119752101021_8314831838462149527_n-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/no-justice-in-ethiopia-gaaffii-tauu-baatus-yaadumatti-akka-qabannuufi/" title="No Justice In Ethiopia: Gaaffii ta’uu baatus yaadumatti akka qabannuufi"> No Justice In Ethiopia: Gaaffii ta’uu baatus yaadumatti akka qabannuufi </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89030 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/no-justice-no-feast-how-hunger-strikers-are-keeping-the-protest-over-oromos-un-just-treatment-in-ethiopia-by-abiy-ahmes-government/" title="No justice, no feast: How hunger strikers are keeping the protest over Oromo&#8217;s un just treatment in Ethiopia by Abiy Ahme&#8217;s Government."><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/154367870_10158035221397469_6048788476917490701_o-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Oromo" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/154367870_10158035221397469_6048788476917490701_o-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/154367870_10158035221397469_6048788476917490701_o-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/154367870_10158035221397469_6048788476917490701_o-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/no-justice-no-feast-how-hunger-strikers-are-keeping-the-protest-over-oromos-un-just-treatment-in-ethiopia-by-abiy-ahmes-government/" title="No justice, no feast: How hunger strikers are keeping the protest over Oromo&#8217;s un just treatment in Ethiopia by Abiy Ahme&#8217;s Government."> No justice, no feast: How hunger strikers are keeping the protest over Oromo&#8217;s un just treatment in Ethiopia by Abiy Ahme&#8217;s Government. </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89025 post type-post status-publish format-standard has-post-thumbnail category-amharic"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%8d%8a%e1%8a%95%e1%8d%8a%e1%8a%94-%e1%88%b8%e1%8c%88%e1%88%ad-%e1%8a%a0%e1%8b%b2%e1%88%b5-%e1%8a%a0%e1%89%a0%e1%89%a3-%e1%8a%a8-1973-2017/" title="ፊንፊኔ/ሸገር/አዲስ አበባ ከ 1973 -2017"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-300x225.jpg 300w, https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-e1614345943637.jpg 700w, https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/pizap-34-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/%e1%8d%8a%e1%8a%95%e1%8d%8a%e1%8a%94-%e1%88%b8%e1%8c%88%e1%88%ad-%e1%8a%a0%e1%8b%b2%e1%88%b5-%e1%8a%a0%e1%89%a0%e1%89%a3-%e1%8a%a8-1973-2017/" title="ፊንፊኔ/ሸገር/አዲስ አበባ ከ 1973 -2017"> ፊንፊኔ/ሸገር/አዲስ አበባ ከ 1973 -2017 </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89022 post type-post status-publish format-standard has-post-thumbnail category-amharic"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%8a%a0%e1%88%9d%e1%8a%90%e1%88%b5%e1%89%b2%e1%8d%a4-%e1%89%a0%e1%8a%a0%e1%8a%ad%e1%88%b1%e1%88%9d-%e1%89%a0%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%8b%88%e1%89%b3%e1%8b%b0%e1%88%ae%e1%89%bd/" title="አምነስቲ፤ «በአክሱም በኤርትራ ወታደሮች የተፈጸመው የጅምላ ግድያ በሰብአዊ ፍጡር ላይ የተፈጸመ ወንጀል ሊሆን ይችላል»"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/154402568_4199528233413574_82895829206161632_o-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="በአክሱም" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/154402568_4199528233413574_82895829206161632_o-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/154402568_4199528233413574_82895829206161632_o-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/%e1%8a%a0%e1%88%9d%e1%8a%90%e1%88%b5%e1%89%b2%e1%8d%a4-%e1%89%a0%e1%8a%a0%e1%8a%ad%e1%88%b1%e1%88%9d-%e1%89%a0%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%8b%88%e1%89%b3%e1%8b%b0%e1%88%ae%e1%89%bd/" title="አምነስቲ፤ «በአክሱም በኤርትራ ወታደሮች የተፈጸመው የጅምላ ግድያ በሰብአዊ ፍጡር ላይ የተፈጸመ ወንጀል ሊሆን ይችላል»"> አምነስቲ፤ «በአክሱም በኤርትራ ወታደሮች የተፈጸመው የጅምላ ግድያ በሰብአዊ ፍጡር ላይ የተፈጸመ ወንጀል ሊሆን ይችላል» </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89017 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/time-is-running-out-urgent-action-needed-to-address-humanitarian-crisis-in-tigray/" title="Time is Running Out: Urgent Action Needed to Address Humanitarian Crisis in Tigray"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-73-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Crisis in Tigray" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-73-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-73-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/time-is-running-out-urgent-action-needed-to-address-humanitarian-crisis-in-tigray/" title="Time is Running Out: Urgent Action Needed to Address Humanitarian Crisis in Tigray"> Time is Running Out: Urgent Action Needed to Address Humanitarian Crisis in Tigray </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89007 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/qaallittii_update-free-all-oromo-political-prisoners/" title="#Qaallittii_Update! Free all Oromo Political prisoners!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/153981171_10215082514975629_7370752817820330942_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Oromo Political prisoners!" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/153981171_10215082514975629_7370752817820330942_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/153981171_10215082514975629_7370752817820330942_n-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/153981171_10215082514975629_7370752817820330942_n-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/qaallittii_update-free-all-oromo-political-prisoners/" title="#Qaallittii_Update! Free all Oromo Political prisoners!"> #Qaallittii_Update! Free all Oromo Political prisoners! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-89001 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/odeessa-qeerroo-intelligence-group/" title="Odeessa! Qeerroo Intelligence Group!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/155222354_2621366628162229_2706663809277123671_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Qeerroo" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/155222354_2621366628162229_2706663809277123671_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/155222354_2621366628162229_2706663809277123671_n-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/odeessa-qeerroo-intelligence-group/" title="Odeessa! Qeerroo Intelligence Group!"> Odeessa! Qeerroo Intelligence Group! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88997 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/waatu-waatu-jira/" title="Waatu waatu jira."><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/pizap-33-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/pizap-33-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/pizap-33-300x225.jpg 300w, https://kichuu.com/wp-content/uploads/2021/02/pizap-33-e1614337225472.jpg 700w, https://kichuu.com/wp-content/uploads/2021/02/pizap-33-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2021/02/pizap-33-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/pizap-33-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/waatu-waatu-jira/" title="Waatu waatu jira."> Waatu waatu jira. </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88991 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/us-restoration-of-foreign-aid-to-ethiopia-signals-new-course/" title="US Restoration of Foreign Aid to Ethiopia Signals New Course "><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-72-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-72-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-72-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/us-restoration-of-foreign-aid-to-ethiopia-signals-new-course/" title="US Restoration of Foreign Aid to Ethiopia Signals New Course "> US Restoration of Foreign Aid to Ethiopia Signals New Course  </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88988 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/biden-discusses-crisis-in-ethiopias-tigray-region-with-kenyan-leader-white-house/" title="Biden Discusses Crisis in Ethiopia&#8217;s Tigray Region With Kenyan Leader: White House"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-70-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Tigray Region" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-70-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-70-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/biden-discusses-crisis-in-ethiopias-tigray-region-with-kenyan-leader-white-house/" title="Biden Discusses Crisis in Ethiopia&#8217;s Tigray Region With Kenyan Leader: White House"> Biden Discusses Crisis in Ethiopia&#8217;s Tigray Region With Kenyan Leader: White House </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88984 post type-post status-publish format-standard has-post-thumbnail category-africa"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/massacre-by-eritrean-troops-in-ethiopias-tigray-region-may-constitute-crime-against-humanity-amnesty-says/" title="Massacre by Eritrean troops in Ethiopia’s Tigray region may constitute crime against humanity, Amnesty says"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-69-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Eritrean troops" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-69-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-69-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/massacre-by-eritrean-troops-in-ethiopias-tigray-region-may-constitute-crime-against-humanity-amnesty-says/" title="Massacre by Eritrean troops in Ethiopia’s Tigray region may constitute crime against humanity, Amnesty says"> Massacre by Eritrean troops in Ethiopia’s Tigray region may constitute crime against humanity, Amnesty says </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88980 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-eritrean-troops-massacre-of-hundreds-of-axum-civilians-may-amount-to-crime-against-humanity/" title="Ethiopia: Eritrean troops’ massacre of hundreds of Axum civilians may amount to crime against humanity"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/axum-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/axum-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/axum-326x240.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/ethiopia-eritrean-troops-massacre-of-hundreds-of-axum-civilians-may-amount-to-crime-against-humanity/" title="Ethiopia: Eritrean troops’ massacre of hundreds of Axum civilians may amount to crime against humanity"> Ethiopia: Eritrean troops’ massacre of hundreds of Axum civilians may amount to crime against humanity </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 26, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88976 post type-post status-publish format-standard has-post-thumbnail category-amharic"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%8b%a8%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%b5%e1%89%b5-%e1%8a%a8%e1%8d%8d%e1%89%b0%e1%8a%9b-%e1%89%a3%e1%88%88%e1%88%b5%e1%88%8d%e1%8c%a3%e1%8a%93%e1%89%b5-%e1%89%a0%e1%88%98%e1%89%b0%e1%8a%a8/" title="የመንግስት ከፍተኛ ባለስልጣናት በመተከልና ትግራይ ክልል ለሚገኙ ዜጎች ድጋፍ አደረጉ"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/153823567_1336331873407248_7881884615952439142_o-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="የመንግስት" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/153823567_1336331873407248_7881884615952439142_o-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/153823567_1336331873407248_7881884615952439142_o-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/153823567_1336331873407248_7881884615952439142_o-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/%e1%8b%a8%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%b5%e1%89%b5-%e1%8a%a8%e1%8d%8d%e1%89%b0%e1%8a%9b-%e1%89%a3%e1%88%88%e1%88%b5%e1%88%8d%e1%8c%a3%e1%8a%93%e1%89%b5-%e1%89%a0%e1%88%98%e1%89%b0%e1%8a%a8/" title="የመንግስት ከፍተኛ ባለስልጣናት በመተከልና ትግራይ ክልል ለሚገኙ ዜጎች ድጋፍ አደረጉ"> የመንግስት ከፍተኛ ባለስልጣናት በመተከልና ትግራይ ክልል ለሚገኙ ዜጎች ድጋፍ አደረጉ </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 25, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88973 post type-post status-publish format-standard has-post-thumbnail category-world"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/statement-by-the-united-states-on-the-human-rights-situation-in-eritrea/" title="Statement by the United States on the Human Rights Situation in Eritrea"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/StatementatHumanRightsCouncil-1140x684-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Eritrea" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/StatementatHumanRightsCouncil-1140x684-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/StatementatHumanRightsCouncil-1140x684-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/02/StatementatHumanRightsCouncil-1140x684-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/statement-by-the-united-states-on-the-human-rights-situation-in-eritrea/" title="Statement by the United States on the Human Rights Situation in Eritrea"> Statement by the United States on the Human Rights Situation in Eritrea </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 25, 2021</a></span></div></div></li></ul></div></aside></div></div><footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter"><div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix"><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1"><div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86091 post type-post status-publish format-standard has-post-thumbnail category-health"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/warri-qabdan-naaf-hiixadhaa-warri-hin-qabne-waaqa-naaf-kadhadhaa/" title="Warri qabdan naaf hiixadhaa, warri hin qabne Waaqa naaf kadhadhaa"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/pizap-55-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Warri qabdan" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/pizap-55-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/01/pizap-55-e1610138038655.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/warri-qabdan-naaf-hiixadhaa-warri-hin-qabne-waaqa-naaf-kadhadhaa/" title="Warri qabdan naaf hiixadhaa, warri hin qabne Waaqa naaf kadhadhaa"> Warri qabdan naaf hiixadhaa, warri hin qabne Waaqa naaf kadhadhaa </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 8, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86075 post type-post status-publish format-standard has-post-thumbnail category-health"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/a-second-chinese-coronavirus-vaccine-is-said-to-be-effective/" title="A Second Chinese Coronavirus Vaccine Is Said to Be Effective"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/merlin_181581558_4e30eb30-5140-4a7f-8e46-f1a87230e00e-jumbo-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/a-second-chinese-coronavirus-vaccine-is-said-to-be-effective/" title="A Second Chinese Coronavirus Vaccine Is Said to Be Effective"> A Second Chinese Coronavirus Vaccine Is Said to Be Effective </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 7, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86072 post type-post status-publish format-standard has-post-thumbnail category-health"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/kenya-says-1st-astrazeneca-vaccine-doses-to-come-next-month/" title="Kenya says 1st AstraZeneca vaccine doses to come next month"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/800-1-80x60.jpeg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="AstraZeneca" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/800-1-80x60.jpeg 80w, https://kichuu.com/wp-content/uploads/2021/01/800-1-678x509.jpeg 678w, https://kichuu.com/wp-content/uploads/2021/01/800-1-326x245.jpeg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/kenya-says-1st-astrazeneca-vaccine-doses-to-come-next-month/" title="Kenya says 1st AstraZeneca vaccine doses to come next month"> Kenya says 1st AstraZeneca vaccine doses to come next month </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 7, 2021</a></span></div></div></li></ul></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2"><div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86239 post type-post status-publish format-standard has-post-thumbnail category-fun-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/gaafa-tokko-harreetu-waraabessaf-tola-olltefi-turte-kana-harreen/" title="Gaafa Tokko harreetu Waraabessaf Tola olltefi turte kana Harreen .."><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/pizap-70-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Harreen" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/pizap-70-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/01/pizap-70-e1610278501681.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/gaafa-tokko-harreetu-waraabessaf-tola-olltefi-turte-kana-harreen/" title="Gaafa Tokko harreetu Waraabessaf Tola olltefi turte kana Harreen .."> Gaafa Tokko harreetu Waraabessaf Tola olltefi turte kana Harreen .. </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 10, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-75646 post type-post status-publish format-standard has-post-thumbnail category-fun-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/isaias-isaiah-to-hit-america/" title="Isaias (Isaiah) to Hit America!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Isaias" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/isaias-isaiah-to-hit-america/" title="Isaias (Isaiah) to Hit America!"> Isaias (Isaiah) to Hit America! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 1, 2020</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Mohammed Hajjii" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"> Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span></div></div></li></ul></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3"><div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86978 post type-post status-publish format-standard has-post-thumbnail category-musics"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/nagugubee-waaeen-kee-haacaaluu-hundeessaa-new-oromo-music/" title="Nagugubee Waa&#8217;een Kee Haacaaluu Hundeessaa New Oromo music"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/pizap-12-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Haacaaluu Hundeessaa" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/pizap-12-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2021/01/pizap-12-e1611609594455.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/nagugubee-waaeen-kee-haacaaluu-hundeessaa-new-oromo-music/" title="Nagugubee Waa&#8217;een Kee Haacaaluu Hundeessaa New Oromo music"> Nagugubee Waa&#8217;een Kee Haacaaluu Hundeessaa New Oromo music </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 25, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-86140 post type-post status-publish format-standard has-post-thumbnail category-musics"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ali-birra-and-abreham-belayneh-%e1%8a%a0%e1%88%8a-%e1%89%a2%e1%88%ab-%e1%8a%a5%e1%8a%93-%e1%8a%a0%e1%89%a5%e1%88%ad%e1%88%83%e1%88%9d-%e1%89%a0%e1%88%8b%e1%8b%ad%e1%8a%90%e1%88%85-%e1%8b%b3%e1%88%ad/" title="Ali Birra and Abreham Belayneh አሊ ቢራ እና አብርሃም በላይነህ (ዳርም የለው)"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/01/Untitled-8-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ali Birra" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/01/Untitled-8-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/01/Untitled-8-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/ali-birra-and-abreham-belayneh-%e1%8a%a0%e1%88%8a-%e1%89%a2%e1%88%ab-%e1%8a%a5%e1%8a%93-%e1%8a%a0%e1%89%a5%e1%88%ad%e1%88%83%e1%88%9d-%e1%89%a0%e1%88%8b%e1%8b%ad%e1%8a%90%e1%88%85-%e1%8b%b3%e1%88%ad/" title="Ali Birra and Abreham Belayneh አሊ ቢራ እና አብርሃም በላይነህ (ዳርም የለው)"> Ali Birra and Abreham Belayneh አሊ ቢራ እና አብርሃም በላይነህ (ዳርም የለው) </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/01/">January 9, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-85277 post type-post status-publish format-standard has-post-thumbnail category-musics"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/tafarii-salaalee-jettee-ree-new-oromo-music-2020/" title="Tafarii Salaalee- Jettee ree! New Oromo Music 2020!"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="New Oromo Music" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/12/pizap-15-2-e1608584630216.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/tafarii-salaalee-jettee-ree-new-oromo-music-2020/" title="Tafarii Salaalee- Jettee ree! New Oromo Music 2020!"> Tafarii Salaalee- Jettee ree! New Oromo Music 2020! </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/12/">December 21, 2020</a></span></div></div></li></ul></div></div><div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4"><div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6><ul class="mh-custom-posts-widget clearfix"><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88863 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/imf-ethiopia-agree-framework-for-loan-deal-reviews/" title="IMF, Ethiopia agree framework for loan deal reviews"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-65-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="IMF," loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-65-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-65-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/imf-ethiopia-agree-framework-for-loan-deal-reviews/" title="IMF, Ethiopia agree framework for loan deal reviews"> IMF, Ethiopia agree framework for loan deal reviews </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 24, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88421 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/world-bank-questions-ethiopias-stance-in-telecoms-competition/" title="World Bank questions Ethiopia’s stance in telecoms competition"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/ousmane-dione-world-bankjpg_51089-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="World Bank" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/ousmane-dione-world-bankjpg_51089-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2021/02/ousmane-dione-world-bankjpg_51089-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/world-bank-questions-ethiopias-stance-in-telecoms-competition/" title="World Bank questions Ethiopia’s stance in telecoms competition"> World Bank questions Ethiopia’s stance in telecoms competition </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 17, 2021</a></span></div></div></li><li class="mh-custom-posts-item mh-custom-posts-small clearfix post-88247 post type-post status-publish format-standard has-post-thumbnail category-business"><figure class="mh-custom-posts-thumb"> <a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/sp-joins-fitch-in-downgrade-of-ethiopia-on-potential-debt-restructuring/" title="S&#038;P joins Fitch in downgrade of Ethiopia on potential debt restructuring"><img width="80" height="60" src="https://kichuu.com/wp-content/uploads/2021/02/Untitled-39-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Ethiopia" loading="lazy" srcset="https://kichuu.com/wp-content/uploads/2021/02/Untitled-39-80x60.png 80w, https://kichuu.com/wp-content/uploads/2021/02/Untitled-39-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" /> </a></figure><div class="mh-custom-posts-header"><div class="mh-custom-posts-small-title"> <a href="https://kichuu.com/sp-joins-fitch-in-downgrade-of-ethiopia-on-potential-debt-restructuring/" title="S&#038;P joins Fitch in downgrade of Ethiopia on potential debt restructuring"> S&#038;P joins Fitch in downgrade of Ethiopia on potential debt restructuring </a></div><div class="mh-meta entry-meta"> <span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2021/02/">February 13, 2021</a></span></div></div></li></ul></div></div></div></footer><div class="mh-footer-nav-mobile"></div><nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="mh-container mh-container-inner clearfix"><div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li></ul></div></div></nav><div class="mh-copyright-wrap"><div class="mh-container mh-container-inner clearfix"><p class="mh-copyright"> Copyright @2016 kichuu.com</p></div></div> <a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a></div><div id="fb-root"></div> <script>(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://kichuu.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/i18n.min.js?ver=ac389435e7fd4ded01cf603f3aaba6a6' id='wp-i18n-js'></script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' id='lodash-js'></script> <script type='text/javascript' id='lodash-js-after'>window.lodash = _.noConflict();</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/url.min.js?ver=98645f0502e5ed8dadffd161e39072d2' id='wp-url-js'></script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/hooks.min.js?ver=84b89ab09cbfb4469f02183611cc0939' id='wp-hooks-js'></script> <script type='text/javascript' id='wp-api-fetch-js-translations'>( function( domain, translations ) {
var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
localeData[""].domain = domain;
wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://kichuu.com/wp-includes/js/dist/api-fetch.min.js?ver=4dec825c071b87c57f687eb90f7c23c3' id='wp-api-fetch-js'></script> <script type='text/javascript' id='wp-api-fetch-js-after'>wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://kichuu.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "1791d0bfe8" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://kichuu.com/wp-admin/admin-ajax.php?action=rest-nonce";</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = [];</script> <script defer type='text/javascript' src='https://kichuu.com/wp-content/cache/autoptimize/js/autoptimize_single_2fdf3cc1d0fcf824759f5287d4bd7b74.js?ver=5.4' id='contact-form-7-js'></script> <script defer type='text/javascript' src='https://kichuu.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script> <script defer type='text/javascript' src='https://kichuu.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script> <script defer="async" type='text/javascript' src='https://kichuu.com/wp-content/cache/autoptimize/js/autoptimize_single_270f0cd7341bce6c2afacf2682e7690e.js?ver=4.1.8' id='akismet-form-js'></script> </body></html><!-- WP Fastest Cache file was created in 0.48711109161377 seconds, on 26-02-21 10:23:10 --><!-- via php -->