<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Ethiopia’s election delay could be good news Kichuu</title>
<!-- This site is optimized with the Yoast SEO plugin v13.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Ethiopia’s election delay could be good news.He has overseen rapid change in Africa’s second most-populous country, including"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://kichuu.com/ethiopias-election-delay-could-be-good-news/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ethiopia’s election delay could be good news Kichuu" />
<meta property="og:description" content="Ethiopia’s election delay could be good news.He has overseen rapid change in Africa’s second most-populous country, including" />
<meta property="og:url" content="https://kichuu.com/ethiopias-election-delay-could-be-good-news/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:publisher" content="https://www.facebook.com/kichuu.info/" />
<meta property="article:section" content="Africa" />
<meta property="article:published_time" content="2020-04-06T17:54:44+00:00" />
<meta property="og:image" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?fit=700%2C350&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?fit=700%2C350&#038;ssl=1" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="350" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507","name":"fmegersa","logo":{"@id":"https://kichuu.com/#personlogo"},"sameAs":[]},{"@type":"WebSite","@id":"https://kichuu.com/#website","url":"https://kichuu.com/","name":"Kichuu","inLanguage":"en-US","publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"potentialAction":[{"@type":"SearchAction","target":"https://kichuu.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?fit=700%2C350&ssl=1","width":700,"height":350,"caption":"Election delay"},{"@type":"WebPage","@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#webpage","url":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/","name":"Ethiopia\u2019s election delay could be good news Kichuu","isPartOf":{"@id":"https://kichuu.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#primaryimage"},"datePublished":"2020-04-06T17:54:44+00:00","dateModified":"2020-04-06T17:54:44+00:00","description":"Ethiopia\u2019s election delay could be good news.He has overseen rapid change in Africa\u2019s second most-populous country, including","potentialAction":[{"@type":"ReadAction","target":["https://kichuu.com/ethiopias-election-delay-could-be-good-news/"]}]},{"@type":"Article","@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#article","isPartOf":{"@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#webpage"},"author":{"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330"},"headline":"Ethiopia\u2019s election delay could be good news","datePublished":"2020-04-06T17:54:44+00:00","dateModified":"2020-04-06T17:54:44+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#webpage"},"publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"image":{"@id":"https://kichuu.com/ethiopias-election-delay-could-be-good-news/#primaryimage"},"articleSection":"Africa","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://kichuu.com/ethiopias-election-delay-could-be-good-news/#respond"]}]},{"@type":["Person"],"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330","name":"kichuu_admin","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Ethiopia’s election delay could be good news Comments Feed" href="https://kichuu.com/ethiopias-election-delay-could-be-good-news/feed/" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='h5ap-style-css'  href='https://kichuu.com/wp-content/plugins/html5-audio-player/style/player-style.css?ver=3.5.10' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/style.css?ver=3.8.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/7uwjxxhq/3xmuw.css" media="all"/>
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/html5-audio-player/js/plyr.js?ver=3.5.10'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.6'></script>
<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4" />
<link rel='shortlink' href='https://kichuu.com/?p=68472' />
<link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&#038;format=xml" />
<script>
document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
</script>
<style>
.no-js img.lazyload { display: none; }
figure.wp-block-image img.lazyloading { min-width: 150px; }
.lazyload, .lazyloading { opacity: 0; }
.lazyloaded {
opacity: 1;
transition: opacity 400ms;
transition-delay: 0ms;
}
</style>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>
<link rel="icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=270%2C270&#038;ssl=1" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-68472 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-top">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kichuu" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?w=331&amp;ssl=1 331w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=300%2C73&amp;ssl=1 300w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=326%2C81&amp;ssl=1 326w" data-lazy-sizes="(max-width: 331px) 100vw, 331px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ads20171214 -->
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3403389782"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
News Ticker<i class="fa fa-chevron-right"></i>		</div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/theology-of-crisis-theological-response-to-the-covid-19-and-human-rights-violations-in-oromia-ethiopia-part-one/" title="Theology of Crisis: Theological Response to the COVID-19 and Human Rights Violations in Oromia/Ethiopia &#8211; Part One">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Theology of Crisis: Theological Response to the COVID-19 and Human Rights Violations in Oromia/Ethiopia &#8211; Part One						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/coronavirus-boris-johnson-moved-to-intensive-care-as-symptoms-worsen/" title="Coronavirus: Boris Johnson moved to intensive care as symptoms &#8216;worsen&#8217;">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Coronavirus: Boris Johnson moved to intensive care as symptoms &#8216;worsen&#8217;						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/goal-to-adopt-pioneering-community-engagement-approach-to-help-fight-spread-of-covid-19/" title="GOAL to adopt pioneering community engagement approach to help fight spread of COVID-19">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
GOAL to adopt pioneering community engagement approach to help fight spread of COVID-19						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/ethiopia-pardons-additional-12500-prisoners/" title="Ethiopia pardons additional 12,500 prisoners">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Ethiopia pardons additional 12,500 prisoners						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/ethiopian-government-progresses-with-telecom-liberalisation/" title="Ethiopian government progresses with telecom liberalisation">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Ethiopian government progresses with telecom liberalisation						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/oromoon-yeroo-waan-hamaa-fi-hammaatan-biyya-mudatu/" title="Oromoon Yeroo waan hamaa fi hammaatan Biyya mudatu.">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Oromoon Yeroo waan hamaa fi hammaatan Biyya mudatu.						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/why-a-covid-19-pandemic-test-center-must-be-opened-at-moyale-town/" title="&#8220;Why a COVID-19 pandemic TEST CENTER must be opened at Moyale Town?">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
&#8220;Why a COVID-19 pandemic TEST CENTER must be opened at Moyale Town?						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/saudi-arabian-airlines-is-still-flying-to-addis-ababa-and-it-has-brought-more-than-1600-ethiopian-deportees-in-one-week/" title="“Saudi Arabian Airlines is still flying to Addis Ababa and it has brought more than 1,600 Ethiopian deportees in one week.”">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
“Saudi Arabian Airlines is still flying to Addis Ababa and it has brought more than 1,600 Ethiopian deportees in one week.”						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Videos							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/ethiopias-election-delay-could-be-good-news/" title="Ethiopia’s election delay could be good news">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Ethiopia’s election delay could be good news						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/indonesia-ranks-among-worlds-worst-in-coronavirus-testing-rate-together-with-ethiopia-bangladesh/" title="Indonesia ranks among world&#8217;s worst in coronavirus testing rate, together with Ethiopia, Bangladesh">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ April 6, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Indonesia ranks among world&#8217;s worst in coronavirus testing rate, together with Ethiopia, Bangladesh						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>		</ul>
</div>
</div>						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/news/">News</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com/category/news/africa/" itemprop="url"><span itemprop="title">Africa</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Ethiopia’s election delay could be good news</nav>
<article id="post-68472" class="post-68472 post type-post status-publish format-standard has-post-thumbnail hentry category-africa">
<header class="entry-header clearfix"><h1 class="entry-title">Ethiopia’s election delay could be good news</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</header>
<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&t=Ethiopia%E2%80%99s+election+delay+could+be+good+news', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Ethiopia%E2%80%99s+election+delay+could+be+good+news:&url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&media=https://kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg&description=Ethiopia%E2%80%99s+election+delay+could+be+good+news', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=Ethiopia%E2%80%99s%20election%20delay%20could%20be%20good%20news&amp;body=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
<p><strong>Ethiopia’s election delay could be good news</strong></p>
<figure id="attachment_68473" aria-describedby="caption-attachment-68473" style="width: 650px" class="wp-caption alignnone"><img class="wp-image-68473 size-large jetpack-lazy-image" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1.jpg?resize=650%2C325&#038;ssl=1" alt width="650" height="325" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?resize=650%2C325&amp;ssl=1 650w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?resize=250%2C125&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?resize=768%2C384&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?w=700&amp;ssl=1 700w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1.jpg?resize=650%2C325&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-68473 size-large" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1.jpg?resize=650%2C325&#038;ssl=1" alt="" width="650" height="325" srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?resize=650%2C325&amp;ssl=1 650w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?resize=250%2C125&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?resize=768%2C384&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg?w=700&amp;ssl=1 700w" sizes="(max-width: 650px) 100vw, 650px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-68473" class="wp-caption-text">Addis Ababa, Ethiopia</figcaption></figure>
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- k20200225 -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3156329304"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong>(<a href="https://www.howwemadeitinafrica.com/ethiopias-election-delay-could-be-good-news/64538/">howwemadeitinafrica</a>)&#8212;Ethiopia’s electoral commission has announced that its scheduled August general election <a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=5b6131f754&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer">will be postponed</a>, due to the effects of the coronavirus crisis. The vote was due to test the reform agenda of prime minister Abiy Ahmed, in power since April 2018.</strong></p>
<p>He has overseen rapid change in Africa’s second most-populous country, including unprecedented opening of the political sphere and ambitious plans to <a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=e0b0e1b3fc&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer">liberalise its state-led economy</a>.</p>
<p>Free and fair polls would mark an unlikely, and rapid transition to democratic governance after decades of authoritarianism. They would also boost Ethiopia’s growth story, which has been criticised for relying on autocratic politics for impressive GDP figures – averaging 9.5% annually from 2009 – 2019.</p>
<p>The delay could be good news in this regard.</p>
<p>While Ahmed’s reforms have won him <a href="https://kichuu.com/qeerroofi-qarreen-oromoo-14-bakka-tokkotti-ajjeefamuu/">global recognition</a> – including a Nobel peace prize – his fast and furious approach has also stirred simmering ethnic and political divisions.</p>
<p>Up to two million people have been internally displaced since 2018, amid calls for more autonomy from some regional ethnic groups, while Ahmed has survived at least one assassination attempt.</p>
<p>This has raised doubts about the government’s ability to maintain law and order, and concerns that a free and fair election in 2020 is simply <a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=d3e92b1c68&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer">too much, too soon</a>, for Ethiopia.</p>
<p>The delay – which has been backed by key opposition groups – offers much-needed time for authorities to prepare.</p>
<p>They must use it well.</p>
<p><strong>From the continent</strong></p>
<p>Ratings agencies Fitch and Moody’s have downgraded leading South African banks including Standard Bank and Nedbank to ‘junk’, following the latter’s removal of the country’s only remaining investment-grade rating last week. The move heaps further pressure on South Africa’s struggling economy, which fell into its second recession in as many years in the final quarter of 2019. More: <a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=45c36bbb24&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer">Reuters</a></p>
<p>Senegal is in discussions with the International Monetary Fund over a $221 million emergency disbursement to help counter the impact of the coronavirus pandemic. The country joins at least 20 others across Africa – many already struggling with high debt – to seek help from the lender since the start of the crisis. More:<a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=ebbbb7624a&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer"> IMF</a></p>
<p><strong>The global perspective</strong></p>
<p>The International Air Transport Association (IATA) has warned that airlines in Africa and the Middle East have lost $23 billion due to the coronavirus pandemic, calling for more government interventions to protect the industry. Commercial aviation, already struggling in Africa, has been especially hard hit by the pandemic. More: <a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=0a348a452d&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer">Reuters</a></p>
<p>German technology and startup investor Rocket Internet has sold its 11% stake in Africa-focused e-commerce firm Jumia. Once hailed as Africa’s first tech ‘unicorn’, the company has fallen from grace since listing on the New York Stock Exchange in April 2019, following allegations of poor governance. More: <a href="https://nurmara.us14.list-manage.com/track/click?u=3d6f0965be5b3a3dd5550fdbf&amp;id=bb339a9d19&amp;e=bdf581e983" target="_blank" rel="noopener noreferrer">CNA</a></p>
<hr />
<p><iframe  width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-src="https://www.youtube.com/embed/egruTdH5m8A" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&t=Ethiopia%E2%80%99s+election+delay+could+be+good+news', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Ethiopia%E2%80%99s+election+delay+could+be+good+news:&url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F&media=https://kichuu.com/wp-content/uploads/2020/04/Addis-Ababa-800x400-1-scaled.jpg&description=Ethiopia%E2%80%99s+election+delay+could+be+good+news', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=Ethiopia%E2%80%99s%20election%20delay%20could%20be%20good%20news&amp;body=https%3A%2F%2Fkichuu.com%2Fethiopias-election-delay-could-be-good-news%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
</div><div id="custom_html-7" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20190303 -->
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="3737122119"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/indonesia-ranks-among-worlds-worst-in-coronavirus-testing-rate-together-with-ethiopia-bangladesh/" rel="prev"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Indonesia" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/yq-indocovtest-006042020-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Previous</span><p>Indonesia ranks among world&#8217;s worst in coronavirus testing rate, together with Ethiopia, Bangladesh</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://kichuu.com/saudi-arabian-airlines-is-still-flying-to-addis-ababa-and-it-has-brought-more-than-1600-ethiopian-deportees-in-one-week/" rel="next"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Saudi Arabian Airlines" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?w=700&amp;ssl=1 700w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=250%2C187&amp;ssl=1 250w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=534%2C400&amp;ssl=1 534w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=768%2C575&amp;ssl=1 768w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-8-1-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Next</span><p>“Saudi Arabian Airlines is still flying to Addis Ababa and it has brought more than 1,600 Ethiopian deportees in one week.”</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ethiopias-election-delay-could-be-good-news/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='68472' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="17fd486144" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="139"/></p></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-68078 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely"><img width="326" height="206" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/close.jpg?resize=326%2C206&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Abiy Ahmed" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/close.jpg?resize=326%2C206&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">
Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 1, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely (Our Struggle is Significantly Bigger than the Restoration of Internet/Phones Access) By Worku Burayu (PhD), April 1, 2020 Summary: Oromoo Sabakoo: Our struggle is <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-67990 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-menelik.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Democracy" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-menelik.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-menelik.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-menelik.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!">
There were some false starts at democracy in Ethiopia – let us make it real this time round!											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 30, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">There were some false starts at democracy in Ethiopia – let us make it real this time round! By Taha Abdi, founder member of the OLF and former member of its executive committee February 20, <a class="mh-excerpt-more" href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-67929 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/abiy-ahmeds-two-years-imprudent-journey/" title="Abiy Ahmed’s Two Years Imprudent Journey"><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy2020.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Abiy" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy2020.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy2020.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy2020.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy2020.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/abiy-ahmeds-two-years-imprudent-journey/" title="Abiy Ahmed’s Two Years Imprudent Journey">
Abiy Ahmed’s Two Years Imprudent Journey											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 30, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Abiy Ahmed’s Two Years Imprudent Journey: &#8211; (From State of Emergency to Blockade of Information Until Spread of COVID-19) By Worku Burayu (PhD), March 30, 2020 Today many know, although too late, from Abiy’s two <a class="mh-excerpt-more" href="https://kichuu.com/abiy-ahmeds-two-years-imprudent-journey/" title="Abiy Ahmed’s Two Years Imprudent Journey">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-67342 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/the-oromo-people-faces-two-coronaviruses-covid-19-and-abiy-both-can-be-prevented-stopped-with-nationwide-stay-in-shelter-across-oromia-for-a-period-of-time/" title="The Oromo People faces two coronaviruses: COVID-19 and Abiy: Both can be prevented/stopped with nationwide stay-in-shelter across Oromia for a period of time!"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-1-scaled-e1584883893994.jpg?resize=300%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Abiy" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-1-scaled-e1584883893994.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-1-scaled-e1584883893994.jpg?zoom=3&amp;resize=326%2C245&amp;ssl=1 978w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/abiy-1-scaled-e1584883893994.jpg?resize=300%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/the-oromo-people-faces-two-coronaviruses-covid-19-and-abiy-both-can-be-prevented-stopped-with-nationwide-stay-in-shelter-across-oromia-for-a-period-of-time/" title="The Oromo People faces two coronaviruses: COVID-19 and Abiy: Both can be prevented/stopped with nationwide stay-in-shelter across Oromia for a period of time!">
The Oromo People faces two coronaviruses: COVID-19 and Abiy: Both can be prevented/stopped with nationwide stay-in-shelter across Oromia for a period of time!											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 22, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">The Oromo People faces two coronaviruses: COVID-19 and Abiy: Both can be prevented/stopped with nationwide stay-in-shelter across Oromia for a period of time! By Aba Orma, Ph.D., March 22, 2020 Two birds with a single stone! <a class="mh-excerpt-more" href="https://kichuu.com/the-oromo-people-faces-two-coronaviruses-covid-19-and-abiy-both-can-be-prevented-stopped-with-nationwide-stay-in-shelter-across-oromia-for-a-period-of-time/" title="The Oromo People faces two coronaviruses: COVID-19 and Abiy: Both can be prevented/stopped with nationwide stay-in-shelter across Oromia for a period of time!">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-64607 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation."><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Human Rights" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">
Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation. Click here for full content to download in PDF OMRHO  presents the state of Human Rights in Ethiopia <a class="mh-excerpt-more" href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-63213 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps"><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Autocrat" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">
Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 9, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps By Jabessa Gurmessa, Finfinne, Oromia, January 09, 2020 1. Introduction The freedom lovers and proponents <a class="mh-excerpt-more" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">[Read More]</a></div>								</div>
</div>
</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68509 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/theology-of-crisis-theological-response-to-the-covid-19-and-human-rights-violations-in-oromia-ethiopia-part-one/" title="Theology of Crisis: Theological Response to the COVID-19 and Human Rights Violations in Oromia/Ethiopia &#8211; Part One">
Theology of Crisis: Theological Response to the COVID-19 and Human Rights Violations in Oromia/Ethiopia &#8211; Part One									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68503 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/coronavirus-boris-johnson-moved-to-intensive-care-as-symptoms-worsen/" title="Coronavirus: Boris Johnson moved to intensive care as symptoms &#8216;worsen&#8217;">
Coronavirus: Boris Johnson moved to intensive care as symptoms &#8216;worsen&#8217;									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68497 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/goal-to-adopt-pioneering-community-engagement-approach-to-help-fight-spread-of-covid-19/" title="GOAL to adopt pioneering community engagement approach to help fight spread of COVID-19">
GOAL to adopt pioneering community engagement approach to help fight spread of COVID-19									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68492 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-pardons-additional-12500-prisoners/" title="Ethiopia pardons additional 12,500 prisoners">
Ethiopia pardons additional 12,500 prisoners									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68489 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopian-government-progresses-with-telecom-liberalisation/" title="Ethiopian government progresses with telecom liberalisation">
Ethiopian government progresses with telecom liberalisation									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68484 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/oromoon-yeroo-waan-hamaa-fi-hammaatan-biyya-mudatu/" title="Oromoon Yeroo waan hamaa fi hammaatan Biyya mudatu.">
Oromoon Yeroo waan hamaa fi hammaatan Biyya mudatu.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68478 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/why-a-covid-19-pandemic-test-center-must-be-opened-at-moyale-town/" title="&#8220;Why a COVID-19 pandemic TEST CENTER must be opened at Moyale Town?">
&#8220;Why a COVID-19 pandemic TEST CENTER must be opened at Moyale Town?									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68475 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/saudi-arabian-airlines-is-still-flying-to-addis-ababa-and-it-has-brought-more-than-1600-ethiopian-deportees-in-one-week/" title="“Saudi Arabian Airlines is still flying to Addis Ababa and it has brought more than 1,600 Ethiopian deportees in one week.”">
“Saudi Arabian Airlines is still flying to Addis Ababa and it has brought more than 1,600 Ethiopian deportees in one week.”									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68472 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopias-election-delay-could-be-good-news/" title="Ethiopia’s election delay could be good news">
Ethiopia’s election delay could be good news									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68469 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/indonesia-ranks-among-worlds-worst-in-coronavirus-testing-rate-together-with-ethiopia-bangladesh/" title="Indonesia ranks among world&#8217;s worst in coronavirus testing rate, together with Ethiopia, Bangladesh">
Indonesia ranks among world&#8217;s worst in coronavirus testing rate, together with Ethiopia, Bangladesh									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68466 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/africas-largest-airline-is-starting-to-furlough-workers-as-the-global-travel-downturn-bites/" title="Africa’s largest airline is starting to furlough workers as the global travel downturn bites">
Africa’s largest airline is starting to furlough workers as the global travel downturn bites									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68463 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-reports-first-two-deaths-from-coronavirus/" title="Ethiopia reports first two deaths from coronavirus">
Ethiopia reports first two deaths from coronavirus									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68460 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/china-thought-it-had-beaten-coronavirus-but-new-and-asymptomatic-cases-are-cropping-up/" title="China Thought It Had Beaten Coronavirus, But New And Asymptomatic Cases Are Cropping Up">
China Thought It Had Beaten Coronavirus, But New And Asymptomatic Cases Are Cropping Up									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68457 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/coronavirus-japan-to-declare-emergency-as-tokyo-cases-soar/" title="Coronavirus: Japan to declare emergency as Tokyo cases soar">
Coronavirus: Japan to declare emergency as Tokyo cases soar									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68454 post type-post status-publish format-standard has-post-thumbnail category-radio">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/qeerroofi-qarreen-oromoo-14-bakka-tokkotti-ajjeefamuu/" title="Qeerroofi Qarreen Oromoo 14, Bakka Tokkotti Ajjeefamuu.">
Qeerroofi Qarreen Oromoo 14, Bakka Tokkotti Ajjeefamuu.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68445 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/abiy-ahmed-%e1%8b%a8%e1%8b%88%e1%88%88%e1%8c%8b-%e1%8a%a6%e1%88%ae%e1%88%9e-%e1%88%8b%e1%8b%ad-%e1%8a%a5%e1%8b%a8%e1%89%b0%e1%8d%88%e1%8d%80%e1%88%98-%e1%8b%ab%e1%88%88-%e1%8c%8d%e1%8d%8d/" title="Abiy Ahmed!! የወለጋ ኦሮሞ ላይ እየተፈፀመ ያለ ግፍ!">
Abiy Ahmed!! የወለጋ ኦሮሞ ላይ እየተፈፀመ ያለ ግፍ!									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68442 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/we-cant-shut-down-democracy-in-a-crisis/" title="We Can’t Shut Down Democracy in a Crisis!!">
We Can’t Shut Down Democracy in a Crisis!!									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68439 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/coronavirus-irish-premier-varadkar-returns-to-work-as-doctor-during-crisis/" title="Coronavirus: Irish premier Varadkar returns to work as doctor during crisis">
Coronavirus: Irish premier Varadkar returns to work as doctor during crisis									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 6, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68430 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/breaking-news-pm-boris-johnson-admitted-to-hospital-over-virus-symptoms/" title="Breaking News: PM Boris Johnson admitted to hospital over virus symptoms">
Breaking News: PM Boris Johnson admitted to hospital over virus symptoms									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 5, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68426 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/south-sudan-51st-of-54-african-nations-to-report-virus-case/" title="South Sudan 51st of 54 African nations to report virus case">
South Sudan 51st of 54 African nations to report virus case									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 5, 2020</a></span>
</div>
</div>
</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://kichuu.com/2020/04/'> April 2020 </option>
<option value='https://kichuu.com/2020/03/'> March 2020 </option>
<option value='https://kichuu.com/2020/02/'> February 2020 </option>
<option value='https://kichuu.com/2020/01/'> January 2020 </option>
<option value='https://kichuu.com/2019/12/'> December 2019 </option>
<option value='https://kichuu.com/2019/11/'> November 2019 </option>
<option value='https://kichuu.com/2019/10/'> October 2019 </option>
<option value='https://kichuu.com/2019/09/'> September 2019 </option>
<option value='https://kichuu.com/2019/08/'> August 2019 </option>
<option value='https://kichuu.com/2019/07/'> July 2019 </option>
<option value='https://kichuu.com/2019/06/'> June 2019 </option>
<option value='https://kichuu.com/2019/05/'> May 2019 </option>
<option value='https://kichuu.com/2019/04/'> April 2019 </option>
<option value='https://kichuu.com/2019/03/'> March 2019 </option>
<option value='https://kichuu.com/2019/02/'> February 2019 </option>
<option value='https://kichuu.com/2019/01/'> January 2019 </option>
<option value='https://kichuu.com/2018/12/'> December 2018 </option>
<option value='https://kichuu.com/2018/11/'> November 2018 </option>
<option value='https://kichuu.com/2018/10/'> October 2018 </option>
<option value='https://kichuu.com/2018/09/'> September 2018 </option>
<option value='https://kichuu.com/2018/08/'> August 2018 </option>
<option value='https://kichuu.com/2018/07/'> July 2018 </option>
<option value='https://kichuu.com/2018/06/'> June 2018 </option>
<option value='https://kichuu.com/2018/05/'> May 2018 </option>
<option value='https://kichuu.com/2018/04/'> April 2018 </option>
<option value='https://kichuu.com/2018/03/'> March 2018 </option>
<option value='https://kichuu.com/2018/02/'> February 2018 </option>
<option value='https://kichuu.com/2018/01/'> January 2018 </option>
<option value='https://kichuu.com/2017/12/'> December 2017 </option>
<option value='https://kichuu.com/2017/11/'> November 2017 </option>
<option value='https://kichuu.com/2017/10/'> October 2017 </option>
<option value='https://kichuu.com/2017/09/'> September 2017 </option>
<option value='https://kichuu.com/2017/08/'> August 2017 </option>
<option value='https://kichuu.com/2017/07/'> July 2017 </option>
<option value='https://kichuu.com/2017/06/'> June 2017 </option>
<option value='https://kichuu.com/2017/05/'> May 2017 </option>
<option value='https://kichuu.com/2017/04/'> April 2017 </option>
<option value='https://kichuu.com/2017/03/'> March 2017 </option>
<option value='https://kichuu.com/2017/02/'> February 2017 </option>
<option value='https://kichuu.com/2017/01/'> January 2017 </option>
<option value='https://kichuu.com/2016/12/'> December 2016 </option>
<option value='https://kichuu.com/2016/11/'> November 2016 </option>
<option value='https://kichuu.com/2013/11/'> November 2013 </option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
var dropdown = document.getElementById( "archives-dropdown-2" );
function onSelectChange() {
if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
document.location.href = this.options[ this.selectedIndex ].value;
}
}
dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
<div class="mh-video-container">
<iframe seamless width="1280" height="720"  allowfullscreen data-src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe>
</div>
</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
<caption>April 2020</caption>
<thead>
<tr>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
<th scope="col" title="Sunday">S</th>
</tr>
</thead>
<tbody>
<tr>
<td colspan="2" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2020/04/01/" aria-label="Posts published on April 1, 2020">1</a></td><td><a href="https://kichuu.com/2020/04/02/" aria-label="Posts published on April 2, 2020">2</a></td><td><a href="https://kichuu.com/2020/04/03/" aria-label="Posts published on April 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/04/04/" aria-label="Posts published on April 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/04/05/" aria-label="Posts published on April 5, 2020">5</a></td>
</tr>
<tr>
<td id="today"><a href="https://kichuu.com/2020/04/06/" aria-label="Posts published on April 6, 2020">6</a></td><td>7</td><td>8</td><td>9</td><td>10</td><td>11</td><td>12</td>
</tr>
<tr>
<td>13</td><td>14</td><td>15</td><td>16</td><td>17</td><td>18</td><td>19</td>
</tr>
<tr>
<td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td>
</tr>
<tr>
<td>27</td><td>28</td><td>29</td><td>30</td>
<td class="pad" colspan="3">&nbsp;</td>
</tr>
</tbody>
</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
<span class="wp-calendar-nav-prev"><a href="https://kichuu.com/2020/03/">&laquo; Mar</a></span>
<span class="pad">&nbsp;</span>
<span class="wp-calendar-nav-next">&nbsp;</span>
</nav></div></div>	</aside>	</div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68394 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/marii-haala-yaroo-irratti-dhibee-koroonaa-vaayrasii-ilaalchissee-gorsa-doktaroota-oromoo-irraa/" title="Marii Haala Yaroo Irratti Dhibee Koroonaa Vaayrasii Ilaalchissee Gorsa Doktaroota oromoo Irraa"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Haala Yaroo" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?w=700&amp;ssl=1 700w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=250%2C187&amp;ssl=1 250w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=534%2C400&amp;ssl=1 534w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=768%2C575&amp;ssl=1 768w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/pizap-3-1-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/marii-haala-yaroo-irratti-dhibee-koroonaa-vaayrasii-ilaalchissee-gorsa-doktaroota-oromoo-irraa/" title="Marii Haala Yaroo Irratti Dhibee Koroonaa Vaayrasii Ilaalchissee Gorsa Doktaroota oromoo Irraa">
Marii Haala Yaroo Irratti Dhibee Koroonaa Vaayrasii Ilaalchissee Gorsa Doktaroota oromoo Irraa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 5, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68364 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/cuomo-warns-that-peak-of-crisis-is-still-to-come/" title="Cuomo Warns That Peak of Crisis Is Still to Come:"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Cuomo" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/04/04nyvirus-briefingNEW1-superJumbo-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/cuomo-warns-that-peak-of-crisis-is-still-to-come/" title="Cuomo Warns That Peak of Crisis Is Still to Come:">
Cuomo Warns That Peak of Crisis Is Still to Come:									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 4, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68331 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/breakingcdcs-recommendation-on-use-of-cloth-face-coverings/" title="Breaking:CDC’s recommendation on use of cloth face coverings,"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="CDC’s recommendation" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/2019-coronavirus-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/breakingcdcs-recommendation-on-use-of-cloth-face-coverings/" title="Breaking:CDC’s recommendation on use of cloth face coverings,">
Breaking:CDC’s recommendation on use of cloth face coverings,									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 4, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Mohammed Hajjii" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68308 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/adem-mohammed-corona-ethiopian-music-2020-official-video/" title="Adem Mohammed &#8211; Corona &#8211; Ethiopian Music 2020 Official Video"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/yes25.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Adem Mohammed" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/yes25.png?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/yes25.png?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/yes25.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/yes25.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/04/yes25.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/adem-mohammed-corona-ethiopian-music-2020-official-video/" title="Adem Mohammed &#8211; Corona &#8211; Ethiopian Music 2020 Official Video">
Adem Mohammed &#8211; Corona &#8211; Ethiopian Music 2020 Official Video									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 3, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-68303 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/darajjee-shuumii-naa-darbii-maaskii-sirba-masinqoo-haaraa-2020/" title="Darajjee Shuumii Naa Darbii Maaskii Sirba  Masinqoo  Haaraa 2020"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/04/yes134.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Darajjee Shuumii" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/04/yes134.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/04/yes134.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/04/yes134.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/04/yes134.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/04/yes134.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/darajjee-shuumii-naa-darbii-maaskii-sirba-masinqoo-haaraa-2020/" title="Darajjee Shuumii Naa Darbii Maaskii Sirba  Masinqoo  Haaraa 2020">
Darajjee Shuumii Naa Darbii Maaskii Sirba  Masinqoo  Haaraa 2020									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 3, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-67985 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/siisaay-girmaa-sin-himadha-new-oromo-music-2020-official-video/" title="Siisaay Girmaa Sin himadha New Oromo  Music 2020. Official Video."><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes6-3.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Siisaay Girmaa" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes6-3.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes6-3.png?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes6-3.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes6-3.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes6-3.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/siisaay-girmaa-sin-himadha-new-oromo-music-2020-official-video/" title="Siisaay Girmaa Sin himadha New Oromo  Music 2020. Official Video.">
Siisaay Girmaa Sin himadha New Oromo  Music 2020. Official Video.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 30, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-67934 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/us-stocks-rise-despite-growing-risks-to-global-economy-from-coronavirus-outbreak/" title="US stocks rise despite growing risks to global economy from coronavirus outbreak"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/getty-stock-market-rising_large.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="US stocks" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/getty-stock-market-rising_large.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/getty-stock-market-rising_large.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/getty-stock-market-rising_large.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/getty-stock-market-rising_large.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/getty-stock-market-rising_large.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/us-stocks-rise-despite-growing-risks-to-global-economy-from-coronavirus-outbreak/" title="US stocks rise despite growing risks to global economy from coronavirus outbreak">
US stocks rise despite growing risks to global economy from coronavirus outbreak									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 30, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66348 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/drilling-officially-kicked-off-for-tulu-moye-geothermal-project-in-ethiopia/" title="Drilling officially kicked off for Tulu Moye geothermal project in Ethiopia"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Tulu Moye geothermal project" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/TuluMoye_drilling_KenGen_Ethiopia-1024x485-1-scaled.jpeg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/drilling-officially-kicked-off-for-tulu-moye-geothermal-project-in-ethiopia/" title="Drilling officially kicked off for Tulu Moye geothermal project in Ethiopia">
Drilling officially kicked off for Tulu Moye geothermal project in Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-66161 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/heat-from-the-earth-toshiba-and-toyota-win-geothermal-deal-in-ethiopia/" title="Heat from the earth: Toshiba and Toyota win geothermal deal in Ethiopia"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Geothermal" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/03/yes8-1.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/heat-from-the-earth-toshiba-and-toyota-win-geothermal-deal-in-ethiopia/" title="Heat from the earth: Toshiba and Toyota win geothermal deal in Ethiopia">
Heat from the earth: Toshiba and Toyota win geothermal deal in Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 6, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
</div>
</footer>
<div class="mh-footer-nav-mobile"></div>
<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
</nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright @2016 kichuu.com              		</p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-58166095-1', 'auto');
ga('send', 'pageview');
</script>			<div id="fb-root"></div>
<script>
(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.6.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://kichuu.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202015.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'111820558',post:'68472',tz:'-4',srv:'kichuu.com'} ]);
_stq.push([ 'clickTrackerInit', '111820558', '68472' ]);
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.635126113892 seconds, on 06-04-20 20:37:49 -->