<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head><style>img.lazy{min-height:1px}</style><link rel="preload" href="https://kichuu.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js" as="script">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests &#x2d; Kichuu</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="robots" content="max-snippet:-1,max-image-preview:standard,max-video-preview:-1" />
<meta name="description" content="From &#8216;isat ena chid&#8217; to &#8216;asadaj ena tesadaj&#8217;, the Abyssinian elite trie to undermine the Oromo fight to justice, freedom and democracy." />
<meta property="og:image" content="https://kichuu.com/wp-content/uploads/2020/07/nego.png" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="386" />
<meta property="og:image" content="https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-650x366.jpg" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests &#x2d; Kichuu" />
<meta property="og:description" content="From &#8216;isat ena chid&#8217; to &#8216;asadaj ena tesadaj&#8217;, the Abyssinian elite trie to undermine the Oromo fight to justice, freedom and democracy." />
<meta property="og:url" content="https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:published_time" content="2020-07-11T13:58+00:00" />
<meta property="article:modified_time" content="2020-07-11T14:04+00:00" />
<meta property="og:updated_time" content="2020-07-11T14:04+00:00" />
<link rel="canonical" href="https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://kichuu.com/","name":"Kichuu is an online news publisher focusing on East Africa"}},{"@type":"ListItem","position":2,"item":{"@id":"https://kichuu.com/category/afaan-oromoo/","name":"Afaan Oromoo"}},{"@type":"ListItem","position":3,"item":{"@id":"https://kichuu.com/category/afaan-oromoo/videos/","name":"Videos"}},{"@type":"ListItem","position":4,"item":{"@id":"https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/","name":"Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 3.40ms meta | 14.41ms boot -->

<link rel="amphtml" href="https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/amp/" /><meta name="generator" content="AMP for WP 1.0.58.3"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests Comments Feed" href="https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/feed/" />
<link rel="stylesheet" href="https://kichuu.com/wp-content/cache/minify/45b8c.css" media="all" />





<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script src="https://kichuu.com/wp-content/cache/minify/e7d24.js"></script>



<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
	<link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-270x270.png" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-74193 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-top">
							<form role="search" method="get" class="search-form" action="https://kichuu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81"   alt="Kichuu" data-srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" data-sizes="(max-width: 331px) 100vw, 331px" class="custom-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="331" height="81" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20331%2081'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" class="custom-logo lazy" alt="Kichuu" data-srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w" data-sizes="(max-width: 331px) 100vw, 331px" /></noscript></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ads20171214 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3403389782"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
	<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
	<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
	<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
	<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
	<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
	<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
	<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/" title="Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 11, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Videos							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%a5%e1%89%b5-%e1%88%98%e1%8c%8d%e1%88%88%e1%8c%ab/" title="የኤርትራ መንግሥት መግለጫ">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 11, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							የኤርትራ መንግሥት መግለጫ						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Business							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/dhimmootni-abbaan-alangaa-federaalaa-namoota-art-haacaaluu-ajjeesaniifi-qaama-ajjeechaa-kana-duuba-jiru-ibsuu/" title="Dhimmootni: Abbaan Alangaa Federaalaa namoota Art. Haacaaluu Ajjeesaniifi qaama ajjeechaa kana duuba jiru ibsuu">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Dhimmootni: Abbaan Alangaa Federaalaa namoota Art. Haacaaluu Ajjeesaniifi qaama ajjeechaa kana duuba jiru ibsuu						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Radio							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/unpo-is-concerned-about-the-apparent-lack-of-legal-basis-justifying-the-deprivation-of-liberty-of-senior-officials-of-olf/" title="UNPO is concerned about the apparent lack of legal basis justifying the deprivation of liberty of senior officials of OLF.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							UNPO is concerned about the apparent lack of legal basis justifying the deprivation of liberty of senior officials of OLF.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																World							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/hiriira-mormii-hawaasa-oromoo-state-of-washington-godhuuf-deemaa-jira/" title="Hiriira mormii Hawaasa Oromoo state of Washington Godhuuf deemaa jira.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Hiriira mormii Hawaasa Oromoo state of Washington Godhuuf deemaa jira.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Videos							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/ethiopia-makes-arrests-in-singers-death-that-sparked-riots/" title="Ethiopia Makes Arrests in Singer’s Death That Sparked Riots">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Ethiopia Makes Arrests in Singer’s Death That Sparked Riots						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/the-jewel-case-ethiopia-boredom-poor-ol-bert-jansch-etc/" title="The Jewel Case: Ethiopia, Boredom, Poor Ol’ Bert Jansch, Etc.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							The Jewel Case: Ethiopia, Boredom, Poor Ol’ Bert Jansch, Etc.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																World							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/oromoonni-afrikkaa-kibbaa-jiraatan-haala-kanaan-hiriira-deeggarsaa-kan-ummata-isaaniif-qaban/" title="Oromoonni Afrikkaa Kibbaa Jiraatan Haala Kanaan Hiriira Deeggarsaa Kan Ummata isaaniif qaban">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Oromoonni Afrikkaa Kibbaa Jiraatan Haala Kanaan Hiriira Deeggarsaa Kan Ummata isaaniif qaban						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Videos							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a0%e1%88%a8%e1%89%b2%e1%88%b5%e1%89%b5-%e1%88%80%e1%8c%ab%e1%88%89-%e1%8c%8d%e1%8b%b0%e1%8b%ab-%e1%8a%a5%e1%8a%93-%e1%8b%a8%e1%8c%a0%e1%89%85%e1%88%8b%e1%8b%ad-%e1%8a%a0%e1%89%83/" title="የአረቲስት ሀጫሉ ግደያ እና የጠቅላይ አቃቤ ህግ መግለጫ: KMN Kush Media Network">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							የአረቲስት ሀጫሉ ግደያ እና የጠቅላይ አቃቤ ህግ መግለጫ: KMN Kush Media Network						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Videos							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/abiyyi-ahimad-naasuu-keessa-jira/" title="Abiyyi Ahimad naasuu keessa jira.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ July 10, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Abiyyi Ahimad naasuu keessa jira.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Videos							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://kichuu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com/category/afaan-oromoo/videos/" itemprop="item"><span itemprop="name">Videos</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests</nav>
<article id="post-74193" class="post-74193 post type-post status-publish format-standard has-post-thumbnail hentry category-videos">
	<header class="entry-header clearfix"><h1 class="entry-title">Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 11, 2020</a></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F&t=Ethiopia+unrest+%3A+African+Diaspora+Forum+calls+on+AU+chair+Cyril+Ramaphosa+to+intervene+in+unrests', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Ethiopia+unrest+%3A+African+Diaspora+Forum+calls+on+AU+chair+Cyril+Ramaphosa+to+intervene+in+unrests:&url=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F&media=https://kichuu.com/wp-content/uploads/2020/07/nego.png&description=Ethiopia+unrest+%3A+African+Diaspora+Forum+calls+on+AU+chair+Cyril+Ramaphosa+to+intervene+in+unrests', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Ethiopia%20unrest%20%3A%20African%20Diaspora%20Forum%20calls%20on%20AU%20chair%20Cyril%20Ramaphosa%20to%20intervene%20in%20unrests&amp;body=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
<h1 class="title style-scope ytd-video-primary-info-renderer">Ethiopia unrest African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests</h1>
<p><iframe  width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-src="https://www.youtube.com/embed/Xz2M49u070E" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<div class="_1dwg _1w_m _q7o" data-visualcompletion="ignore-dynamic">
<div>
<div id="js_4cq" class="_5pbx userContent _3ds9 _3576" data-testid="post_message" data-ft="{&quot;tn&quot;:&quot;K&quot;}">
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- k20200225 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3156329304"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>From &#8216;isat ena chid&#8217; to &#8216;asadaj ena tesadaj&#8217;, the Abyssinian elite trie to undermine the Oromo fight to justice, freedom and democracy.</p>
<p>TPLF called the Oromo attempt to work with like minded Amharas to bring about change and get rid of dictatorship &#8216;Isat ena chid&#8217;.</p>
<p>Now the Naftenga/Neonaftenga are calling the solidarity between Tigreans and Oromos against dictatorship &#8216;tesadaj ena asadaj&#8217;. The Neonaftenga lunatics in &#8220;Addis Ababa&#8221; have concluded that all Tigreans who are standing in solidarity with Oromos are TPLF members and &#8216;asadaj&#8217;. Mind that.</p>
<p><a href="https://www.facebook.com/reinventingethiopia?__tn__=%2CdC-R1.g-R&amp;eid=ARAs24KLI9V_UwB6XsG931UzTxBfR_XEjXtBOsLGiUq5vWYjJK3v2Aq5oYLZJyRh92jFS8wxktdr7Sxg&amp;hc_ref=ARTrKgjC4Bj3keDRRCFfpCKILI1wT7kbi2RqgHjRQ3it_mqF25Q-ozIe6x2aprUb3B8&amp;fref=nf" data-hovercard="/ajax/hovercard/user.php?id=100007021622223&amp;extragetparams=%7B%22__tn__%22%3A%22%2CdC-R1.g-R%22%2C%22eid%22%3A%22ARAs24KLI9V_UwB6XsG931UzTxBfR_XEjXtBOsLGiUq5vWYjJK3v2Aq5oYLZJyRh92jFS8wxktdr7Sxg%22%2C%22hc_ref%22%3A%22ARTrKgjC4Bj3keDRRCFfpCKILI1wT7kbi2RqgHjRQ3it_mqF25Q-ozIe6x2aprUb3B8%22%2C%22fref%22%3A%22nf%22%7D" data-hovercard-prefer-more-content-show="1" data-hovercard-referer="ARTrKgjC4Bj3keDRRCFfpCKILI1wT7kbi2RqgHjRQ3it_mqF25Q-ozIe6x2aprUb3B8">Biyya Oromiyaa</a></p>
<p><iframe style="border: none; overflow: hidden;"  width="560" height="315" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen" data-src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2Feftuus%2Fvideos%2F10217325394595208%2F&amp;show_text=0&amp;width=560" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<p><a class="_58cn" href="https://www.facebook.com/hashtag/oromoprotests?__eep__=6&amp;source=feed_text&amp;epa=HASHTAG" data-ft="{&quot;type&quot;:104,&quot;tn&quot;:&quot;*N&quot;}"><span class="_5afx"><span class="_58cl _5afz" aria-label="hashtag">#</span><span class="_58cm">OromoProtests</span></span></a> justice for Haacaaluu!! Mpls MN!!</p>
<hr />
<p>Evil Abiy ordered the assassination ofHaacaalu, and now he is directing a drama to accuse Oromos and Tigreans.</p>
<p><img   alt="" width="650" height="366" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-650x366.jpg 650w, https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-250x141.jpg 250w, https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-678x381.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-scaled.jpg 700w"  data-src="http://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-650x366.jpg" data-sizes="(max-width: 650px) 100vw, 650px" class="alignnone size-large wp-image-74194 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignnone size-large wp-image-74194 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20366'%3E%3C/svg%3E" data-src="http://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-650x366.jpg" alt="" width="650" height="366" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-650x366.jpg 650w, https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-250x141.jpg 250w, https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-678x381.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/107599023_4042186779188464_7383976536548588487_n-scaled.jpg 700w" data-sizes="(max-width: 650px) 100vw, 650px" /></noscript></p>
<p><a class="_hli" title="Caalaa Hayiluu Abaataa" href="https://www.facebook.com/chala.hailu1?__tn__=%2Cd%2AF%2AF-R&amp;eid=ARDpQReAXNRD-HJ6_fedME24krLyN2a2zf8mxJDcsrlDW4-crTOYAcFhKwEUApmeNNhxSuINWw1nOpTX&amp;tn-str=%2AF" data-hovercard="/ajax/hovercard/user.php?id=100001915440094&amp;extragetparams=%7B%22__tn__%22%3A%22%2Cd%2AF%2AF-R%22%2C%22eid%22%3A%22ARDpQReAXNRD-HJ6_fedME24krLyN2a2zf8mxJDcsrlDW4-crTOYAcFhKwEUApmeNNhxSuINWw1nOpTX%22%2C%22tn-str%22%3A%22%2AF%22%7D" data-hovercard-prefer-more-content-show="1">Caalaa Hayiluu Abaataa</a></p>
<hr />
<p><iframe style="border: none; overflow: hidden;"  width="560" height="315" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen" data-src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FDabessaG%2Fvideos%2F10221641078287979%2F&amp;show_text=0&amp;width=560" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<p><iframe  width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-src="https://www.youtube.com/embed/5YIekmgbjyo" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe></p>
<p>Que falta de respeto! disrespect!</p>
</div>
</div>
</div>
<!-- AI CONTENT END 1 -->
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F&t=Ethiopia+unrest+%3A+African+Diaspora+Forum+calls+on+AU+chair+Cyril+Ramaphosa+to+intervene+in+unrests', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Ethiopia+unrest+%3A+African+Diaspora+Forum+calls+on+AU+chair+Cyril+Ramaphosa+to+intervene+in+unrests:&url=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F&media=https://kichuu.com/wp-content/uploads/2020/07/nego.png&description=Ethiopia+unrest+%3A+African+Diaspora+Forum+calls+on+AU+chair+Cyril+Ramaphosa+to+intervene+in+unrests', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Ethiopia%20unrest%20%3A%20African%20Diaspora%20Forum%20calls%20on%20AU%20chair%20Cyril%20Ramaphosa%20to%20intervene%20in%20unrests&amp;body=https%3A%2F%2Fkichuu.com%2Fethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
	</div><div id="custom_html-7" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20190303 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3737122119"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%a5%e1%89%b5-%e1%88%98%e1%8c%8d%e1%88%88%e1%8c%ab/" rel="prev"><img width="80" height="60"   alt="የኤርትራ" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60"   alt="የኤርትራ" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="የኤርትራ" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript><span>Previous</span><p>የኤርትራ መንግሥት መግለጫ</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='74193' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="22247c46cd" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="43"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-71565 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done"><img width="326" height="245"   alt="Ego Aside" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/say-oromia-80x60.jpg 80w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg" data-sizes="(max-width: 326px) 100vw, 326px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Ego Aside" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/say-oromia-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done">
												Putting Your Ego Aside and Getting the Job Done											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 3, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Putting Your Ego Aside and Getting the Job Done (Avoid Making the Same Mistake Twice) By Worku Burayu (Ph.D), June 3, 2020 Summary: Let’s load our Gada package that consists of seeing things intelligently, listening <a class="mh-excerpt-more" href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-70935 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia"><img width="209" height="241"   alt="Prospect for Uniting or Dismantling Ethiopia" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg 209w, https://kichuu.com/wp-content/uploads/2020/05/wbo-officers-173x200.jpg 173w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg" data-sizes="(max-width: 209px) 100vw, 209px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="209" height="241" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20209%20241'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Prospect for Uniting or Dismantling Ethiopia" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg 209w, https://kichuu.com/wp-content/uploads/2020/05/wbo-officers-173x200.jpg 173w" data-sizes="(max-width: 209px) 100vw, 209px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia">
												Prospect for Uniting or Dismantling Ethiopia											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 25, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Prospect for Uniting or Dismantling Ethiopia- “it is in our hand”-Oromo Liberation Army (OLA) By Worku Burayu (Ph.D.), May 25, 2020 Summary: “The remaining chance for united or dismantled Ethiopia falls on the hands of <a class="mh-excerpt-more" href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-70152 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion"><img width="326" height="245"   alt="crisis" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-80x60.jpg 80w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg" data-sizes="(max-width: 326px) 100vw, 326px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="crisis" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion">
												Ethiopia’s Dilemma and the Prime Minister’s Confusion											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 10, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Ethiopia’s Dilemma and the Prime Minister’s Confusion By Guluma Gemeda, PhD, May 10, 2020  Prime Minister Abiy Ahmed’s statements on Ethiopia’s election postponement, apparent constitutional crisis and the future of democracy in Ethiopia are full <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-69016 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia"><img width="325" height="217"   alt="Genocide" data-src="https://kichuu.com/wp-content/uploads/2018/08/Olf-flag.gif" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="325" height="217" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20325%20217'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2018/08/Olf-flag.gif" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Genocide" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia">
												Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 14, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia By: Itana Gammada, April 14, 2020 A people under colonial occupation have a maximum of two choices, either stand up and fight for their freedom <a class="mh-excerpt-more" href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-68078 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely"><img width="326" height="206"   alt="Abiy Ahmed" data-src="https://kichuu.com/wp-content/uploads/2020/04/close-326x206.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="206" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20206'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/04/close-326x206.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Abiy Ahmed" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">
												Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 1, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely (Our Struggle is Significantly Bigger than the Restoration of Internet/Phones Access) By Worku Burayu (PhD), April 1, 2020 Summary: Oromoo Sabakoo: Our struggle is <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-67990 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!"><img width="326" height="245"   alt="Democracy" data-srcset="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-80x60.jpg 80w"  data-src="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg" data-sizes="(max-width: 326px) 100vw, 326px" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Democracy" data-srcset="https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/03/abiy-menelik-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" /></noscript>										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!">
												There were some false starts at democracy in Ethiopia – let us make it real this time round!											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/03/">March 30, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">There were some false starts at democracy in Ethiopia – let us make it real this time round! By Taha Abdi, founder member of the OLF and former member of its executive committee February 20, <a class="mh-excerpt-more" href="https://kichuu.com/there-were-some-false-starts-at-democracy-in-ethiopia-let-us-make-it-real-this-time-round/" title="There were some false starts at democracy in Ethiopia – let us make it real this time round!">[Read More]</a></div>								</div>
							</div>
						</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74193 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-unrest-african-diaspora-forum-calls-on-au-chair-cyril-ramaphosa-to-intervene-in-unrests/" title="Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests">
										Ethiopia unrest : African Diaspora Forum calls on AU chair Cyril Ramaphosa to intervene in unrests									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 11, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74186 post type-post status-publish format-standard has-post-thumbnail category-business">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%a5%e1%89%b5-%e1%88%98%e1%8c%8d%e1%88%88%e1%8c%ab/" title="የኤርትራ መንግሥት መግለጫ">
										የኤርትራ መንግሥት መግለጫ									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 11, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74170 post type-post status-publish format-standard has-post-thumbnail category-radio">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/dhimmootni-abbaan-alangaa-federaalaa-namoota-art-haacaaluu-ajjeesaniifi-qaama-ajjeechaa-kana-duuba-jiru-ibsuu/" title="Dhimmootni: Abbaan Alangaa Federaalaa namoota Art. Haacaaluu Ajjeesaniifi qaama ajjeechaa kana duuba jiru ibsuu">
										Dhimmootni: Abbaan Alangaa Federaalaa namoota Art. Haacaaluu Ajjeesaniifi qaama ajjeechaa kana duuba jiru ibsuu									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74167 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/unpo-is-concerned-about-the-apparent-lack-of-legal-basis-justifying-the-deprivation-of-liberty-of-senior-officials-of-olf/" title="UNPO is concerned about the apparent lack of legal basis justifying the deprivation of liberty of senior officials of OLF.">
										UNPO is concerned about the apparent lack of legal basis justifying the deprivation of liberty of senior officials of OLF.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74160 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/hiriira-mormii-hawaasa-oromoo-state-of-washington-godhuuf-deemaa-jira/" title="Hiriira mormii Hawaasa Oromoo state of Washington Godhuuf deemaa jira.">
										Hiriira mormii Hawaasa Oromoo state of Washington Godhuuf deemaa jira.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74149 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-makes-arrests-in-singers-death-that-sparked-riots/" title="Ethiopia Makes Arrests in Singer’s Death That Sparked Riots">
										Ethiopia Makes Arrests in Singer’s Death That Sparked Riots									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74146 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/the-jewel-case-ethiopia-boredom-poor-ol-bert-jansch-etc/" title="The Jewel Case: Ethiopia, Boredom, Poor Ol’ Bert Jansch, Etc.">
										The Jewel Case: Ethiopia, Boredom, Poor Ol’ Bert Jansch, Etc.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74143 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/oromoonni-afrikkaa-kibbaa-jiraatan-haala-kanaan-hiriira-deeggarsaa-kan-ummata-isaaniif-qaban/" title="Oromoonni Afrikkaa Kibbaa Jiraatan Haala Kanaan Hiriira Deeggarsaa Kan Ummata isaaniif qaban">
										Oromoonni Afrikkaa Kibbaa Jiraatan Haala Kanaan Hiriira Deeggarsaa Kan Ummata isaaniif qaban									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74139 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a0%e1%88%a8%e1%89%b2%e1%88%b5%e1%89%b5-%e1%88%80%e1%8c%ab%e1%88%89-%e1%8c%8d%e1%8b%b0%e1%8b%ab-%e1%8a%a5%e1%8a%93-%e1%8b%a8%e1%8c%a0%e1%89%85%e1%88%8b%e1%8b%ad-%e1%8a%a0%e1%89%83/" title="የአረቲስት ሀጫሉ ግደያ እና የጠቅላይ አቃቤ ህግ መግለጫ: KMN Kush Media Network">
										የአረቲስት ሀጫሉ ግደያ እና የጠቅላይ አቃቤ ህግ መግለጫ: KMN Kush Media Network									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74135 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/abiyyi-ahimad-naasuu-keessa-jira/" title="Abiyyi Ahimad naasuu keessa jira.">
										Abiyyi Ahimad naasuu keessa jira.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74132 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/pm-abiy-ahmed-has-failed-to-reaffirm-human-rights-rule-of-law/" title="PM Abiy Ahmed Has Failed To Reaffirm Human Rights, Rule Of Law">
										PM Abiy Ahmed Has Failed To Reaffirm Human Rights, Rule Of Law									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74129 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/another-donald-trump-foreign-policy-foray-goes-awry/" title="Another Donald Trump Foreign Policy Foray Goes Awry">
										Another Donald Trump Foreign Policy Foray Goes Awry									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74127 post type-post status-publish format-standard has-post-thumbnail category-health">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/icco-supports-peoples-fight-against-the-coronavirus/" title="ICCO supports people’s fight against the coronavirus">
										ICCO supports people’s fight against the coronavirus									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74119 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/nile-dam-row-egypt-and-ethiopia-generate-heat-but-no-power/" title="Nile Dam row: Egypt and Ethiopia generate heat but no power">
										Nile Dam row: Egypt and Ethiopia generate heat but no power									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74114 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/bbs-hiriira-mormii-dhalattoota-oromoo-uk-manchestar-jiraataniin-gaggeeffamaa-jiru/" title="BBS: Hiriira Mormii Dhalattoota Oromoo ,UK Manchestar jiraataniin gaggeeffamaa jiru.">
										BBS: Hiriira Mormii Dhalattoota Oromoo ,UK Manchestar jiraataniin gaggeeffamaa jiru.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74112 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/breaking-warri-bilxiginnaa-jawar-irratti-murtii-duaa-seeraan-murteessuf-karoorfattee-itti-bobbaatee-jirti/" title="Breaking: Warri bilxiginnaa, Jawar irratti murtii du&#8217;aa seeraan murteessuf karoorfattee itti bobbaatee jirti.">
										Breaking: Warri bilxiginnaa, Jawar irratti murtii du&#8217;aa seeraan murteessuf karoorfattee itti bobbaatee jirti.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74108 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/in-abiys-ethiopia-media-freedom-means-to-adore-the-regime-like-jesus-christ/" title="In Abiy&#8217;s Ethiopia, Media freedom means to adore the regime like Jesus Christ.">
										In Abiy&#8217;s Ethiopia, Media freedom means to adore the regime like Jesus Christ.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74104 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/hiriira-mormii-qeerroo-fi-hawaasa-oromoo-jarmanii-guyyaa-lammaffaa/" title="Hiriira Mormii Qeerroo fi hawaasa Oromoo Jarmanii guyyaa lammaffaa">
										Hiriira Mormii Qeerroo fi hawaasa Oromoo Jarmanii guyyaa lammaffaa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74099 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/as-ethiopians-take-to-the-streets-to-protest-a-musicians-murder-prime-minister-abiy-ahmed-is-stuck-in-a-precarious-position/" title="As Ethiopians Take to the Streets to Protest a Musician&#8217;s Murder, Prime Minister Abiy Ahmed Is Stuck in a Precarious Position">
										As Ethiopians Take to the Streets to Protest a Musician&#8217;s Murder, Prime Minister Abiy Ahmed Is Stuck in a Precarious Position									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 9, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74093 post type-post status-publish format-standard has-post-thumbnail category-amharic">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8a%a0%e1%89%b6-%e1%8a%a0%e1%89%a5%e1%8b%ad-%e1%8a%a0%e1%88%85%e1%88%98%e1%8b%b5-%e1%8b%a8%e1%8d%88%e1%88%a8%e1%88%b0%e1%8b%8d%e1%8a%95-%e1%8b%a8%e1%8a%a0%e1%8d%84-%e1%88%80%e1%8b%8d%e1%88%8d/" title="አቶ አብይ አህመድ የፈረሰውን የአፄ ሀውልት ዳግም እንደሚያቆም በለንደን የኢትዮዽያ ኢምባሲ አማካኝነት ገልፇል">
										አቶ አብይ አህመድ የፈረሰውን የአፄ ሀውልት ዳግም እንደሚያቆም በለንደን የኢትዮዽያ ኢምባሲ አማካኝነት ገልፇል									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 9, 2020</a></span>
</div>
							</div>
						</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://kichuu.com/2020/07/'> July 2020 </option>
	<option value='https://kichuu.com/2020/06/'> June 2020 </option>
	<option value='https://kichuu.com/2020/05/'> May 2020 </option>
	<option value='https://kichuu.com/2020/04/'> April 2020 </option>
	<option value='https://kichuu.com/2020/03/'> March 2020 </option>
	<option value='https://kichuu.com/2020/02/'> February 2020 </option>
	<option value='https://kichuu.com/2020/01/'> January 2020 </option>
	<option value='https://kichuu.com/2019/12/'> December 2019 </option>
	<option value='https://kichuu.com/2019/11/'> November 2019 </option>
	<option value='https://kichuu.com/2019/10/'> October 2019 </option>
	<option value='https://kichuu.com/2019/09/'> September 2019 </option>
	<option value='https://kichuu.com/2019/08/'> August 2019 </option>
	<option value='https://kichuu.com/2019/07/'> July 2019 </option>
	<option value='https://kichuu.com/2019/06/'> June 2019 </option>
	<option value='https://kichuu.com/2019/05/'> May 2019 </option>
	<option value='https://kichuu.com/2019/04/'> April 2019 </option>
	<option value='https://kichuu.com/2019/03/'> March 2019 </option>
	<option value='https://kichuu.com/2019/02/'> February 2019 </option>
	<option value='https://kichuu.com/2019/01/'> January 2019 </option>
	<option value='https://kichuu.com/2018/12/'> December 2018 </option>
	<option value='https://kichuu.com/2018/11/'> November 2018 </option>
	<option value='https://kichuu.com/2018/10/'> October 2018 </option>
	<option value='https://kichuu.com/2018/09/'> September 2018 </option>
	<option value='https://kichuu.com/2018/08/'> August 2018 </option>
	<option value='https://kichuu.com/2018/07/'> July 2018 </option>
	<option value='https://kichuu.com/2018/06/'> June 2018 </option>
	<option value='https://kichuu.com/2018/05/'> May 2018 </option>
	<option value='https://kichuu.com/2018/04/'> April 2018 </option>
	<option value='https://kichuu.com/2018/03/'> March 2018 </option>
	<option value='https://kichuu.com/2018/02/'> February 2018 </option>
	<option value='https://kichuu.com/2018/01/'> January 2018 </option>
	<option value='https://kichuu.com/2017/12/'> December 2017 </option>
	<option value='https://kichuu.com/2017/11/'> November 2017 </option>
	<option value='https://kichuu.com/2017/10/'> October 2017 </option>
	<option value='https://kichuu.com/2017/09/'> September 2017 </option>
	<option value='https://kichuu.com/2017/08/'> August 2017 </option>
	<option value='https://kichuu.com/2017/07/'> July 2017 </option>
	<option value='https://kichuu.com/2017/06/'> June 2017 </option>
	<option value='https://kichuu.com/2017/05/'> May 2017 </option>
	<option value='https://kichuu.com/2017/04/'> April 2017 </option>
	<option value='https://kichuu.com/2017/03/'> March 2017 </option>
	<option value='https://kichuu.com/2017/02/'> February 2017 </option>
	<option value='https://kichuu.com/2017/01/'> January 2017 </option>
	<option value='https://kichuu.com/2016/12/'> December 2016 </option>
	<option value='https://kichuu.com/2016/11/'> November 2016 </option>
	<option value='https://kichuu.com/2013/11/'> November 2013 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720"  allowfullscreen data-src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe>
        		</div>
			</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>July 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2020/07/01/" aria-label="Posts published on July 1, 2020">1</a></td><td><a href="https://kichuu.com/2020/07/02/" aria-label="Posts published on July 2, 2020">2</a></td><td><a href="https://kichuu.com/2020/07/03/" aria-label="Posts published on July 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/07/04/" aria-label="Posts published on July 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/07/05/" aria-label="Posts published on July 5, 2020">5</a></td>
	</tr>
	<tr>
		<td><a href="https://kichuu.com/2020/07/06/" aria-label="Posts published on July 6, 2020">6</a></td><td><a href="https://kichuu.com/2020/07/07/" aria-label="Posts published on July 7, 2020">7</a></td><td><a href="https://kichuu.com/2020/07/08/" aria-label="Posts published on July 8, 2020">8</a></td><td><a href="https://kichuu.com/2020/07/09/" aria-label="Posts published on July 9, 2020">9</a></td><td><a href="https://kichuu.com/2020/07/10/" aria-label="Posts published on July 10, 2020">10</a></td><td id="today"><a href="https://kichuu.com/2020/07/11/" aria-label="Posts published on July 11, 2020">11</a></td><td>12</td>
	</tr>
	<tr>
		<td>13</td><td>14</td><td>15</td><td>16</td><td>17</td><td>18</td><td>19</td>
	</tr>
	<tr>
		<td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td>
	</tr>
	<tr>
		<td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://kichuu.com/2020/06/">&laquo; Jun</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74127 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/icco-supports-peoples-fight-against-the-coronavirus/" title="ICCO supports people’s fight against the coronavirus"><img width="80" height="60"   alt="Coronavirus" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-250x190.png 250w, https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-326x245.png 326w, https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318.png 420w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Coronavirus" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-250x190.png 250w, https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318-326x245.png 326w, https://kichuu.com/wp-content/uploads/2020/07/ReliefWeb-420x320-20200318.png 420w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/icco-supports-peoples-fight-against-the-coronavirus/" title="ICCO supports people’s fight against the coronavirus">
										ICCO supports people’s fight against the coronavirus									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-73690 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/food-security-of-people-at-risk-in-ethiopia-due-to-wfp-funding-crises/" title="Food security of people at risk in Ethiopia due to WFP funding crises"><img width="80" height="60"   alt="Food security" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-250x190.png 250w, https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-326x245.png 326w, https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318.png 420w"  data-src="https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Food security" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-250x190.png 250w, https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318-326x245.png 326w, https://kichuu.com/wp-content/uploads/2020/05/ReliefWeb-420x320-20200318.png 420w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/food-security-of-people-at-risk-in-ethiopia-due-to-wfp-funding-crises/" title="Food security of people at risk in Ethiopia due to WFP funding crises">
										Food security of people at risk in Ethiopia due to WFP funding crises									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 3, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-73145 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/covid-19-survivors-could-lose-health-insurance-if-trump-wins-bid-to-repeal-obamacare/" title="Covid-19 survivors could lose health insurance if Trump wins bid to repeal Obamacare"><img width="80" height="60"   alt="Obamacare" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/2625-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/2625-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/2625-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/2625-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/2625-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Obamacare" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/2625-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/2625-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/2625-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/covid-19-survivors-could-lose-health-insurance-if-trump-wins-bid-to-repeal-obamacare/" title="Covid-19 survivors could lose health insurance if Trump wins bid to repeal Obamacare">
										Covid-19 survivors could lose health insurance if Trump wins bid to repeal Obamacare									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 28, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60"   alt="Mohammed Hajjii" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w"  data-src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Mohammed Hajjii" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
										Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60"   alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
										“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60"   alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/04/robe-678x509.png 678w, https://kichuu.com/wp-content/uploads/2019/04/robe-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" data-srcset="https://kichuu.com/wp-content/uploads/2019/04/robe-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/04/robe-678x509.png 678w, https://kichuu.com/wp-content/uploads/2019/04/robe-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
										Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-73564 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/hachalu-hundessa-millennium-hall-addis-ababa-finfinee/" title="Hachalu Hundessa @ Millennium Hall Addis Ababa (Finfinee)"><img width="80" height="60"   alt="Hachalu Hundessa" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/pizap-2-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-scaled.jpg 665w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/pizap-2-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/pizap-2-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Hachalu Hundessa" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/pizap-2-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/07/pizap-2-scaled.jpg 665w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/hachalu-hundessa-millennium-hall-addis-ababa-finfinee/" title="Hachalu Hundessa @ Millennium Hall Addis Ababa (Finfinee)">
										Hachalu Hundessa @ Millennium Hall Addis Ababa (Finfinee)									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 1, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-73109 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/andualem-gosa-waa-hoyyee-new-ethiopia-oromo/" title="Andualem Gosa -Waa Hoyyee &#8211; New Ethiopia Oromo"><img width="80" height="60"   alt="Andualem Gosa" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-scaled.jpg 665w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Andualem Gosa" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/pizap-1-4-scaled.jpg 665w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/andualem-gosa-waa-hoyyee-new-ethiopia-oromo/" title="Andualem Gosa -Waa Hoyyee &#8211; New Ethiopia Oromo">
										Andualem Gosa -Waa Hoyyee &#8211; New Ethiopia Oromo									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 27, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-73064 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ittiiqaa-tafarii-saaqi-saanqaa-new-oromo-music/" title="Ittiiqaa Tafarii: Saaqi Saanqaa NEW Oromo Music"><img width="80" height="60"   alt="Ittiiqaa Tafarii" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-scaled.jpg 665w"  data-src="https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Ittiiqaa Tafarii" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-532x400.jpg 532w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-768x577.jpg 768w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/pizap-24-1-scaled.jpg 665w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ittiiqaa-tafarii-saaqi-saanqaa-new-oromo-music/" title="Ittiiqaa Tafarii: Saaqi Saanqaa NEW Oromo Music">
										Ittiiqaa Tafarii: Saaqi Saanqaa NEW Oromo Music									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 26, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74186 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/%e1%8b%a8%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%a5%e1%89%b5-%e1%88%98%e1%8c%8d%e1%88%88%e1%8c%ab/" title="የኤርትራ መንግሥት መግለጫ"><img width="80" height="60"   alt="የኤርትራ" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60"   alt="የኤርትራ" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="የኤርትራ" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/EceeDArWkAAScV3-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a4%e1%88%ad%e1%89%b5%e1%88%ab-%e1%88%98%e1%8a%95%e1%8c%8d%e1%88%a5%e1%89%b5-%e1%88%98%e1%8c%8d%e1%88%88%e1%8c%ab/" title="የኤርትራ መንግሥት መግለጫ">
										የኤርትራ መንግሥት መግለጫ									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 11, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-74023 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-india-top-countries-where-poor-nutrition-is-costing-companies-billions-of-dollars/" title="Ethiopia, India top countries where poor nutrition is costing companies billions of dollars"><img width="80" height="60"   alt="Ethiopia-India" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-326x245.jpg 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-80x60.jpg" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Ethiopia-India" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/07/105fb02a-e8eb-4d8b-ae49-1d03d81ed843-e1592720503111-1024x576-1-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-india-top-countries-where-poor-nutrition-is-costing-companies-billions-of-dollars/" title="Ethiopia, India top countries where poor nutrition is costing companies billions of dollars">
										Ethiopia, India top countries where poor nutrition is costing companies billions of dollars									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 8, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-73511 post type-post status-publish format-standard has-post-thumbnail category-business category-world">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/fitch-rating-fitch-affirms-ethiopia-at-b-outlook-negative/" title="Fitch Rating: Fitch Affirms Ethiopia at &#8216;B&#8217;; Outlook Negative"><img width="80" height="60"   alt="Fitch Affirms Ethiopia" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/6f563922-d2e7-4251-9ea1-39d35e542b49_wide_fallback-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/07/6f563922-d2e7-4251-9ea1-39d35e542b49_wide_fallback-326x245.png 326w"  data-src="https://kichuu.com/wp-content/uploads/2020/07/6f563922-d2e7-4251-9ea1-39d35e542b49_wide_fallback-80x60.png" data-sizes="(max-width: 80px) 100vw, 80px" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/6f563922-d2e7-4251-9ea1-39d35e542b49_wide_fallback-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Fitch Affirms Ethiopia" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/6f563922-d2e7-4251-9ea1-39d35e542b49_wide_fallback-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/07/6f563922-d2e7-4251-9ea1-39d35e542b49_wide_fallback-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" /></noscript>									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/fitch-rating-fitch-affirms-ethiopia-at-b-outlook-negative/" title="Fitch Rating: Fitch Affirms Ethiopia at &#8216;B&#8217;; Outlook Negative">
										Fitch Rating: Fitch Affirms Ethiopia at &#8216;B&#8217;; Outlook Negative									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 1, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright @2016 kichuu.com              		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-58166095-1', 'auto');
  ga('send', 'pageview');

</script>			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> <script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>

<script src="https://kichuu.com/wp-content/cache/minify/9cc9c.js"></script>

<script type='text/javascript'>
lazySizes.cfg.nativeLoading={setLoadingAttribute:false,disableListeners:{scroll:true}};lazySizes.init();
</script>


<script src="https://kichuu.com/wp-content/cache/minify/4ab7c.js"></script>

<script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src="https://kichuu.com/wp-content/cache/minify/1615d.js"></script>
</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 
Lazy Loading
Minified using disk
Database Caching 132/148 queries in 0.137 seconds using disk

Served from: kichuu.com @ 2020-07-11 10:05:47 by W3 Total Cache
-->