<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Eritrean President: South Sudan’s separation from Sudan was a great mistake Kichuu</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v12.9.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Eritrean President: South Sudan’s separation from Sudan was a great mistake. Speaking On a live interview conducted on national tv"/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Eritrean President: South Sudan’s separation from Sudan was a great mistake Kichuu" />
<meta property="og:description" content="Eritrean President: South Sudan’s separation from Sudan was a great mistake. Speaking On a live interview conducted on national tv" />
<meta property="og:url" content="https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:publisher" content="https://www.facebook.com/kichuu.info/" />
<meta property="article:section" content="Africa" />
<meta property="article:published_time" content="2020-02-09T00:12:39+00:00" />
<meta property="article:modified_time" content="2020-02-09T00:45:28+00:00" />
<meta property="og:updated_time" content="2020-02-09T00:45:28+00:00" />
<meta property="og:image" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?fit=750%2C774&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?fit=750%2C774&#038;ssl=1" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="774" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507","name":"fmegersa","logo":{"@id":"https://kichuu.com/#personlogo"},"sameAs":[]},{"@type":"WebSite","@id":"https://kichuu.com/#website","url":"https://kichuu.com/","name":"Kichuu","publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"potentialAction":{"@type":"SearchAction","target":"https://kichuu.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#primaryimage","url":"https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?fit=750%2C774&ssl=1","width":750,"height":774,"caption":"Eritrean President"},{"@type":"WebPage","@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#webpage","url":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/","inLanguage":"en-US","name":"Eritrean President: South Sudan\u2019s separation from Sudan was a great mistake Kichuu","isPartOf":{"@id":"https://kichuu.com/#website"},"primaryImageOfPage":{"@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#primaryimage"},"datePublished":"2020-02-09T00:12:39+00:00","dateModified":"2020-02-09T00:45:28+00:00","description":"Eritrean President: South Sudan\u2019s separation from Sudan was a great mistake. Speaking On a live interview conducted on national tv"},{"@type":"Article","@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#article","isPartOf":{"@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#webpage"},"author":{"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330"},"headline":"Eritrean President: South Sudan\u2019s separation from Sudan was a great mistake","datePublished":"2020-02-09T00:12:39+00:00","dateModified":"2020-02-09T00:45:28+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#webpage"},"publisher":{"@id":"https://kichuu.com/#/schema/person/379f8adb561bf35b0e4dc4f918751507"},"image":{"@id":"https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#primaryimage"},"articleSection":"Africa"},{"@type":["Person"],"@id":"https://kichuu.com/#/schema/person/d25a886fc3bed9aa00f2f879a4c77330","name":"kichuu_admin","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Eritrean President: South Sudan’s separation from Sudan was a great mistake Comments Feed" href="https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/feed/" />
<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ -->		<script>
//@formatter:off
advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
</script><link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://kichuu.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='https://kichuu.com/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css?ver=1.7.5' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-magazine-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/style.css?ver=3.8.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='mh-font-awesome-css'  href='https://kichuu.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//kichuu.com/wp-content/cache/wpfc-minified/dhrvjwy1/3wmh1.css" media="all"/>
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.1.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='https://kichuu.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.6'></script>
<link rel='https://api.w.org/' href='https://kichuu.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://kichuu.com/?p=64688' />
<link rel="alternate" type="application/json+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://kichuu.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>
<script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1.png?fit=270%2C270&#038;ssl=1" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-64688 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-top">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="Kichuu" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?w=331&amp;ssl=1 331w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=300%2C73&amp;ssl=1 300w, https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?resize=326%2C81&amp;ssl=1 326w" data-lazy-sizes="(max-width: 331px) 100vw, 331px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png?fit=331%2C81&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="6220502696"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-title mh-ticker-title-bottom">
News Ticker<i class="fa fa-chevron-right"></i>		</div>
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/%e1%88%9a%e1%88%8a%e1%89%b0%e1%88%aa%e1%8b%9d%e1%88%9d-%e1%88%88%e1%8a%a2%e1%89%b5%e1%8b%ae%e1%8c%b5%e1%8b%ab%e1%8a%a0%e1%88%81%e1%8a%95-%e1%8a%a0%e1%88%81%e1%8a%95-%e1%8a%a5%e1%8b%ab%e1%88%b5/" title="ሚሊተሪዝም ለኢትዮጵያ?አሁን አሁን እያስተዋልን ያለነው አብይ አህመድ የመንግሥቱ ኃይለማርያምን ዱካ እየተከተለ መምጣቱን ነው።">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
ሚሊተሪዝም ለኢትዮጵያ?አሁን አሁን እያስተዋልን ያለነው አብይ አህመድ የመንግሥቱ ኃይለማርያምን ዱካ እየተከተለ መምጣቱን ነው።						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Amharic							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/eritrea-the-trump-administration-has-confirmed-visa-bans-on-four-african-countries-including-nigeria/" title="Eritrea: The Trump administration has confirmed visa bans on four African countries, including Nigeria">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Eritrea: The Trump administration has confirmed visa bans on four African countries, including Nigeria						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
World							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/" title="Eritrean President: South Sudan’s separation from Sudan was a great mistake">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Eritrean President: South Sudan’s separation from Sudan was a great mistake						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/abon-magaalaa-baakkootti-uummata-waliin-marii-balaa-gaggeeffate-gufuunis-mudate/" title="ABO&#8217;n magaalaa Baakkootti uummata waliin marii bal&#8217;aa gaggeeffate! Gufuunis mudate">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
ABO&#8217;n magaalaa Baakkootti uummata waliin marii bal&#8217;aa gaggeeffate! Gufuunis mudate						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/breakin-news-salphinni-abiy-haamidifi-bilxiginnaa-akkuma-itti-fufeetti-jira/" title="Breakin News: Salphinni Abiy haamidifi Bilxiginnaa akkuma itti fufeetti jira!">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Breakin News: Salphinni Abiy haamidifi Bilxiginnaa akkuma itti fufeetti jira!						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Africa							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/isaayaas-afawarqii-laft-eeritiraa-kan-hin-deebiiin-hafee-diddaa-tplftiin/" title="Isaayaas Afawarqii: &#8220;Laft Eeritiraa kan hin deebi&#8217;iin hafee diddaa TPLF&#8217;tiin&#8221;">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Isaayaas Afawarqii: &#8220;Laft Eeritiraa kan hin deebi&#8217;iin hafee diddaa TPLF&#8217;tiin&#8221;						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/yaasoo-kabbabaa-haa-hiikamu-jechuun-eebba-waajjira-abo-kamisee-irratti-ummati-keenya-walloo-gaafachaa-oole/" title="Yaasoo Kabbabaa haa hiikamu jechuun Eebba waajjira ABO Kamisee irratti ummati Keenya walloo gaafachaa oole! .">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Yaasoo Kabbabaa haa hiikamu jechuun Eebba waajjira ABO Kamisee irratti ummati Keenya walloo gaafachaa oole! .						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/%e1%8b%a8%e1%88%9d%e1%88%ad%e1%8c%ab-%e1%89%a6%e1%88%ad%e1%8b%b5-%e1%88%b0%e1%89%a5%e1%88%b3%e1%89%a2-%e1%8b%88-%e1%89%b5-%e1%89%a5%e1%88%ad%e1%89%b1%e1%8a%ab%e1%8a%95-%e1%88%88%e1%8a%a0%e1%8b%b5/" title="የምርጫ ቦርድ ሰብሳቢ ወ/ት ብርቱካን ለአድማጮች የሰጡት መልስ">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
የምርጫ ቦርድ ሰብሳቢ ወ/ት ብርቱካን ለአድማጮች የሰጡት መልስ						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Amharic							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/ethiopia-reflects-on-its-founding-fathers-triumphant-bloody-legacy/" title="Ethiopia Reflects On Its Founding Father&#8217;s Triumphant, Bloody Legacy">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
Ethiopia Reflects On Its Founding Father&#8217;s Triumphant, Bloody Legacy						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
Radio							</span>
</a>
</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
<a href="https://kichuu.com/dhaamsa-gabaabaa-uummata-oromoo-cufaaf-ajajaa-wbo-zoonii-kibbaatiif-qabsaaa-mirga-ilmaan-namaa-kan-taan-jaal-goollicha_dheengee_bonayyaa_i-yyaa-irraa/" title="DHAAMSA GABAABAA UUMMATA OROMOO CUFAAF AJAJAA WBO ZOONII KIBBAATIIF QABSAA&#8217;A MIRGA ILMAAN NAMAA KAN TA&#8217;AN JAAL GOOLLICHA_DHEENGEE_BONAYYAA_I YYAA IRRAA:-">
<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
[ February 8, 2020 ]                        </span>
<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
DHAAMSA GABAABAA UUMMATA OROMOO CUFAAF AJAJAA WBO ZOONII KIBBAATIIF QABSAA&#8217;A MIRGA ILMAAN NAMAA KAN TA&#8217;AN JAAL GOOLLICHA_DHEENGEE_BONAYYAA_I YYAA IRRAA:-						</span>
<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
<i class="fa fa-caret-right"></i>
News							</span>
</a>
</li>		</ul>
</div>
</div>						</div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://kichuu.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>						</aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/news/">News</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://kichuu.com/category/news/africa/" itemprop="url"><span itemprop="title">Africa</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Eritrean President: South Sudan’s separation from Sudan was a great mistake</nav>
<article id="post-64688" class="post-64688 post type-post status-publish format-standard has-post-thumbnail hentry category-africa">
<header class="entry-header clearfix"><h1 class="entry-title">Eritrean President: South Sudan’s separation from Sudan was a great mistake</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</header>
<div id="custom_html-2" class="widget_text mh-widget mh-posts-1 widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Above Single Post</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div>	<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&t=Eritrean+President%3A+South+Sudan%E2%80%99s+separation+from+Sudan+was+a+great+mistake', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Eritrean+President%3A+South+Sudan%E2%80%99s+separation+from+Sudan+was+a+great+mistake:&url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&media=https://kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg&description=Eritrean+President%3A+South+Sudan%E2%80%99s+separation+from+Sudan+was+a+great+mistake', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=Eritrean%20President%3A%20South%20Sudan%E2%80%99s%20separation%20from%20Sudan%20was%20a%20great%20mistake&amp;body=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
<div class="kichu-before-content" id="kichu-2078077486"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="4810789386" 
data-ad-format="link"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><p><strong class="mvp-post-title left entry-title">Eritrean President: South Sudan’s separation from Sudan was a <a href="https://kichuu.com/eitrean-president-back-ethiopia/" target="_blank" rel="noopener noreferrer">great mistake</a></strong></p>
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20191026 -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-6953193962442323"
data-ad-slot="2237740205"
data-ad-format="auto"
data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>By <span class="author-name vcard fn author">Omolo</span></p>
<p><img class="alignnone size-large wp-image-64689 jetpack-lazy-image" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=388%2C400&#038;ssl=1" alt width="388" height="400" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=388%2C400&amp;ssl=1 388w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=194%2C200&amp;ssl=1 194w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?w=750&amp;ssl=1 750w" data-lazy-sizes="(max-width: 388px) 100vw, 388px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=388%2C400&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-large wp-image-64689" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=388%2C400&#038;ssl=1" alt="" width="388" height="400" srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=388%2C400&amp;ssl=1 388w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?resize=194%2C200&amp;ssl=1 194w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg?w=750&amp;ssl=1 750w" sizes="(max-width: 388px) 100vw, 388px" data-recalc-dims="1" /></noscript></p>
<p>(<a href="http://jubatvm.com/2020/02/08/eritrean-president-south-sudans-cession-separation-from-sudan-was-a-great-mistake/?fbclid=IwAR3ydItTV8IF4tCPhTk1YHljw9zzH54KY24PrFZmrlGz6WTIoAbm2ZdMmKc">jubatvm</a>)&#8212;Speaking On a live interview conducted on national tv, Eritrean president Essayas Afewerki, said that South Sudan’s secession (separation) from Sudan was a grave mistake &amp; openly opposed South Sudan’s independence from Sudan.</p>
<p>He affirmed that, South Sudan should have been remained part of the greater Sudan.<br />
He said that South Sudan independence was a fabrication of the western powers against the will of the South Sudan’s people. South Sudanese people wants to remain part of Sudan.</p>
<p><strong>This man is obviously sick. His last days are now at death’s door!!</strong></p>
<hr />
<p><iframe src="https://www.youtube.com/embed/JPT4-bzzAl4" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<hr />
<p><strong>“እኔ የሚያሳስበኝ የኢትዮጵያ የውስጥ ጉዳይ ነው</strong><br />
<strong>ኢሳያስ አፈወርቂ</strong></p>
<p>የኤርትራው ፕረሲደንት ኢሳያሰ አፈወርቂ መግለጫ ተጀምሮ እስከሚያልቅ ስለ ኢትዮጵያ ብቻ ነበር::የመግለጫው ዋና ዋና ነጥቦች የሚከተሉት ናቸው::</p><div class="kichu-k20191225middle" id="kichu-1414901538"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<div class="text_exposed_show">
<p>በኢትዮጵያ ያለው ሁኔታ አስቸጋሪ ነው። የራሳቸው ጉዳይ ነው ብለን ግን እጃችን እና እግራችን አጣጥፈን አንቀመጥም።በንቁነት የምንሰራበት ጉዳይ ነው።ኢትዮጵያ በኣስቸጋሪ ሁኔታ ላይ ነው ያለችው።የብሄር ግጭት ኣለ።ለኛ አዲስ ነገር አደለም።የሚገርምም አደለም።</p>
<p>እኛ ዳግመኛ ወደ ጦርነት መግባት አንፈልግም::ነገሩ ግን የሚመጣብን ጥቃት እንከላከላን::</p>
<p>ወደ ግጭት የከተተን በኢትዮጵያ የተተከለው ብሄር መሰረት ያደረገ ፌደራላዊ ስርዓትና እሱን ተከትሎ የመጡ አስተሳሰቦች ናቸው። ከኢትዮጵያ ጋር ያጣለን የድንበር ችግር የለም። ባድመም አይደለችም።</p>
<p>ጠቅላይ ሚኒስተር አብይ አህመድ በ ኢትዮጵያ ያለው ብሄር መሰረት ያደረገ ፌደራላዊ ስርዓት ለመቀየር እየሄደበት ያለው መንገድ በጣም ጥሩ የሚባል ነው::</p>
<p>ጠቅላይ ሚኒስተር አብይ አህመድ ፈተና የሆነበት ብሄር መሰረት ያደረገ ፌደራላዊ ስርዓት ለማስቀጠል የሚፈልጉ ጃንዳ ወያነ እና ሌሎች በኢትዮጵያ ያሉት ፖለቲካ ፓርቲዎች ነው::ይህ ጃንዳ ባለፈው 20 ዓመት ይደረግ እንደነበረው አሁንም በውጭ ኃይሎች ድጋፍ እያገኘ ነው::</p>
<p>ደቡብ ሱዳን ከሱዳን መለየት አልነበረበትም::ተለይታ የተጠቀመቹ ነገር የለም::ከ ዋናው ሱዳን ጋ ብትቆይ የበለጠ ለ ሁለቱ ህዝብ ይጠቅማል::</p>
<p>በ ኢትዮጵያ ምርጫ መካየድና አለማካየድ አጀንዳ መሆን የለበትም:: በምርጫ የሚመጣ አዲስ ነገር የለም::</p>
<p>የኢትዮ -ኤርትራ ጦርነት የተነሳው በድንበር /በባድመ/ ጉዳይ አይደለም። ባድመ ጉዳያችን አልነበረም በኢትዮጵያ የነበረው ሃይል ውስጣዊ ፖለቲካቸው(ብሔር መሰረት ያደረገ )ስርዓት በመኖሩ ነው ወደ ግጭት ያስገባን ። አሁንም መሬታችን በሃይል የያዙ ወያኔዎች አሉ ነገር ግን ያለፈው ነገር ይበቃናል በማለት የባድመን ጉዳይ ለግዜው ትተን በኢትዮጵያ ውስጣዊ ሁኔታ የተከታተልን ነው ።</p>
<p>የኤርትራ ህዝብ ለስደት የተዳረገው በወያኔ ምክንያት ነው ።</p>
<p>የወያኔ ብሄርተኮር ፖለቲካ ከኢትዮጵያ እንዲወገድ አብይ የጀመረው ስራ አለ እኛም እንደግፈዋለን ።”</p>
<p>ከትላንቱ ቃለመጠይቁ የተወሰደ</p>
</div>
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="kichu-k20191225below" id="kichu-1288376926"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6953193962442323" 
data-ad-slot="" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&t=Eritrean+President%3A+South+Sudan%E2%80%99s+separation+from+Sudan+was+a+great+mistake', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Eritrean+President%3A+South+Sudan%E2%80%99s+separation+from+Sudan+was+a+great+mistake:&url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F&media=https://kichuu.com/wp-content/uploads/2020/02/1D5299C1-98C5-4AC5-A3B9-94181FED5D69.jpeg&description=Eritrean+President%3A+South+Sudan%E2%80%99s+separation+from+Sudan+was+a+great+mistake', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
</a>
<a class="mh-email" href="mailto:?subject=Eritrean%20President%3A%20South%20Sudan%E2%80%99s%20separation%20from%20Sudan%20was%20a%20great%20mistake&amp;body=https%3A%2F%2Fkichuu.com%2Feritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake%2F" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
</div><div id="text-3" class="mh-widget mh-posts-2 widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Below Single Post</span></h4>			<div class="textwidget"><p><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></p>
</div>
</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/abon-magaalaa-baakkootti-uummata-waliin-marii-balaa-gaggeeffate-gufuunis-mudate/" rel="prev"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-12-2-e1581204295325.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="ABO&#039;n magaalaa Baakkootti" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-12-2-e1581204295325.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Previous</span><p>ABO&#8217;n magaalaa Baakkootti uummata waliin marii bal&#8217;aa gaggeeffate! Gufuunis mudate</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://kichuu.com/eritrea-the-trump-administration-has-confirmed-visa-bans-on-four-african-countries-including-nigeria/" rel="next"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/Trump-and-Sondland-e1581209682258.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Eritrea" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/Trump-and-Sondland-e1581209682258.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/Trump-and-Sondland-e1581209682258.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/Trump-and-Sondland-e1581209682258.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span>Next</span><p>Eritrea: The Trump administration has confirmed visa bans on four African countries, including Nigeria</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment				</span>
</h4>	<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='64688' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="80daeae782" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="26"/></p></form>	</div><!-- #respond -->
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-64607 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation."><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Human Rights" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/02/omrho26.png?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">
Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation. Click here to download in PDF OMRHO  presents the state of Human Rights in Ethiopia since the incumbent <a class="mh-excerpt-more" href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-63213 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps"><img width="326" height="245" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Autocrat" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/abiy-ahmed-800x445-1.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">
Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 9, 2020</a></span>
</div>
</div>
<div class="mh-excerpt">Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps By Jabessa Gurmessa, Finfinne, Oromia, January 09, 2020 1. Introduction The freedom lovers and proponents <a class="mh-excerpt-more" href="https://kichuu.com/abiy-ahmeds-plan-to-become-an-autocrat-and-plot-to-kill-the-fdre-constitution-reflection-on-his-measures-and-steps/" title="Abiy Ahmed’s Plan to Become an Autocrat and Plot to Kill the FDRE Constitution: Reflection on His Measures and Steps">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62609 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Gammaachuu Ayaanaa Gemechu" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/12/81106968_2062039637232933_4429971814763986944_n.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit">
Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit By Worku Burayu (PhD), January 1, 2020 During the times of apartheid, it was said that some prisons reached almost 200% of what the prison was built to hold. The exact copy of <a class="mh-excerpt-more" href="https://kichuu.com/prisons-that-held-gemechu-ayana-cant-crush-self-determinations-spirit/" title="Prisons that Held Gemechu Ayana Can’t Crush Self-Determination&#8217;s Spirit">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62599 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama"><img width="326" height="245" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Berhanu Nega" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?zoom=2&amp;resize=326%2C245&amp;ssl=1 652w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/12/berhanu_nega.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama">
EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama By Guluma Gemeda,  Ph.D., December 31, 2019 Dr. Berhanu Nega, leader of the Ethiopian Citizens for Social Justice (EZEMA) party, made a <a class="mh-excerpt-more" href="https://kichuu.com/ezema-is-a-federalist-party-comments-on-dr-berhanu-negas-speech-in-adama/" title="EZEMA is a Federalist Party? Comments on Dr. Berhanu Nega’s Speech in Adama">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-62290 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="IRBUU Struggle" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/03/wbo2.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">
Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/12/">December 26, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa By Bilisummaa Jaalataa, December 26, 2019 Like all African countries, the Oromo (hereafter We/Our/Us) were colonized in the last quarter of the <a class="mh-excerpt-more" href="https://kichuu.com/our-struggle-our-sacrifices-our-last-option-the-need-to-reignite-fincila-bilisummaa/" title="Our Struggle, Our Sacrifices, Our Last Option: The Need to Reignite Fincila Bilisummaa">[Read More]</a></div>								</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-59364 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY"><img width="326" height="245" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="Finfinnee" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/10/finfinnee.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />										</a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">
TEN POINTS WHY FINFINNEE IS OROMO CITY											</a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/10/">October 28, 2019</a></span>
</div>
</div>
<div class="mh-excerpt">TEN POINTS WHY FINFINNEE IS OROMO CITY BY Worku Gadissa, October 29, 1019 Note: Sheger is another name for Finfinnee and both name are used in this article. We are all aware of present highly <a class="mh-excerpt-more" href="https://kichuu.com/ten-points-why-finfinnee-is-oromo-city/" title="TEN POINTS WHY FINFINNEE IS OROMO CITY">[Read More]</a></div>								</div>
</div>
</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64703 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%88%9a%e1%88%8a%e1%89%b0%e1%88%aa%e1%8b%9d%e1%88%9d-%e1%88%88%e1%8a%a2%e1%89%b5%e1%8b%ae%e1%8c%b5%e1%8b%ab%e1%8a%a0%e1%88%81%e1%8a%95-%e1%8a%a0%e1%88%81%e1%8a%95-%e1%8a%a5%e1%8b%ab%e1%88%b5/" title="ሚሊተሪዝም ለኢትዮጵያ?አሁን አሁን እያስተዋልን ያለነው አብይ አህመድ የመንግሥቱ ኃይለማርያምን ዱካ እየተከተለ መምጣቱን ነው።">
ሚሊተሪዝም ለኢትዮጵያ?አሁን አሁን እያስተዋልን ያለነው አብይ አህመድ የመንግሥቱ ኃይለማርያምን ዱካ እየተከተለ መምጣቱን ነው።									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64699 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/eritrea-the-trump-administration-has-confirmed-visa-bans-on-four-african-countries-including-nigeria/" title="Eritrea: The Trump administration has confirmed visa bans on four African countries, including Nigeria">
Eritrea: The Trump administration has confirmed visa bans on four African countries, including Nigeria									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64688 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/eritrean-president-south-sudans-separation-from-sudan-was-a-great-mistake/" title="Eritrean President: South Sudan’s separation from Sudan was a great mistake">
Eritrean President: South Sudan’s separation from Sudan was a great mistake									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64684 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/abon-magaalaa-baakkootti-uummata-waliin-marii-balaa-gaggeeffate-gufuunis-mudate/" title="ABO&#8217;n magaalaa Baakkootti uummata waliin marii bal&#8217;aa gaggeeffate! Gufuunis mudate">
ABO&#8217;n magaalaa Baakkootti uummata waliin marii bal&#8217;aa gaggeeffate! Gufuunis mudate									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64680 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/breakin-news-salphinni-abiy-haamidifi-bilxiginnaa-akkuma-itti-fufeetti-jira/" title="Breakin News: Salphinni Abiy haamidifi Bilxiginnaa akkuma itti fufeetti jira!">
Breakin News: Salphinni Abiy haamidifi Bilxiginnaa akkuma itti fufeetti jira!									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64675 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/isaayaas-afawarqii-laft-eeritiraa-kan-hin-deebiiin-hafee-diddaa-tplftiin/" title="Isaayaas Afawarqii: &#8220;Laft Eeritiraa kan hin deebi&#8217;iin hafee diddaa TPLF&#8217;tiin&#8221;">
Isaayaas Afawarqii: &#8220;Laft Eeritiraa kan hin deebi&#8217;iin hafee diddaa TPLF&#8217;tiin&#8221;									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64670 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/yaasoo-kabbabaa-haa-hiikamu-jechuun-eebba-waajjira-abo-kamisee-irratti-ummati-keenya-walloo-gaafachaa-oole/" title="Yaasoo Kabbabaa haa hiikamu jechuun Eebba waajjira ABO Kamisee irratti ummati Keenya walloo gaafachaa oole! .">
Yaasoo Kabbabaa haa hiikamu jechuun Eebba waajjira ABO Kamisee irratti ummati Keenya walloo gaafachaa oole! .									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64665 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8b%a8%e1%88%9d%e1%88%ad%e1%8c%ab-%e1%89%a6%e1%88%ad%e1%8b%b5-%e1%88%b0%e1%89%a5%e1%88%b3%e1%89%a2-%e1%8b%88-%e1%89%b5-%e1%89%a5%e1%88%ad%e1%89%b1%e1%8a%ab%e1%8a%95-%e1%88%88%e1%8a%a0%e1%8b%b5/" title="የምርጫ ቦርድ ሰብሳቢ ወ/ት ብርቱካን ለአድማጮች የሰጡት መልስ">
የምርጫ ቦርድ ሰብሳቢ ወ/ት ብርቱካን ለአድማጮች የሰጡት መልስ									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64660 post type-post status-publish format-standard has-post-thumbnail category-radio">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-reflects-on-its-founding-fathers-triumphant-bloody-legacy/" title="Ethiopia Reflects On Its Founding Father&#8217;s Triumphant, Bloody Legacy">
Ethiopia Reflects On Its Founding Father&#8217;s Triumphant, Bloody Legacy									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64657 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/dhaamsa-gabaabaa-uummata-oromoo-cufaaf-ajajaa-wbo-zoonii-kibbaatiif-qabsaaa-mirga-ilmaan-namaa-kan-taan-jaal-goollicha_dheengee_bonayyaa_i-yyaa-irraa/" title="DHAAMSA GABAABAA UUMMATA OROMOO CUFAAF AJAJAA WBO ZOONII KIBBAATIIF QABSAA&#8217;A MIRGA ILMAAN NAMAA KAN TA&#8217;AN JAAL GOOLLICHA_DHEENGEE_BONAYYAA_I YYAA IRRAA:-">
DHAAMSA GABAABAA UUMMATA OROMOO CUFAAF AJAJAA WBO ZOONII KIBBAATIIF QABSAA&#8217;A MIRGA ILMAAN NAMAA KAN TA&#8217;AN JAAL GOOLLICHA_DHEENGEE_BONAYYAA_I YYAA IRRAA:-									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64654 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/%e1%8b%a8%e1%88%b2%e1%8b%b3%e1%88%9b-%e1%89%b3%e1%8c%8b%e1%8b%ae%e1%89%bd%e1%8a%95-%e1%88%88%e1%88%9b%e1%88%b0%e1%88%ad-%e1%8b%a8%e1%8b%88%e1%8c%a3%e1%8b%8d-%e1%89%b5%e1%8b%95%e1%8b%9b%e1%8b%9d/" title="የሲዳማ ታጋዮችን ለማሰር የወጣው ትዕዛዝ በተወሰኑ አመራሮች አለመግባባት ተቀልብሷል!!">
የሲዳማ ታጋዮችን ለማሰር የወጣው ትዕዛዝ በተወሰኑ አመራሮች አለመግባባት ተቀልብሷል!!									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64640 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/today-wolayta-sodo-is-hosting-outstanding-politicians-in-ethiopia-professor-merera-gudina-and-professor-beyene-petros/" title="Today, Wolayta Sodo is hosting outstanding politicians in Ethiopia, Professor Merera Gudina and Professor Beyene Petros.">
Today, Wolayta Sodo is hosting outstanding politicians in Ethiopia, Professor Merera Gudina and Professor Beyene Petros.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64637 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/nobody-respects-oromiyaas-constitution-the-opposition-and-government/" title="Nobody respects Oromiyaa&#8217;s constitution, the opposition and government.">
Nobody respects Oromiyaa&#8217;s constitution, the opposition and government.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64607 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/human-rights-abuses-committed-by-the-ethiopian-army-in-different-parts-of-ethiopia-needs-urgent-independent-international-investigation/" title="Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.">
Human Rights Abuses Committed by the Ethiopian Army in Different Parts of Ethiopia.Needs Urgent independent international Investigation.									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64600 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/sirna-baniinsa-waajjira-abo-wallo-magaalaa-kamiseetti/" title="Sirna baniinsa waajjira ABO &#8211; Wallo, magaalaa Kamiseetti">
Sirna baniinsa waajjira ABO &#8211; Wallo, magaalaa Kamiseetti									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 8, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64597 post type-post status-publish format-standard has-post-thumbnail category-africa">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/struggle-whose-finishing-is-messed-up-qabsoo-xumura-badde/" title="Struggle Whose Finishing is Messed up | Qabsoo Xumura Badde">
Struggle Whose Finishing is Messed up | Qabsoo Xumura Badde									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 7, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64592 post type-post status-publish format-standard has-post-thumbnail category-health">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/weerarri-gifiraa-godinaalee-oromiyaa-keessatti-yoo-xiqqaate-namoota-kuma-shan-qabe-biiroon-fayyaa-naannichaa/" title="Weerarri Gifiraa Godinaalee Oromiyaa Keessatti Yoo Xiqqaate Namoota Kuma Shan Qabe, Biiroon Fayyaa Naannichaa">
Weerarri Gifiraa Godinaalee Oromiyaa Keessatti Yoo Xiqqaate Namoota Kuma Shan Qabe, Biiroon Fayyaa Naannichaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 7, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64589 post type-post status-publish format-standard has-post-thumbnail category-world">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/trudeau-lands-in-ethiopia-where-he-will-head-to-the-african-union/" title="Trudeau lands in Ethiopia, where he will head to the African Union">
Trudeau lands in Ethiopia, where he will head to the African Union									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 7, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64585 post type-post status-publish format-standard has-post-thumbnail category-videos">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/omn-turtii-jawaar-mahammad-waliin-gur-07-2020/" title="OMN: Turtii Jawaar Mahammad Waliin (Gur. 07, 2020 )">
OMN: Turtii Jawaar Mahammad Waliin (Gur. 07, 2020 )									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 7, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64582 post type-post status-publish format-standard has-post-thumbnail category-amharic">
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/omn%e1%88%8d%e1%8b%a9-%e1%8b%9d%e1%8c%8d%e1%8c%85%e1%89%b5%e1%8d%a5-%e1%89%86%e1%8b%ad%e1%89%b3-%e1%8a%a8%e1%8a%a2%e1%89%b5%e1%8b%ae%e1%8c%b5%e1%8b%ab-%e1%88%9d%e1%88%ad%e1%8c%ab-%e1%89%a6%e1%88%ad/" title="OMN: ልዩ ዝግጅት፥  ቆይታ ከኢትዮጵያ ምርጫ ቦርድ ሊቀመንበር ብርቱካን ሚደቅሳ ጋር (Feb. 07, 2020)">
OMN: ልዩ ዝግጅት፥  ቆይታ ከኢትዮጵያ ምርጫ ቦርድ ሊቀመንበር ብርቱካን ሚደቅሳ ጋር (Feb. 07, 2020)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 7, 2020</a></span>
</div>
</div>
</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
<select id="archives-dropdown-2" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://kichuu.com/2020/02/'> February 2020 </option>
<option value='https://kichuu.com/2020/01/'> January 2020 </option>
<option value='https://kichuu.com/2019/12/'> December 2019 </option>
<option value='https://kichuu.com/2019/11/'> November 2019 </option>
<option value='https://kichuu.com/2019/10/'> October 2019 </option>
<option value='https://kichuu.com/2019/09/'> September 2019 </option>
<option value='https://kichuu.com/2019/08/'> August 2019 </option>
<option value='https://kichuu.com/2019/07/'> July 2019 </option>
<option value='https://kichuu.com/2019/06/'> June 2019 </option>
<option value='https://kichuu.com/2019/05/'> May 2019 </option>
<option value='https://kichuu.com/2019/04/'> April 2019 </option>
<option value='https://kichuu.com/2019/03/'> March 2019 </option>
<option value='https://kichuu.com/2019/02/'> February 2019 </option>
<option value='https://kichuu.com/2019/01/'> January 2019 </option>
<option value='https://kichuu.com/2018/12/'> December 2018 </option>
<option value='https://kichuu.com/2018/11/'> November 2018 </option>
<option value='https://kichuu.com/2018/10/'> October 2018 </option>
<option value='https://kichuu.com/2018/09/'> September 2018 </option>
<option value='https://kichuu.com/2018/08/'> August 2018 </option>
<option value='https://kichuu.com/2018/07/'> July 2018 </option>
<option value='https://kichuu.com/2018/06/'> June 2018 </option>
<option value='https://kichuu.com/2018/05/'> May 2018 </option>
<option value='https://kichuu.com/2018/04/'> April 2018 </option>
<option value='https://kichuu.com/2018/03/'> March 2018 </option>
<option value='https://kichuu.com/2018/02/'> February 2018 </option>
<option value='https://kichuu.com/2018/01/'> January 2018 </option>
<option value='https://kichuu.com/2017/12/'> December 2017 </option>
<option value='https://kichuu.com/2017/11/'> November 2017 </option>
<option value='https://kichuu.com/2017/10/'> October 2017 </option>
<option value='https://kichuu.com/2017/09/'> September 2017 </option>
<option value='https://kichuu.com/2017/08/'> August 2017 </option>
<option value='https://kichuu.com/2017/07/'> July 2017 </option>
<option value='https://kichuu.com/2017/06/'> June 2017 </option>
<option value='https://kichuu.com/2017/05/'> May 2017 </option>
<option value='https://kichuu.com/2017/04/'> April 2017 </option>
<option value='https://kichuu.com/2017/03/'> March 2017 </option>
<option value='https://kichuu.com/2017/02/'> February 2017 </option>
<option value='https://kichuu.com/2017/01/'> January 2017 </option>
<option value='https://kichuu.com/2016/12/'> December 2016 </option>
<option value='https://kichuu.com/2016/11/'> November 2016 </option>
<option value='https://kichuu.com/2013/11/'> November 2013 </option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
var dropdown = document.getElementById( "archives-dropdown-2" );
function onSelectChange() {
if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
document.location.href = this.options[ this.selectedIndex ].value;
}
}
dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
<div class="mh-video-container">
<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
</div>
</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
<caption>February 2020</caption>
<thead>
<tr>
<th scope="col" title="Monday">M</th>
<th scope="col" title="Tuesday">T</th>
<th scope="col" title="Wednesday">W</th>
<th scope="col" title="Thursday">T</th>
<th scope="col" title="Friday">F</th>
<th scope="col" title="Saturday">S</th>
<th scope="col" title="Sunday">S</th>
</tr>
</thead>
<tfoot>
<tr>
<td colspan="3" id="prev"><a href="https://kichuu.com/2020/01/">&laquo; Jan</a></td>
<td class="pad">&nbsp;</td>
<td colspan="3" id="next" class="pad">&nbsp;</td>
</tr>
</tfoot>
<tbody>
<tr>
<td colspan="5" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2020/02/01/" aria-label="Posts published on February 1, 2020">1</a></td><td><a href="https://kichuu.com/2020/02/02/" aria-label="Posts published on February 2, 2020">2</a></td>
</tr>
<tr>
<td><a href="https://kichuu.com/2020/02/03/" aria-label="Posts published on February 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/02/04/" aria-label="Posts published on February 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/02/05/" aria-label="Posts published on February 5, 2020">5</a></td><td><a href="https://kichuu.com/2020/02/06/" aria-label="Posts published on February 6, 2020">6</a></td><td><a href="https://kichuu.com/2020/02/07/" aria-label="Posts published on February 7, 2020">7</a></td><td id="today"><a href="https://kichuu.com/2020/02/08/" aria-label="Posts published on February 8, 2020">8</a></td><td>9</td>
</tr>
<tr>
<td>10</td><td>11</td><td>12</td><td>13</td><td>14</td><td>15</td><td>16</td>
</tr>
<tr>
<td>17</td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td>
</tr>
<tr>
<td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td>
<td class="pad" colspan="1">&nbsp;</td>
</tr>
</tbody>
</table></div></div>	</aside>	</div>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64592 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/weerarri-gifiraa-godinaalee-oromiyaa-keessatti-yoo-xiqqaate-namoota-kuma-shan-qabe-biiroon-fayyaa-naannichaa/" title="Weerarri Gifiraa Godinaalee Oromiyaa Keessatti Yoo Xiqqaate Namoota Kuma Shan Qabe, Biiroon Fayyaa Naannichaa"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/02/DBDA6B09-7B7C-4E26-954A-5593A50491B0_cx16_cy6_cw84_w1023_r1_s-e1581114803164.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Gifiraa Godinaalee Oromiyaa" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/02/DBDA6B09-7B7C-4E26-954A-5593A50491B0_cx16_cy6_cw84_w1023_r1_s-e1581114803164.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/02/DBDA6B09-7B7C-4E26-954A-5593A50491B0_cx16_cy6_cw84_w1023_r1_s-e1581114803164.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/02/DBDA6B09-7B7C-4E26-954A-5593A50491B0_cx16_cy6_cw84_w1023_r1_s-e1581114803164.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/weerarri-gifiraa-godinaalee-oromiyaa-keessatti-yoo-xiqqaate-namoota-kuma-shan-qabe-biiroon-fayyaa-naannichaa/" title="Weerarri Gifiraa Godinaalee Oromiyaa Keessatti Yoo Xiqqaate Namoota Kuma Shan Qabe, Biiroon Fayyaa Naannichaa">
Weerarri Gifiraa Godinaalee Oromiyaa Keessatti Yoo Xiqqaate Namoota Kuma Shan Qabe, Biiroon Fayyaa Naannichaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 7, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64239 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/how-african-countries-are-responding-to-coronavirus/" title="How African countries are responding to Coronavirus"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_1007105-e1580479151845.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Coronavirus" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_1007105-e1580479151845.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_1007105-e1580479151845.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/1024x576_1007105-e1580479151845.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/how-african-countries-are-responding-to-coronavirus/" title="How African countries are responding to Coronavirus">
How African countries are responding to Coronavirus									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 31, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64060 post type-post status-publish format-standard has-post-thumbnail category-health">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-begins-airport-screening-against-china-virus/" title="Ethiopia begins airport screening against China virus"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-21-4-e1580055740549.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="China virus" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-21-4-e1580055740549.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/ethiopia-begins-airport-screening-against-china-virus/" title="Ethiopia begins airport screening against China virus">
Ethiopia begins airport screening against China virus									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 26, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Mohammed Hajjii" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2019/07/Untitled-2.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-50318 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2019/04/robe-e1556371718277.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/funny-afaan-oromo-brain-teasers-questions-and-answers/" title="Funny Afaan Oromo Brain Teasers Questions and Answers">
Funny Afaan Oromo Brain Teasers Questions and Answers									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/04/">April 27, 2019</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64343 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/new-oromo-music-bilsigina-diina-kenyaa-2020-ofk-dhaba-kenya-walisa-abdi-fadis/" title="New Oromo Music Bilsigina Diina Kenyaa 2020 OFK Dhaba Kenya Walisa Abdi Fadis"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-4-1-e1580647503244.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Bilsigina" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/02/pizap-4-1-e1580647503244.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/new-oromo-music-bilsigina-diina-kenyaa-2020-ofk-dhaba-kenya-walisa-abdi-fadis/" title="New Oromo Music Bilsigina Diina Kenyaa 2020 OFK Dhaba Kenya Walisa Abdi Fadis">
New Oromo Music Bilsigina Diina Kenyaa 2020 OFK Dhaba Kenya Walisa Abdi Fadis									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/02/">February 2, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64218 post type-post status-publish format-standard has-post-thumbnail category-musics">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/yosan-getahun-waatu-jira-waatu-new-ethiopian-oromo-music-2020-official-video/" title="Yosan Getahun &#8211; Waatu Jira Waatu New Ethiopian Oromo music 2020 (Official Video)"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-16-8-e1580416908617.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Yosan Getahun" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/pizap-16-8-e1580416908617.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/yosan-getahun-waatu-jira-waatu-new-ethiopian-oromo-music-2020-official-video/" title="Yosan Getahun &#8211; Waatu Jira Waatu New Ethiopian Oromo music 2020 (Official Video)">
Yosan Getahun &#8211; Waatu Jira Waatu New Ethiopian Oromo music 2020 (Official Video)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 30, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63722 post type-post status-publish format-standard has-post-thumbnail category-musics category-videos">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/yanet-dinku-falmii-koo-new-oromo-music-2020-official-video/" title="Yanet Dinku Falmii Koo New Oromo Music 2020 (Official Video)"><img width="80" height="60" src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/yes2-2.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Yanet Dinku" data-lazy-srcset="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/yes2-2.png?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/yes2-2.png?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/yes2-2.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/yes2-2.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/kichuu.com/wp-content/uploads/2020/01/yes2-2.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/yanet-dinku-falmii-koo-new-oromo-music-2020-official-video/" title="Yanet Dinku Falmii Koo New Oromo Music 2020 (Official Video)">
Yanet Dinku Falmii Koo New Oromo Music 2020 (Official Video)									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 20, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64154 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/u-s-assistant-secretary-concludes-visit-to-ethiopia/" title="U.S. Assistant Secretary concludes visit to Ethiopia"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/NagyinSA-e1580229243125.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="U.S. Assistant Secretar" data-lazy-srcset="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/NagyinSA-e1580229243125.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/NagyinSA-e1580229243125.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/NagyinSA-e1580229243125.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/u-s-assistant-secretary-concludes-visit-to-ethiopia/" title="U.S. Assistant Secretary concludes visit to Ethiopia">
U.S. Assistant Secretary concludes visit to Ethiopia									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 28, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-64143 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/privatisations-in-ethiopia-could-mtn-pull-off-a-surprise/" title="Privatisations in Ethiopia: could MTN pull off a surprise?"><img width="80" height="60" src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/RTX6YCWC-e1580226525464.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="MTN" data-lazy-srcset="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/RTX6YCWC-e1580226525464.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/RTX6YCWC-e1580226525464.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/kichuu.com/wp-content/uploads/2020/01/RTX6YCWC-e1580226525464.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/privatisations-in-ethiopia-could-mtn-pull-off-a-surprise/" title="Privatisations in Ethiopia: could MTN pull off a surprise?">
Privatisations in Ethiopia: could MTN pull off a surprise?									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 28, 2020</a></span>
</div>
</div>
</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-63881 post type-post status-publish format-standard has-post-thumbnail category-business">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/abiys-ethiopia-not-quite-an-indian-summer/" title="Abiy’s Ethiopia not quite an Indian summer"><img width="80" height="60" src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/unnamed-e1580050436909.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="Ethiopian prime minister." data-lazy-src="https://i1.wp.com/kichuu.com/wp-content/uploads/2020/01/unnamed-e1580050436909.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />									</a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://kichuu.com/abiys-ethiopia-not-quite-an-indian-summer/" title="Abiy’s Ethiopia not quite an Indian summer">
Abiy’s Ethiopia not quite an Indian summer									</a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/01/">January 23, 2020</a></span>
</div>
</div>
</li>			</ul></div></div>
</div>
</footer>
<div class="mh-footer-nav-mobile"></div>
<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-container mh-container-inner clearfix">
<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
</nav>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright @2016 kichuu.com              		</p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-58166095-1', 'auto');
ga('send', 'pageview');
</script>			<div id="fb-root"></div>
<script>
(function(d, s, id){
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://kichuu.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://kichuu.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202006.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'111820558',post:'64688',tz:'-4',srv:'kichuu.com'} ]);
_stq.push([ 'clickTrackerInit', '111820558', '64688' ]);
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.662806987762 seconds, on 08-02-20 21:32:51 -->