<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head><style>img.lazy{min-height:1px}</style><link rel="preload" href="https://kichuu.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js" as="script">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Coronavirus: Ethiopia Country Office – Humanitarian Situation Report &#x2d; Kichuu</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="robots" content="max-snippet:-1,max-image-preview:standard,max-video-preview:-1" />
<meta name="description" content="Ethiopia’s humanitarian situation became increasingly precarious in April and May 2020 due to increased spread of COVID&#x2d;19, cholera and measles outbreaks" />
<meta property="og:image" content="https://kichuu.com/wp-content/uploads/2020/08/unnamed-e1597675623887.jpg" />
<meta property="og:image:width" content="700" />
<meta property="og:image:height" content="700" />
<meta property="og:image:alt" content="Humanitarian Situation Report" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Coronavirus: Ethiopia Country Office – Humanitarian Situation Report &#x2d; Kichuu" />
<meta property="og:description" content="Ethiopia’s humanitarian situation became increasingly precarious in April and May 2020 due to increased spread of COVID&#x2d;19, cholera and measles outbreaks" />
<meta property="og:url" content="https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/" />
<meta property="og:site_name" content="Kichuu" />
<meta property="article:published_time" content="2020-08-17T14:48+00:00" />
<meta property="article:modified_time" content="2020-08-17T14:48+00:00" />
<meta property="og:updated_time" content="2020-08-17T14:48+00:00" />
<link rel="canonical" href="https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://kichuu.com/","name":"Kichuu is an online news publisher focusing on East Africa"}},{"@type":"ListItem","position":2,"item":{"@id":"https://kichuu.com/category/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@id":"https://kichuu.com/category/news/africa/","name":"Africa"}},{"@type":"ListItem","position":4,"item":{"@id":"https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/","name":"Coronavirus: Ethiopia Country Office \u2013 Humanitarian Situation Report"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 2.98ms meta | 83.98ms boot -->

<link rel="amphtml" href="https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/amp/" /><meta name="generator" content="AMP for WP 1.0.62.1"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Feed" href="https://kichuu.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Comments Feed" href="https://kichuu.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kichuu &raquo; Coronavirus: Ethiopia Country Office – Humanitarian Situation Report Comments Feed" href="https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/feed/" />
<link rel="stylesheet" href="https://kichuu.com/wp-content/cache/minify/45b8c.css" media="all" />





<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather:300,400,400italic,600,700' type='text/css' media='all' />
<script src="https://kichuu.com/wp-content/cache/minify/1edfa.js"></script>


<link rel="https://api.w.org/" href="https://kichuu.com/wp-json/" /><link rel="alternate" type="application/json" href="https://kichuu.com/wp-json/wp/v2/posts/76744" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kichuu.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kichuu.com/wp-includes/wlwmanifest.xml" /> 
<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://kichuu.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">.flex-direction-nav { display: none; }</style><style type="text/css">
.entry-content { font-size: 13px; font-size: 0.8125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Merriweather", serif; }
body { font-family: "Merriweather", serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e5e4e2; }
</style>
	<link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_icon1-2-270x270.png" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-76744 single-format-standard custom-background wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout3 mh-widget-layout3 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
							<div class="menu-top_menu-container"><ul id="menu-top_menu" class="menu"><li id="menu-item-348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-348"><a href="https://kichuu.com/category/business/">Business</a></li>
<li id="menu-item-769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-769"><a href="https://kichuu.com/category/fun-videos/">Fun Videos</a></li>
<li id="menu-item-18338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18338"><a href="https://kichuu.com/category/photo-gallery/">Photo Gallery</a></li>
<li id="menu-item-12292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12292"><a href="http://ayyaantuu.org">Ayyaantuu</a></li>
<li id="menu-item-21746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21746"><a href="https://kichuu.com/category/chronicles-page/">Odaa Post</a></li>
<li id="menu-item-60450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60450"><a href="https://kichuu.com/contact-us/">Contact us</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-top">
							<form role="search" method="get" class="search-form" action="https://kichuu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<a href="https://kichuu.com/" class="custom-logo-link" rel="home"><img width="331" height="81" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20331%2081'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png" class="custom-logo lazy" alt="Kichuu" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1.png 331w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-300x73.png 300w, https://kichuu.com/wp-content/uploads/2016/11/cropped-kichuu_headerlogo1-1-326x81.png 326w" data-sizes="(max-width: 331px) 100vw, 331px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-6" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ads20171214 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3403389782"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
			<div class="menu-main_menu-container"><ul id="menu-main_menu" class="menu"><li id="menu-item-48174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
	<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li id="menu-item-18343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
	<li id="menu-item-18358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
	<li id="menu-item-18359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
	<li id="menu-item-18360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
	<li id="menu-item-18362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-18351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
	<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
	<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li id="menu-item-764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/pm-abiy-ahmed-health-is-a-basic-human-right/" title="#PM Abiy Ahmed: Health is a basic human right!">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							#PM Abiy Ahmed: Health is a basic human right!						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Health							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/freeoromia-freeoromoprisoners-oromoprotests/" title="#FreeOromia #FreeOromoPrisoners #OromoProtests">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							#FreeOromia #FreeOromoPrisoners #OromoProtests						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																World							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/bb-obbo-jawar-mohammed-mana-hidhaa-keessatti-dhukkubsatan/" title="BB$: Obbo Jawar Mohammed mana hidhaa keessatti dhukkubsatan">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							BB$: Obbo Jawar Mohammed mana hidhaa keessatti dhukkubsatan						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/" title="Coronavirus: Ethiopia Country Office – Humanitarian Situation Report">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Coronavirus: Ethiopia Country Office – Humanitarian Situation Report						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/itoophiyaa-humni-addaa-yaaddoomoo-wabii-nageenya-naannooleetii/" title="Itoophiyaa: Humni addaa yaaddoomoo wabii nageenya naannooleetii?">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Itoophiyaa: Humni addaa yaaddoomoo wabii nageenya naannooleetii?						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/the-attack-on-oromo-nation-by-the-ethiopian-government-is-an-attack-on-all-historically-subjugated-nations-in-ethiopia/" title="The Attack On Oromo Nation By The Ethiopian Government Is An Attack On All Historically Subjugated Nations In Ethiopia!">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							The Attack On Oromo Nation By The Ethiopian Government Is An Attack On All Historically Subjugated Nations In Ethiopia!						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/the-nobel-peace-prize-winner-abiy-ahmed-is-a-kingpin-of-violence-and-terror/" title="The Nobel peace prize winner( Abiy Ahmed) is a kingpin of violence and terror!">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							The Nobel peace prize winner( Abiy Ahmed) is a kingpin of violence and terror!						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																News							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/odeeffannoo-dharaa-hd-abo-ilaalchisee-facaafamaa-jiru-irratti-ibsa-abo/" title="Odeeffannoo Dharaa HD ABO Ilaalchisee Facaafamaa Jiru Irratti Ibsa ABO">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 16, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Odeeffannoo Dharaa HD ABO Ilaalchisee Facaafamaa Jiru Irratti Ibsa ABO						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/kmn%e1%8c%89%e1%8b%b3%e1%8b%ab%e1%89%bd%e1%8a%95-%e1%8b%a8%e1%88%85%e1%8b%88%e1%88%93%e1%89%b5-%e1%88%b5%e1%88%ab-%e1%8a%a0%e1%88%b0%e1%8d%88%e1%8d%83%e1%88%9a-%e1%8a%a0%e1%89%a3%e1%88%8d-%e1%8a%a5/" title="KMN:#ጉዳያችን የህወሓት ስራ አሰፈፃሚ አባል እና የትግራይ ክልል አማካሪ ከሆኑት አቶ ጌታቸዉ ረዳ ጋር የተደረገ ዉይይት።">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 16, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							KMN:#ጉዳያችን የህወሓት ስራ አሰፈፃሚ አባል እና የትግራይ ክልል አማካሪ ከሆኑት አቶ ጌታቸዉ ረዳ ጋር የተደረገ ዉይይት።						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Amharic							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://kichuu.com/breaking-namooti-bor-galmee-jawaarffaa-irratti-ragaa-bahan-hara-leenjii-osoo-fudhatanii-qeerroon-qabee-jira/" title="breaking! Namooti bor galmee Jawaarffaa irratti ragaa bahan har&#8217;a leenjii osoo fudhatanii qeerroon qabee jira.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ August 16, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							breaking! Namooti bor galmee Jawaarffaa irratti ragaa bahan har&#8217;a leenjii osoo fudhatanii qeerroon qabee jira.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Africa							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://kichuu.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://kichuu.com/category/news/">News</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://kichuu.com/category/news/africa/" itemprop="item"><span itemprop="name">Africa</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Coronavirus: Ethiopia Country Office – Humanitarian Situation Report</nav>
<article id="post-76744" class="post-76744 post type-post status-publish format-standard has-post-thumbnail hentry category-africa">
	<header class="entry-header clearfix"><h1 class="entry-title">Coronavirus: Ethiopia Country Office – Humanitarian Situation Report</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F&t=Coronavirus%3A+Ethiopia+Country+Office+%E2%80%93+Humanitarian+Situation+Report', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Coronavirus%3A+Ethiopia+Country+Office+%E2%80%93+Humanitarian+Situation+Report:&url=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F&media=https://kichuu.com/wp-content/uploads/2020/08/unnamed-e1597675623887.jpg&description=Coronavirus%3A+Ethiopia+Country+Office+%E2%80%93+Humanitarian+Situation+Report', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Coronavirus%3A%20Ethiopia%20Country%20Office%20%E2%80%93%20Humanitarian%20Situation%20Report&amp;body=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
<h3><strong>Coronavirus: Ethiopia Country Office – Humanitarian Situation Report</strong></h3>
<p><em>Content provided by APO Group. <a href="https://www.cnbcafrica.com/africa-press-office/2020/08/17/coronavirus-ethiopia-country-office-humanitarian-situation-report/">CNBC Africa</a> provides content from APO Group as a service to its readers, but does not edit the articles it publishes. CNBC Africa is not responsible for the content provided by APO Group.</em></p>
<div class="mh-content-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- k20200225 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3156329304"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Highlights</p>
<p>Ethiopia’s humanitarian situation became increasingly precarious in April and May 2020 due to increased spread of COVID-19, cholera and measles outbreaks, decimation of food crops by locusts, and flooding.</p>
<p>Nearly 320,000 people in seven regions have received non-food items through UNICEF support to Regional Water Bureaus (RWBs). The assistance reached internally displaced persons (IDPs), returnees, communities vulnerable to COVID-19, COVID-19 treatment and isolation centers and communities affected by flooding and cholera.</p>
<p>The humanitarian response has become more difficult to deliver due to access constraints arising from COVID-19 travel restrictions and the need for Personal Protective Equipment (PPE) to deliver services and support safely</p>
<p>Download Report:<a href="https://reliefweb.int/sites/reliefweb.int/files/resources/UNICEF%20Ethiopia%20Humanitarian%20Situation%20Report%20-%20April-May%202020.pdf"> https://bit.ly/3h6rlNd</a></p>
<p>Situation Overview and Humanitarian Needs</p>
<p>Ethiopia’s humanitarian situation deteriorated further in April and May as a result of the countrywide spread of COVID19, the desert locust infestation and flooding in Southern and Eastern Ethiopia, as well as the continuing health emergencies, notably cholera and measles outbreaks.</p>
<p>In May alone, 470,000 people were affected by excessive rainfall that led to flooding. This resulted in 300,000 people being displaced with loss of lives and livelihoods in the Somali, Oromia, Afar, Southern Nations Nationalities and Peoples (SNNP) regions, Dire Dawa and Harari. The flood-related situation is particularly severe in Somali region: more than 79 per cent of the flood-affected and displaced people are located in Hudet and Mubarak woredas, Dawa Zone; in Dollo Ado and Bokolmanyo woredas and in Moyale and Kadaduma woredas. A National Flood Response Plan was shared in May 2020 with an estimated cost of US$ 30.7 million.</p>
<p>In April and May, 2,143 cholera cases and 24 deaths were reported in SNNP (1,875), Somali (234) and Oromia (34) regions. Since January, a total of 5,029 cholera cases and 68 related deaths were reported. In SNNP region, five zones and one special woreda reported cases. Dasenech woreda in South Omo reported 1,041 cases and 21 deaths, the highest in the region. The risk factors include poor access to health, unsafe water and poor hygiene and sanitation practices particularly in the remote pastoralist communities of South Omo zone. This area is subject to cholera outbreaks every year, but this year the number of cases and addressing the crisis has been exacerbated by the presence of covid19.</p>
<p>In April and May, 4,736 measles cases were reported, bringing the cumulative total from January to the last week of May to 22,000 measles, with 90 deaths. These figures are higher than the same period in 2018 and 20196 .</p>
<p>Distributed by APO Group on behalf of UNICEF Ethiopia.Media filesDownload logo</p>
<!-- AI CONTENT END 1 -->
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F&t=Coronavirus%3A+Ethiopia+Country+Office+%E2%80%93+Humanitarian+Situation+Report', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Coronavirus%3A+Ethiopia+Country+Office+%E2%80%93+Humanitarian+Situation+Report:&url=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F&media=https://kichuu.com/wp-content/uploads/2020/08/unnamed-e1597675623887.jpg&description=Coronavirus%3A+Ethiopia+Country+Office+%E2%80%93+Humanitarian+Situation+Report', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Coronavirus%3A%20Ethiopia%20Country%20Office%20%E2%80%93%20Humanitarian%20Situation%20Report&amp;body=https%3A%2F%2Fkichuu.com%2Fcoronavirus-ethiopia-country-office-humanitarian-situation-report%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
	</div><div id="custom_html-7" class="widget_text mh-widget mh-posts-2 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- kichuu20190303 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6953193962442323"
     data-ad-slot="3737122119"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://kichuu.com/itoophiyaa-humni-addaa-yaaddoomoo-wabii-nageenya-naannooleetii/" rel="prev"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/113959329_918800bb-7483-472a-b963-0780527ce209-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Humni addaa" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/113959329_918800bb-7483-472a-b963-0780527ce209-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/113959329_918800bb-7483-472a-b963-0780527ce209-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>Itoophiyaa: Humni addaa yaaddoomoo wabii nageenya naannooleetii?</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://kichuu.com/bb-obbo-jawar-mohammed-mana-hidhaa-keessatti-dhukkubsatan/" rel="next"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/117924277_751315022376425_6149466773122432485_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Jawar Mohammed" loading="lazy" /><span>Next</span><p>BB$: Obbo Jawar Mohammed mana hidhaa keessatti dhukkubsatan</p></a></div>
</nav>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/coronavirus-ethiopia-country-office-humanitarian-situation-report/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://kichuu.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='76744' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="257ea3136e" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="132"/></p></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Right Side</span></h4><div class="textwidget custom-html-widget"><script data-ad-client="ca-pub-6953193962442323" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></div></div><div id="mh_magazine_facebook_page-5" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Conect with us</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/kichuu.info/" data-width="320" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_social-3" class="mh-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-widget-container"><ul id="menu-social-widget" class="menu"><li id="menu-item-30396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30396"><a href="https://www.facebook.com/kichuu.info/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-30395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30395"><a href="https://twitter.com/kichuu24"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-30398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30398"><a href="https://www.youtube.com/channel/UCEkcqwtt4K_9czPpoElLetA"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Youtube</span></a></li>
<li id="menu-item-30397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-30397"><a href="https://www.instagram.com/kichuu5075/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>				</nav></div><div id="mh_magazine_custom_posts-26" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://kichuu.com/category/chronicles-page/" class="mh-widget-title-link">Odaa Post</a></span></h4>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-75195 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prosperity-partys-medemer-is-derived-from-american-prosperity-gospel/" title="Prosperity Party’s ‘Medemer’ is Derived from “American Prosperity Gospel”"><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/07/You-deserve-a-margarita-1080x675-1-326x245.png" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Prosperity Gospel" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/07/You-deserve-a-margarita-1080x675-1-326x245.png 326w, https://kichuu.com/wp-content/uploads/2020/07/You-deserve-a-margarita-1080x675-1-80x60.png 80w" data-sizes="(max-width: 326px) 100vw, 326px" />										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/prosperity-partys-medemer-is-derived-from-american-prosperity-gospel/" title="Prosperity Party’s ‘Medemer’ is Derived from “American Prosperity Gospel”">
												Prosperity Party’s ‘Medemer’ is Derived from “American Prosperity Gospel”											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/07/">July 24, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Prosperity Party’s ‘Medemer’ is Derived from “American Prosperity Gospel” It isn’t Homebased, It isn’t Synergy, It isn’t Indigenous. Worku Burayu (PhD), July 24, 2020 Summary: The lethal mistake of Ethiopia’s celebrated PM Abiy Ahmed has <a class="mh-excerpt-more" href="https://kichuu.com/prosperity-partys-medemer-is-derived-from-american-prosperity-gospel/" title="Prosperity Party’s ‘Medemer’ is Derived from “American Prosperity Gospel”">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-71565 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done"><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Ego Aside" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/06/say-oromia-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/06/say-oromia-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" />										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done">
												Putting Your Ego Aside and Getting the Job Done											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/06/">June 3, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Putting Your Ego Aside and Getting the Job Done (Avoid Making the Same Mistake Twice) By Worku Burayu (Ph.D), June 3, 2020 Summary: Let’s load our Gada package that consists of seeing things intelligently, listening <a class="mh-excerpt-more" href="https://kichuu.com/putting-your-ego-aside-and-getting-the-job-done/" title="Putting Your Ego Aside and Getting the Job Done">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-70935 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia"><img width="209" height="241" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20209%20241'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Prospect for Uniting or Dismantling Ethiopia" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/wbo-officers.jpg 209w, https://kichuu.com/wp-content/uploads/2020/05/wbo-officers-173x200.jpg 173w" data-sizes="(max-width: 209px) 100vw, 209px" />										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia">
												Prospect for Uniting or Dismantling Ethiopia											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 25, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Prospect for Uniting or Dismantling Ethiopia- “it is in our hand”-Oromo Liberation Army (OLA) By Worku Burayu (Ph.D.), May 25, 2020 Summary: “The remaining chance for united or dismantled Ethiopia falls on the hands of <a class="mh-excerpt-more" href="https://kichuu.com/prospect-for-uniting-or-dismantling-ethiopia/" title="Prospect for Uniting or Dismantling Ethiopia">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-70152 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion"><img width="326" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20245'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="crisis" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/05/abiydilemma-80x60.jpg 80w" data-sizes="(max-width: 326px) 100vw, 326px" />										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion">
												Ethiopia’s Dilemma and the Prime Minister’s Confusion											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/05/">May 10, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Ethiopia’s Dilemma and the Prime Minister’s Confusion By Guluma Gemeda, PhD, May 10, 2020  Prime Minister Abiy Ahmed’s statements on Ethiopia’s election postponement, apparent constitutional crisis and the future of democracy in Ethiopia are full <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-dilemma-and-the-prime-ministers-confusion/" title="Ethiopia’s Dilemma and the Prime Minister’s Confusion">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-69016 post type-post status-publish format-standard has-post-thumbnail category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia"><img width="325" height="217" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20325%20217'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2018/08/Olf-flag.gif" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Genocide" loading="lazy" />										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia">
												Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 14, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia By: Itana Gammada, April 14, 2020 A people under colonial occupation have a maximum of two choices, either stand up and fight for their freedom <a class="mh-excerpt-more" href="https://kichuu.com/oromiyaa-the-endless-colonial-conspiracy-and-genocide-wars-in-ethiopia/" title="Oromiyaa: The Endless Colonial Conspiracy and Genocide Wars in Ethiopia">[Read More]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-68078 post type-post status-publish format-standard has-post-thumbnail category-africa category-chronicles-page">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely"><img width="326" height="206" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20326%20206'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/04/close-326x206.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image lazy" alt="Abiy Ahmed" loading="lazy" />										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">
												Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/04/">April 1, 2020</a></span>
</div>
									</div>
									<div class="mh-excerpt">Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely (Our Struggle is Significantly Bigger than the Restoration of Internet/Phones Access) By Worku Burayu (PhD), April 1, 2020 Summary: Oromoo Sabakoo: Our struggle is <a class="mh-excerpt-more" href="https://kichuu.com/ethiopias-pm-abiy-ahmed-listen-carefully-give-attention-and-move-wisely/" title="Ethiopia’s PM Abiy Ahmed: Listen Carefully, Give Attention and Move Wisely">[Read More]</a></div>								</div>
							</div>
						</li>			</ul></div><div id="mh_magazine_custom_posts-24" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recent Posts</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76761 post type-post status-publish format-standard has-post-thumbnail category-health">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/pm-abiy-ahmed-health-is-a-basic-human-right/" title="#PM Abiy Ahmed: Health is a basic human right!">
										#PM Abiy Ahmed: Health is a basic human right!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76752 post type-post status-publish format-standard has-post-thumbnail category-world">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/freeoromia-freeoromoprisoners-oromoprotests/" title="#FreeOromia #FreeOromoPrisoners #OromoProtests">
										#FreeOromia #FreeOromoPrisoners #OromoProtests									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76747 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/bb-obbo-jawar-mohammed-mana-hidhaa-keessatti-dhukkubsatan/" title="BB$: Obbo Jawar Mohammed mana hidhaa keessatti dhukkubsatan">
										BB$: Obbo Jawar Mohammed mana hidhaa keessatti dhukkubsatan									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76744 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/coronavirus-ethiopia-country-office-humanitarian-situation-report/" title="Coronavirus: Ethiopia Country Office – Humanitarian Situation Report">
										Coronavirus: Ethiopia Country Office – Humanitarian Situation Report									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76741 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/itoophiyaa-humni-addaa-yaaddoomoo-wabii-nageenya-naannooleetii/" title="Itoophiyaa: Humni addaa yaaddoomoo wabii nageenya naannooleetii?">
										Itoophiyaa: Humni addaa yaaddoomoo wabii nageenya naannooleetii?									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76736 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/the-attack-on-oromo-nation-by-the-ethiopian-government-is-an-attack-on-all-historically-subjugated-nations-in-ethiopia/" title="The Attack On Oromo Nation By The Ethiopian Government Is An Attack On All Historically Subjugated Nations In Ethiopia!">
										The Attack On Oromo Nation By The Ethiopian Government Is An Attack On All Historically Subjugated Nations In Ethiopia!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76731 post type-post status-publish format-standard has-post-thumbnail category-news-afaan-oromoo">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/the-nobel-peace-prize-winner-abiy-ahmed-is-a-kingpin-of-violence-and-terror/" title="The Nobel peace prize winner( Abiy Ahmed) is a kingpin of violence and terror!">
										The Nobel peace prize winner( Abiy Ahmed) is a kingpin of violence and terror!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76727 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/odeeffannoo-dharaa-hd-abo-ilaalchisee-facaafamaa-jiru-irratti-ibsa-abo/" title="Odeeffannoo Dharaa HD ABO Ilaalchisee Facaafamaa Jiru Irratti Ibsa ABO">
										Odeeffannoo Dharaa HD ABO Ilaalchisee Facaafamaa Jiru Irratti Ibsa ABO									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76724 post type-post status-publish format-standard has-post-thumbnail category-amharic">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/kmn%e1%8c%89%e1%8b%b3%e1%8b%ab%e1%89%bd%e1%8a%95-%e1%8b%a8%e1%88%85%e1%8b%88%e1%88%93%e1%89%b5-%e1%88%b5%e1%88%ab-%e1%8a%a0%e1%88%b0%e1%8d%88%e1%8d%83%e1%88%9a-%e1%8a%a0%e1%89%a3%e1%88%8d-%e1%8a%a5/" title="KMN:#ጉዳያችን የህወሓት ስራ አሰፈፃሚ አባል እና የትግራይ ክልል አማካሪ ከሆኑት አቶ ጌታቸዉ ረዳ ጋር የተደረገ ዉይይት።">
										KMN:#ጉዳያችን የህወሓት ስራ አሰፈፃሚ አባል እና የትግራይ ክልል አማካሪ ከሆኑት አቶ ጌታቸዉ ረዳ ጋር የተደረገ ዉይይት።									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76717 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/breaking-namooti-bor-galmee-jawaarffaa-irratti-ragaa-bahan-hara-leenjii-osoo-fudhatanii-qeerroon-qabee-jira/" title="breaking! Namooti bor galmee Jawaarffaa irratti ragaa bahan har&#8217;a leenjii osoo fudhatanii qeerroon qabee jira.">
										breaking! Namooti bor galmee Jawaarffaa irratti ragaa bahan har&#8217;a leenjii osoo fudhatanii qeerroon qabee jira.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76713 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/we-all-know-that-oromia-pp-amhara-pp-will-never-work-together/" title="We all know that #Oromia PP &#038; #Amhara PP will never work together.">
										We all know that #Oromia PP &#038; #Amhara PP will never work together.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76710 post type-post status-publish format-standard has-post-thumbnail category-radio">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/odeefano-ijoo-fi-ibsa-adda-bilisummaa-oromoo-jaal-haraso-bahiqila-wajjiin-gone/" title="Odeefano ijoo fi Ibsa Adda Bilisummaa Oromoo Jaal haraso bahiqila wajjiin gone">
										Odeefano ijoo fi Ibsa Adda Bilisummaa Oromoo Jaal haraso bahiqila wajjiin gone									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76705 post type-post status-publish format-standard has-post-thumbnail category-amharic">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8b%8d%e1%88%be%e1%89%bd-%e1%8b%ad%e1%8c%ae%e1%88%83%e1%88%89-%e1%8d%a4-%e1%8c%8d%e1%88%98%e1%88%89%e1%88%9d-%e1%8b%ad%e1%8c%93%e1%8b%9b%e1%88%8d%e1%8a%a2%e1%89%b5%e1%8b%ae-360-%e1%8a%a5/" title="&#8220;ውሾች ይጮሃሉ ፤ ግመሉም ይጓዛል&#8221;ኢትዮ 360 እና ኢሳት የሚባሉ የፅንፈኛ አህዳዉያን ሚዲያዎች">
										&#8220;ውሾች ይጮሃሉ ፤ ግመሉም ይጓዛል&#8221;ኢትዮ 360 እና ኢሳት የሚባሉ የፅንፈኛ አህዳዉያን ሚዲያዎች									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76697 post type-post status-publish format-standard has-post-thumbnail category-musics">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/bilisummaa-taddasaa-malummaaf-calstuu-ethiopian-oromoo-music/" title="Bilisummaa Taddasaa &#8211; Malummaaf calstuu &#8211; Ethiopian Oromoo music">
										Bilisummaa Taddasaa &#8211; Malummaaf calstuu &#8211; Ethiopian Oromoo music									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76694 post type-post status-publish format-standard has-post-thumbnail category-amharic">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/%e1%8b%a8%e1%8a%a0%e1%8c%88%e1%8b%8d-%e1%88%85%e1%8b%9d%e1%89%a5-%e1%8b%a8%e1%8a%ad%e1%88%8d%e1%88%8d%e1%8a%90%e1%89%b5-%e1%8c%a5%e1%8b%ab%e1%89%84%e2%80%bc%ef%b8%8f/" title="የአገው ህዝብ የክልልነት ጥያቄ‼️">
										የአገው ህዝብ የክልልነት ጥያቄ‼️									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76688 post type-post status-publish format-standard has-post-thumbnail category-videos">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/while-pp-is-losing-its-support-all-over-the-country-in-somali-region-onlf-seems-to-be-winining/" title="While #PP is losing it&#8217;s support all over the country, in #Somali region, #ONLF seems to be winining">
										While #PP is losing it&#8217;s support all over the country, in #Somali region, #ONLF seems to be winining									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76682 post type-post status-publish format-standard has-post-thumbnail category-tv">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/oromia-waamicha-qabsoo-marsaa-3ffaa-qeerroo-irraa-kenname/" title="Oromia: Waamicha Qabsoo Marsaa 3ffaa Qeerroo irraa kenname">
										Oromia: Waamicha Qabsoo Marsaa 3ffaa Qeerroo irraa kenname									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76679 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/dr-tsegaye-ararssa-a-dangerous-proposition/" title="#Dr.Tsegaye Ararssa:  A Dangerous Proposition">
										#Dr.Tsegaye Ararssa:  A Dangerous Proposition									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76670 post type-post status-publish format-standard has-post-thumbnail category-tv">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/omn-yaada-ummataa-fi-haala-yeroo-hag-15-2020/" title="OMN: Yaada ummataa fi Haala Yeroo (Hag 15, 2020)">
										OMN: Yaada ummataa fi Haala Yeroo (Hag 15, 2020)									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 15, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76667 post type-post status-publish format-standard has-post-thumbnail category-africa">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-under-pm-abiy-a-failed-state-in-the-lurking-2/" title="Ethiopia under PM Abiy: a Failed State in the lurking">
										Ethiopia under PM Abiy: a Failed State in the lurking									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 15, 2020</a></span>
</div>
							</div>
						</li>			</ul></div><div id="archives-2" class="mh-widget widget_archive"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archives by Month</span></h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives by Month</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://kichuu.com/2020/08/'> August 2020 </option>
	<option value='https://kichuu.com/2020/07/'> July 2020 </option>
	<option value='https://kichuu.com/2020/06/'> June 2020 </option>
	<option value='https://kichuu.com/2020/05/'> May 2020 </option>
	<option value='https://kichuu.com/2020/04/'> April 2020 </option>
	<option value='https://kichuu.com/2020/03/'> March 2020 </option>
	<option value='https://kichuu.com/2020/02/'> February 2020 </option>
	<option value='https://kichuu.com/2020/01/'> January 2020 </option>
	<option value='https://kichuu.com/2019/12/'> December 2019 </option>
	<option value='https://kichuu.com/2019/11/'> November 2019 </option>
	<option value='https://kichuu.com/2019/10/'> October 2019 </option>
	<option value='https://kichuu.com/2019/09/'> September 2019 </option>
	<option value='https://kichuu.com/2019/08/'> August 2019 </option>
	<option value='https://kichuu.com/2019/07/'> July 2019 </option>
	<option value='https://kichuu.com/2019/06/'> June 2019 </option>
	<option value='https://kichuu.com/2019/05/'> May 2019 </option>
	<option value='https://kichuu.com/2019/04/'> April 2019 </option>
	<option value='https://kichuu.com/2019/03/'> March 2019 </option>
	<option value='https://kichuu.com/2019/02/'> February 2019 </option>
	<option value='https://kichuu.com/2019/01/'> January 2019 </option>
	<option value='https://kichuu.com/2018/12/'> December 2018 </option>
	<option value='https://kichuu.com/2018/11/'> November 2018 </option>
	<option value='https://kichuu.com/2018/10/'> October 2018 </option>
	<option value='https://kichuu.com/2018/09/'> September 2018 </option>
	<option value='https://kichuu.com/2018/08/'> August 2018 </option>
	<option value='https://kichuu.com/2018/07/'> July 2018 </option>
	<option value='https://kichuu.com/2018/06/'> June 2018 </option>
	<option value='https://kichuu.com/2018/05/'> May 2018 </option>
	<option value='https://kichuu.com/2018/04/'> April 2018 </option>
	<option value='https://kichuu.com/2018/03/'> March 2018 </option>
	<option value='https://kichuu.com/2018/02/'> February 2018 </option>
	<option value='https://kichuu.com/2018/01/'> January 2018 </option>
	<option value='https://kichuu.com/2017/12/'> December 2017 </option>
	<option value='https://kichuu.com/2017/11/'> November 2017 </option>
	<option value='https://kichuu.com/2017/10/'> October 2017 </option>
	<option value='https://kichuu.com/2017/09/'> September 2017 </option>
	<option value='https://kichuu.com/2017/08/'> August 2017 </option>
	<option value='https://kichuu.com/2017/07/'> July 2017 </option>
	<option value='https://kichuu.com/2017/06/'> June 2017 </option>
	<option value='https://kichuu.com/2017/05/'> May 2017 </option>
	<option value='https://kichuu.com/2017/04/'> April 2017 </option>
	<option value='https://kichuu.com/2017/03/'> March 2017 </option>
	<option value='https://kichuu.com/2017/02/'> February 2017 </option>
	<option value='https://kichuu.com/2017/01/'> January 2017 </option>
	<option value='https://kichuu.com/2016/12/'> December 2016 </option>
	<option value='https://kichuu.com/2016/11/'> November 2016 </option>
	<option value='https://kichuu.com/2013/11/'> November 2013 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><i class="fa fa-youtube-play"></i>OROMO GENERATION</span></h4>			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/BUVIbxJxZM4?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=2&amp;rel=1" allowfullscreen></iframe>
        		</div>
			</div></div><div id="calendar-2" class="mh-widget widget_calendar"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Archive in Calendar</span></h4><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>August 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="5" class="pad">&nbsp;</td><td><a href="https://kichuu.com/2020/08/01/" aria-label="Posts published on August 1, 2020">1</a></td><td><a href="https://kichuu.com/2020/08/02/" aria-label="Posts published on August 2, 2020">2</a></td>
	</tr>
	<tr>
		<td><a href="https://kichuu.com/2020/08/03/" aria-label="Posts published on August 3, 2020">3</a></td><td><a href="https://kichuu.com/2020/08/04/" aria-label="Posts published on August 4, 2020">4</a></td><td><a href="https://kichuu.com/2020/08/05/" aria-label="Posts published on August 5, 2020">5</a></td><td><a href="https://kichuu.com/2020/08/06/" aria-label="Posts published on August 6, 2020">6</a></td><td><a href="https://kichuu.com/2020/08/07/" aria-label="Posts published on August 7, 2020">7</a></td><td><a href="https://kichuu.com/2020/08/08/" aria-label="Posts published on August 8, 2020">8</a></td><td><a href="https://kichuu.com/2020/08/09/" aria-label="Posts published on August 9, 2020">9</a></td>
	</tr>
	<tr>
		<td><a href="https://kichuu.com/2020/08/10/" aria-label="Posts published on August 10, 2020">10</a></td><td><a href="https://kichuu.com/2020/08/11/" aria-label="Posts published on August 11, 2020">11</a></td><td><a href="https://kichuu.com/2020/08/12/" aria-label="Posts published on August 12, 2020">12</a></td><td><a href="https://kichuu.com/2020/08/13/" aria-label="Posts published on August 13, 2020">13</a></td><td><a href="https://kichuu.com/2020/08/14/" aria-label="Posts published on August 14, 2020">14</a></td><td><a href="https://kichuu.com/2020/08/15/" aria-label="Posts published on August 15, 2020">15</a></td><td><a href="https://kichuu.com/2020/08/16/" aria-label="Posts published on August 16, 2020">16</a></td>
	</tr>
	<tr>
		<td id="today"><a href="https://kichuu.com/2020/08/17/" aria-label="Posts published on August 17, 2020">17</a></td><td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td>
	</tr>
	<tr>
		<td>24</td><td>25</td><td>26</td><td>27</td><td>28</td><td>29</td><td>30</td>
	</tr>
	<tr>
		<td>31</td>
		<td class="pad" colspan="6">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://kichuu.com/2020/07/">&laquo; Jul</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="mh_magazine_custom_posts-16" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/health/" class="mh-widget-title-link">Health</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76761 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/pm-abiy-ahmed-health-is-a-basic-human-right/" title="#PM Abiy Ahmed: Health is a basic human right!"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/117943431_10221940863622425_2389593537895809335_n-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Health" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/117943431_10221940863622425_2389593537895809335_n-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/117943431_10221940863622425_2389593537895809335_n-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/pm-abiy-ahmed-health-is-a-basic-human-right/" title="#PM Abiy Ahmed: Health is a basic human right!">
										#PM Abiy Ahmed: Health is a basic human right!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 17, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76542 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/6789-people-infected-with-cholera-in-ethiopia-un/" title="6,789 people infected with cholera in Ethiopia: UN"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/child-cholera-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Cholera" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/child-cholera-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/child-cholera-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/08/child-cholera-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/6789-people-infected-with-cholera-in-ethiopia-un/" title="6,789 people infected with cholera in Ethiopia: UN">
										6,789 people infected with cholera in Ethiopia: UN									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 14, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76369 post type-post status-publish format-standard has-post-thumbnail category-health">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/covid-in-ethiopia-from-a-slow-start-to-serious-socio-economic-impacts/" title="COVID in Ethiopia: from a slow start to serious socio-economic impacts"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/watering-girl-1-copy-637326707219653561-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Socio-economic impacts" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/watering-girl-1-copy-637326707219653561-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/watering-girl-1-copy-637326707219653561-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/covid-in-ethiopia-from-a-slow-start-to-serious-socio-economic-impacts/" title="COVID in Ethiopia: from a slow start to serious socio-economic impacts">
										COVID in Ethiopia: from a slow start to serious socio-economic impacts									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 11, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="mh_magazine_custom_posts-12" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/fun-videos/" class="mh-widget-title-link">Fun Videos</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-75646 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/isaias-isaiah-to-hit-america/" title="Isaias (Isaiah) to Hit America!"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Isaias" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/116815866_1346726828853241_1762356899848592848_o-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/isaias-isaiah-to-hit-america/" title="Isaias (Isaiah) to Hit America!">
										Isaias (Isaiah) to Hit America!									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 1, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-54179 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Mohammed Hajjii" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/we-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2019/07/we-250x188.jpg 250w, https://kichuu.com/wp-content/uploads/2019/07/we-768x576.jpg 768w, https://kichuu.com/wp-content/uploads/2019/07/we-533x400.jpg 533w, https://kichuu.com/wp-content/uploads/2019/07/we-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2019/07/we-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2019/07/we-e1564169436269.jpg 650w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/funyee-show-mohammed-hajjii-dargaggeessa-hojjaa-gabaabaafi-hojjataa-waajjira-say-fitek-oromiyaa/" title="Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa">
										Funyee Show : Mohammed Hajjii Dargaggeessa Hojjaa Gabaabaafi Hojjataa Waajjira Say.fiTek.Oromiyaa									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 26, 2019</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-53719 post type-post status-publish format-standard has-post-thumbnail category-fun-videos">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-80x60.png 80w, https://kichuu.com/wp-content/uploads/2019/07/Untitled-2-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/smiling-is-the-best-way-to-face-every-problem-to-crush-every-fear-and-to-hide-every-pain/" title="“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”">
										“Smiling is the best way to face every problem, to crush every fear and to hide every pain.”									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2019/07/">July 16, 2019</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="mh_magazine_custom_posts-13" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/musics/" class="mh-widget-title-link">Musics</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76697 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/bilisummaa-taddasaa-malummaaf-calstuu-ethiopian-oromoo-music/" title="Bilisummaa Taddasaa &#8211; Malummaaf calstuu &#8211; Ethiopian Oromoo music"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/qeerroo-1-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Bilisummaa Taddasaa" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/qeerroo-1-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/08/qeerroo-1-678x509.png 678w, https://kichuu.com/wp-content/uploads/2020/08/qeerroo-1-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/bilisummaa-taddasaa-malummaaf-calstuu-ethiopian-oromoo-music/" title="Bilisummaa Taddasaa &#8211; Malummaaf calstuu &#8211; Ethiopian Oromoo music">
										Bilisummaa Taddasaa &#8211; Malummaaf calstuu &#8211; Ethiopian Oromoo music									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 16, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76528 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/jafar-yusuf-of-qopheessi-new-oromo-music-2020/" title="Jafar Yusuf &#8211; Of Qopheessi &#8211; New Oromo Music 2020"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/yes-1-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Jafar Yusuf" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/yes-1-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/08/yes-1-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/jafar-yusuf-of-qopheessi-new-oromo-music-2020/" title="Jafar Yusuf &#8211; Of Qopheessi &#8211; New Oromo Music 2020">
										Jafar Yusuf &#8211; Of Qopheessi &#8211; New Oromo Music 2020									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 14, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76354 post type-post status-publish format-standard has-post-thumbnail category-musics">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/jamiil-abduu-dhugaa-qabdu-new-oromo-music-2020/" title="Jamiil Abduu DHUGAA QABDU New Oromo Music 2020."><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-250x187.jpg 250w, https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-534x400.jpg 534w, https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-768x575.jpg 768w, https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-326x245.jpg 326w, https://kichuu.com/wp-content/uploads/2020/08/pizap-4-2-e1597148575984.jpg 700w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/jamiil-abduu-dhugaa-qabdu-new-oromo-music-2020/" title="Jamiil Abduu DHUGAA QABDU New Oromo Music 2020.">
										Jamiil Abduu DHUGAA QABDU New Oromo Music 2020.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 11, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_custom_posts-14" class="mh-footer-widget mh_magazine_custom_posts"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner"><a href="https://kichuu.com/category/business/" class="mh-widget-title-link">Business</a></span></h6>			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76474 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/kenya-rejects-ethiopian-airlines-plan-on-cargo/" title="Kenya rejects Ethiopian Airlines plan on cargo"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/et-cargo-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="Ethiopian Airlines" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/et-cargo-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/et-cargo-678x509.jpg 678w, https://kichuu.com/wp-content/uploads/2020/08/et-cargo-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/kenya-rejects-ethiopian-airlines-plan-on-cargo/" title="Kenya rejects Ethiopian Airlines plan on cargo">
										Kenya rejects Ethiopian Airlines plan on cargo									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 12, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76328 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopias-move-to-bar-foreign-telcos-slows-liberalisation/" title="Ethiopia’s move to bar foreign telcos slows liberalisation"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/mobile-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="liberalisation" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/mobile-80x60.jpg 80w, https://kichuu.com/wp-content/uploads/2020/08/mobile-326x245.jpg 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopias-move-to-bar-foreign-telcos-slows-liberalisation/" title="Ethiopia’s move to bar foreign telcos slows liberalisation">
										Ethiopia’s move to bar foreign telcos slows liberalisation									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 10, 2020</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-76319 post type-post status-publish format-standard has-post-thumbnail category-business">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://kichuu.com/ethiopia-protests-threaten-to-derail-abiys-reforms/" title="Ethiopia protests threaten to derail Abiy’s reforms"><img width="80" height="60" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2060'%3E%3C/svg%3E" data-src="https://kichuu.com/wp-content/uploads/2020/08/Oromo-demonstrators-protest-the-death-of-musician-and-activist-Hachalu-Hundessa-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image lazy" alt="" loading="lazy" data-srcset="https://kichuu.com/wp-content/uploads/2020/08/Oromo-demonstrators-protest-the-death-of-musician-and-activist-Hachalu-Hundessa-80x60.png 80w, https://kichuu.com/wp-content/uploads/2020/08/Oromo-demonstrators-protest-the-death-of-musician-and-activist-Hachalu-Hundessa-678x509.png 678w, https://kichuu.com/wp-content/uploads/2020/08/Oromo-demonstrators-protest-the-death-of-musician-and-activist-Hachalu-Hundessa-326x245.png 326w" data-sizes="(max-width: 80px) 100vw, 80px" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://kichuu.com/ethiopia-protests-threaten-to-derail-abiys-reforms/" title="Ethiopia protests threaten to derail Abiy’s reforms">
										Ethiopia protests threaten to derail Abiy’s reforms									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://kichuu.com/2020/08/">August 10, 2020</a></span>
</div>
							</div>
						</li>			</ul></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-48174"><a href="https://kichuu.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-140"><a href="https://kichuu.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-162"><a href="https://kichuu.com/category/news/africa/">Africa</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://kichuu.com/category/news/world/">World</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18343"><a href="https://kichuu.com/category/afaan-oromoo/">Afaan Oromoo</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18358"><a href="https://kichuu.com/category/afaan-oromoo/news-afaan-oromoo/">News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18359"><a href="https://kichuu.com/category/afaan-oromoo/radio/">Radio</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18360"><a href="https://kichuu.com/category/afaan-oromoo/tv/">TV</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18362"><a href="https://kichuu.com/category/afaan-oromoo/videos/">Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18351"><a href="https://kichuu.com/category/amharic/">Amharic</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-18"><a href="https://kichuu.com/category/women/">Women</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://kichuu.com/category/women/oromo/">Oromo</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232"><a href="https://kichuu.com/category/women/other-women/">Other women</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://kichuu.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764"><a href="https://kichuu.com/category/musics/">Musics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-350"><a href="https://kichuu.com/category/sports/">Sports</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			Copyright @2016 kichuu.com              		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-58166095-1', 'auto');
  ga('send', 'pageview');

</script>			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> <script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/kichuu.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>



<script src="https://kichuu.com/wp-content/cache/minify/c50e7.js"></script>

<script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src="https://kichuu.com/wp-content/cache/minify/1615d.js"></script>
</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 
Lazy Loading
Minified using disk
Database Caching 119/147 queries in 1.117 seconds using disk

Served from: kichuu.com @ 2020-08-17 12:31:00 by W3 Total Cache
-->